Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla Pre-Release 3

MarkMark Vanilla Staff
edited July 2006 in Vanilla 1.0 Help
A big thank you to rockwaldo && corn13read for discovering a big problem with the upgrader on Windows. The long and short of it is that MySQL on Windows doesn't handle case sensitivity of table names properly. It caused any queries in the upgrader to fail because I'd use LUM_TableName but on windows it should have been lum_tablename. I've made the upgrader case insensitive, and that should rectify the problem. So, without any further ado, here is the third version of the Vanilla 1 pre-release: Rockwaldo, if you want to download that and give it a shot, it would be much appreciated if you could confirm that it works properly.


  • Awesome.
    This is the exact problem I was having the other day.

  • Hi, upgraded to pre-release fine. I added some add-ons, fine. I can't get the yellow fade to work though. It was OK on the 0.9 version. Is it me?
  • edited June 2006
    I am beginning to think that I'm seeing things... Or not. lol I for some reason can't figure out how to save my extension selection... Is there supposed to be a save button? TIA AH I figured it out! Firefox doesn't work when enabling extensions...
  • Hi. I notice that in the 0.9 there was a bunch of preinstalled extensions that are not there. I can't find them in the Add-ons section either. Is there another location? Or can I still use them on this new version? Thanks
  • lechlech Chicagoland
    As mentioned before and from now on, Vanilla will be served as-is in a "vanilla format". You snag and stack the extensions yourself from the add-ons page. This is also meant to keep things a little more simple in terms of finding bugs.
  • Fair enough but I can't find the 'whisper' extension in Add-ons. Should I just use the one from the 0.9 version?
  • If you cant find an extension in the addons repository it doesnt yet officially work with v1 and it'l be making its way there very shortly (probably after v1 is properly released, though). Whispers arent an extension anymore though, you just need to go into your appg/settings.php file and change: $Configuration['ENABLE_WHISPERS'] = '0'; to: $Configuration['ENABLE_WHISPERS'] = '1'; Or ideally add that second line to your conf/settings.php file and that should turn them on for you.
  • That worked a treat! Thanks. Any idea why the yellow fade isn't working in the new version? I have the extension (yellow.php in my case) in the extensions folder and YellowFade.js in the js folder. But no luck :-(
  • Yellow fade doesn't work.

    @ corn13read: check the permissions of conf/ and of the folders in extensions/
  • That's funny 'cause I could have sworn it worked on my last version and when I post something here it also works. Maybe my eyes are going ....
  • Sorry I thought that I read something about it, and hadn't bother installed it, and hadn't realized there was something missing on my forum.
    I just installed, it seems to work find. lol thank you.
  • That's good. What version have you got?
  • version 1 pre3 fresh installed.
    Do you have access to your logs? what say access_log?
  • Possibly, where might I find them? My version is an upgrade rather than a fresh install.
  • do you have shell access? You can find the location of access_log in /etc/httpd/conf/httpd.conf (look for the directive CustomLog), are can use, on linux, "locate access_log"
  • AH, no shell access. Hmmm Maybe I'll go for a fresh install....
  • edited June 2006
    do you have something like awstats? awstats list all the 404 error message.
  • Where did you get the Yellow Fade extension? Mine is from the svn.
  • OOOHHHH! A fresh install, 6 extensions no problem but yellow fade still not working :-( How hard can it be? Any chance of a link to one that works?
This discussion has been closed.