Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla Pre-Release 3



  • Looking at the Addons site it would appear there's not a download yet for the yellowfade. I think Mark has more important things on his mind than that right now.
  • idiot question:

    what is the proper procedure for updating to pre3?
  • deeldeel New
    edited June 2006
    nvmd just found the (old) documentation.
  • upgraded nicely.
  • Yeah, thanks giginger. I was rather hoping Dinoboff was going to tell me where he got his from. Hats off to Mark, no question.
  • I got it from the svn server of vanilla, but the extensions are not there anymore.

    more info about svn
    export revision 472 to get the extensions
  • MarkMark Vanilla Staff
    edited June 2006
    most of those extensions in old svn don't work (another reason why they've been removed from the repos) - I wouldn't get them if I were you. just wait until they're available in the addon's site.

    Firefox doesn't work when enabling extensions...

    1.5 does. It's been tested in all browsers on all OSes. What version and OS are you on?

    Fair enough but I can't find the 'whisper' extension in Add-ons. Should I just use the one from the 0.9 version?

    Go to settings > application settings and there is a checkbox on that form to enable or disable whispers.
  • MarkMark Vanilla Staff
    Regarding yellowfade - I really wish the author would update it and upload it to the addons directory, but I can't make him do it...

    Here is the code that goes in extensions/YellowFade/default.php:

    <?php /* Extension Name: YellowFade Effect Extension Url: Description: Adds the YellowFade effect on some stuff. Version: 0.1 Author: Michael Raichelson Author Url: */ if (in_array($Context->SelfUrl, array("index.php", "categories.php", "comments.php", "search.php", "post.php", "account.php", "settings.php"))){ $Head->AddScript('extensions/YellowFade/functions.js'); } ?>

    Then make sure you've got the js file that goes along with it:

  • Thank heavens! The horse's mouth! It works perfectly! The thing is the last yellowfade php worked when put straight into extensions. Having created the folder 'yellowfade' and renamed the file 'default' (as suggested) all is well. Many thanks. Over and out.
  • blizeHblizeH ✭✭
    Yellowfade! Thank you mark, I've been after this for ages <3
  • Mark:

    Good stuff getting this sorted - just installed the new version and it works a treat...:)
  • I've done as explained above regarding "yellowfade" but i cant see it in the extensions menu?

    I have a folder in the extentions directory called "yellowfade" which contains the file default.php as above and the js file as above.

    What do i need to do next?
  • Ok, it was the whole linebreaks problem.

    creating the default.php file from scratch in notepad and it didnt work.

    bastardising an existing default.php file (i.e using their linebreaks) - it worked a treat.

  • Hello! I decided I wanted to make a clean install of Vanilla 1.pre3, but I wan into some problems. I am using Windows, and Apache (as part of XAMPP). First of all, the XAMPP package doesn't seem to have mod_rewite included, so I got a 500 error before I had even started. Removing the .htaccess file fixed that. After that I could install Vanilla. All tables (and their contents) seem to have been created alright, but I can't log in once the installation is complete. I did a little search and saw that there still were a few places in the code where it said "LUM_" (uppercase), but I don't know if that might be a cause. For instance here in appg/database.php it says: $DatabaseTables['User'] = 'LUM_User'; (I tried changing just that value to lowercase, but that didn't help any). Any suggestions would be welcome.
  • edited June 2006
    For mod_rewrite, check httpd.conf. Mod_rewrite is not enable by default. If it available with xampp, you just need to uncomment a line in httpd.conf. You it is not available with xampp- what would be strange, you can switch to EasyPhp.
  • blizeHblizeH ✭✭
    edited June 2006
    I've got ...


    Yet for some reason it isn't showing up in the extensions part of the site, nggh.

    I've absolutely no idea why, but it seems lately like no matter what I try and do with Vanilla it goes horribly wrong, I'm jinxed! :(

    // it's okay, I've got it working via the conf/extensions.php, it's still not showing in the actual Extensions list but it works and I've no intention of disabling it, so this'll do just fine :D
  • Oh, you were right Dinoboff, I just had to enable mod_rewrite. Still, the sign-in problem remains.
  • MarkMark Vanilla Staff
    @bjrn: What error does it give you when you try to log in?

    You can open up your mysql database using whatever program you use and change your user's account to a plain text password of your choice. Then to try to log in with that password. Once signed in, go change your password in the account area and sign back out. If you try to sign in and it fails again, I bet it's a mysql problem.
  • Oh, sorry, I forgot to add that. It doesn't complain about the wrong password, but says "The requested user could not be found.".
  • MarkMark Vanilla Staff
    Open up your db and see if that user has been created or not...
This discussion has been closed.