Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

What do I do? CSS and WP Theme issues*

jens1seojens1seo
edited November 2013 in Vanilla 2.0 - 2.8

Hi all
I am slow as a snail when it comes to CSS so I hired a so called experienced theme developer to create a theme for my WordPress forum. Without looking at the creative brief I sent him, he installed the Vanilla imbed plugin over a fully installed version of vanilla running a separate DB. After removing the plugin the he themed the site and the navigation does not work. he claims it had nothing to do with him and that is a separate job to fix. WTF? Ya right! Does anyone know what I need to do to get my forum navigation working again? Do I reinstall the forum? Will my theme get ruined?

«1

Comments

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    @jens1seo

    I'm assuming your developer created a custom theme, in themes folder.

    I would suggest setting up a new instance of Vanilla (either on your host, or local) and make sure it is running as you expect.

    Then add in the theme your developer created.

    If you have the same issues, you have clear evidence that your developer has not done the job properly.

    If you don't, then you are good to go!

    hgtonightUnderDog
  • TamaTama United Kingdom ✭✭✭

    I'd speak to your designer about the fact they are editing style.css in the dashboard application, instead of creating a custom theme. This means with a vanilla update your style changes will be overwritten. I remember creating a port of the theme for free, but I had to dash to finalize a project in my own community. So if you want to contact me via email again I'll see if I can help you with getting the port to work :).

    The embed plugin while good, does become annoying once your forum gets too big. This is why ports of your site's main theme are often a better idea than just embedding the theme.

    hgtonightUnderDog
  • whu606: So if I understand you correct, you are saying basically set up a test server and make the dev work on the test server so I have a comparison between sites/files? He is working directly in the theme file. I cant seem to find a new theme folder, I'll ask him. speaking of which the theme file is filled with a bunch of bullshit that should not be there.
    Tama The theme you showed me was exactly what I wanted. I loved it. But could not get it to display properly when I uploaded the theme file. I am running a separate instance Vanilla on its own DB/URL I know it looks better and will function if the forum grows. Yes I would love you to come back and do this project I'd rather pay you than have some guy who does not know what hes doing screw up my forum...

    UnderDog
  • Tama: He did not edit my theme in the dashboard I would have fired him. Any idiot can do that. He installed vanilla imbed for WP without reading my theme instructions or looking to see what was or was not installed. I still do not see a theme file in the folder and he has indeed CSS the page. Do you mean to say that he hacked the core CSS?? Because the Vanilla Navigation does not work im getting this error
    "Something has gone wrong.
    We've run into a problem and are unable to handle this request right now.
    Please check back in a little while." On all forum pages

    UnderDog
  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    @jens1seo

    It sounds like your developer has not done the expected thing, which would be to create a new theme, and make changes in the custom.css and default.master files in there.

    Which suggests your developer hasn't got a proper clue about how to customise Vanilla.

    The suggestion I made was to try to clarify if the changes your dev made were responsible for the errors or not.

    If they repeat their changes on a clean install, not embedded, that should give you a good idea.

    hgtonightUnderDog
  • Ok Im doing a clean re-install. I'll update you how it goes.

    UnderDog
  • hbfhbf wiki guy? MVP

    you asked for a developer here, got some responses from the site, then hired a developer from somewhere else and they botched something so now you are back here asking for free help?

    WTF.

    UnderDog
  • @hbf she hired a wordpress themer, I don't think she expect him to theme the forum, I don' think she is asking for free work.

    grep is your friend.

    UnderDog[Deleted User]
  • HBF>>>no one was available for hire. Tama gave me help for free but had a lot of other work to do.

    UnderDog
  • jens1seojens1seo
    edited November 2013

    Tama No I paid this guy and I paid at a normal developers rate. Im not asking for something for nothing. But if I pay someone and he tells me he knows how to theme and then installs a plugin I did not ask for and then the 2x themes the core file>>>would you be a little concerned??

    UnderDog
  • OK I did a fresh re-installed 2 things are now happening. #1 the new installation screen does not come up and #2 it looks like he also customized my already custom WordPress theme template, because it now has a custom sidebar on the WP theme template on the vanilla forum page that I dont want. Great!

  • hbfhbf wiki guy? MVP

    @jens1seo said:
    Tama No I paid this guy and I paid at a normal developers rate. Im not asking for something for nothing. But if I pay someone and he tells me he knows how to theme and then installs a plugin I did not ask for and then the 2x themes the core file>>>would you be a little concerned??

    Would I be concerned, yes. Take up the issue with the developer. Get your money back and offer it to someone to fix it. You are asking for something for nothing, you are aking for advice on how to trouble shoot and fix issues with paid work.

    There would be no issue had you made the mess yourself. I'd be happy to help you trouble shoot the jam, but you paid someone to get you in this mess, make them deal with it - otherwise there is no consequence to them for their shoddy work.

    As for no one having time, I explicitly asked for some details or specifications for the work requested. You provided none. There are plenty of people that could have done the wordpress integration around here.

    Live and learn.

    [Deleted User]
  • hgtonighthgtonight ∞ · New Moderator

    Garden won't ask you to configure it if $Configuration['Garden']['Installed'] = TRUE; is in your config file.

    Try removing that and try again.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    UnderDog
  • HBF: What are you talking about? I provided full details and e-mail addresss to discuss this in private (and got scraped by a dating service in the process) and I posted a screen shot. I wish I had the funds to pay Vanilla to do it but this is a start up blog and its not earning any revenue for me to pay for their service right now. I plan on it in the near future. When it comes to Vanilla this community is the only community I trust. As I just learned those other guys dont know what the F they are doing. As for my original question, it was about "should I do a e-install." Your damn right I trust when they say yes do it.

    UnderDog
  • HG: can I set it to =false or just delete the whole line?

  • @jens1seo I'm sorry this happened to you. Let's keep 2 discussions for you :

    [☆] this one (how to deal with your CSS developer)

    [☆] a new discussion, after you made your local install and set up your WP and theme

    So now you can test out those things that are suggested.

    Your situation is not horrible yet, so it can be solved with the help of the community.

    Since it's a startup blog and you (hopefully) have a backup of the theme your developer made, reinstall would be ok.

    If you can post your WordPress and Vanilla versions the community can help you reproduce your situation (except for your custom theme of course).

    After that please let us know what you would like to achieve. Blog, Forum, just comment system for the blog?

    And maybe the Url of the website or just PM it to some of us, so we can check there once in a while.

    hgtonight
  • @hgtonight said:
    Garden won't ask you to configure it if $Configuration['Garden']['Installed'] = TRUE; is in your config file.

    Try removing that and try again.

    Worked like a charm. Thanks re-install complete

    UnderDog
  • jens1seojens1seo
    edited November 2013

    @UnderDog said:
    Let's keep 2 discussions for you :

    [☆] this one (how to deal with your CSS developer)

    [☆] a new discussion, after you made your local install and set up your WP and theme>


    I welcome an open discussion on how to deal with a CSS developer or at least how to hire one. Thanks for the post

  • Hi Guys: Just an update on the outcome from my developer I hired. When I asked what files he themed this was his reply

    "
    this is path for css
    vanilla/applications/dashboard/design/style.css
    and theme files is
    vanilla/applications/dashboard/modules/class.headmodule.php"

    My question to the community is Will I run into a major train wreck if the dev I hired themed these files?? He finished the theme editing these files. Your opinions please

    UnderDog
  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    The biggest weakness with this 'solution' imo, is that the files will be overwritten if you update to a newer version of Vanilla (which you will almost certainly want to do in the future.)

    This is why there is a constant refrain on here of 'don't modify the core'.

    UnderDog
Sign In or Register to comment.