Please upgrade here. These earlier versions are no longer being updated and have security issues.

Bonk error with Smarty, do I need to create templates_c directory?*

This discussion is related to the Leaf addon.
shashashasha New
edited November 2013 in Vanilla 2.0 - 2.8

I am getting this error : Something funky happened. Please bear with us while we iron out the kinks

I am on Version 2.0.18.8

Comments

  • hgtonighthgtonight ∞ · New Moderator
    edited November 2013

    What is the actual error?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • in case he doesn't realize you provided a link, because light blue is so hard to distiguish it is a clickable link.

    I have posted an obvious link

    http://vanillaforums.org/docs/errors

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    EathuisUnderDog
  • shashashasha New
    edited November 2013

    The error occurred on or near: /library/vendors/Smarty-2.6.25/libs/Smarty.class.php

    1109: * @param integer $error_type

    1110: */

    1111: function trigger_error($error_msg, $error_type = E_USER_WARNING)

    1112: {

    1113: trigger_error("Smarty error: $error_msg", $error_type);

    1114: }

    1115:

    1116:

    1117: /**

    Please let me know what change I have to make?

  • peregrineperegrine MVP
    edited November 2013

    Several things - @jeongwee probably never tested it on 2.0.18.8

    The theme should have a requirement of vanilla 2.1


    for 2.0.18.8 - to get rid of errors

    two things:

    in Leaf/views/default.master.tpl

    there is no such thing as a categories_link in 2.0.18.8

    you can do one of two things

    change line 16 from

    {categories_link}

    to
    {category_link}

    OR

    create a function.categories_link.php

    and place it in library/vendors/SmartyPlugins

    <br /><?php if (!defined('APPLICATION')) exit();
    /*
    Copyright 2008, 2009 Vanilla Forums Inc.
    This file is part of Garden.
    Garden is free software: you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation, either version 3 of the License, or (at your option) any later version.
    Garden is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
    You should have received a copy of the GNU General Public License along with Garden.  If not, see <http://www.gnu.org/licenses/>.
    Contact Vanilla Forums Inc. at support [at] vanillaforums [dot] com
    */
    
    
    /**
     */
    function smarty_function_categories_link($Params, &$Smarty) {
       $Wrap = GetValue('wrap', $Params, 'li');
       return Gdn_Theme::Link('categories',
          GetValue('text', $Params, T('Categories')),
          GetValue('format', $Params, Wrap('<a href="%url" class="%class">%text</a>', $Wrap)));
    }
    
    
    

    Also in 2.0.18.8

    you may need to remove in Leaf/views/default.master.tpl

    {module name="MeModule"}


    then when you have the errors gone.

    you may need to style the sitemenu correctly and adjust other style elements in custom.css

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Probably a good idea when uploading a new plugin or theme

    make sure it works with the current stable release

    or if it doesn't work with current stable release
    - put a requirement for the version it does actually does work with and the one you tested it on.

    or a note in the plugin and theme or description - only tested in vanilla version x.x.xxx

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    jeongwee
  • jeongweejeongwee Vanilla version 2.6 ✭✭
    edited November 2013

    peregrine said:
    Several things - jeongwee probably never tested it on 2.0.18.8

    yea,i never test it on 2.0.18.8.

    theres a title on the theme based on 2.1

  • peregrineperegrine MVP
    edited November 2013

    @jeongwee

    theres a title on the theme based on 2.1

    in english "based on 2.1" does not signify "required vanilla 2.1.x " or tested only in vanilla 2.1b2" which be more obvious to new users.

    and a requirement in the info in the about.php would alleviate the problem of users trying to enable theme in version of vanilla less than vanilla 2.1 .

    By preventing them from enabling theme in a lower version it would prevent (new users or novices from getting errors that crash their system).

    just pointing it out.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    jeongwee
  • I've changed the title for you. Search the forum and report back once you've solved it :-)

    jeongwee
  • @Underdog - for this theme to work in 2.0.18 if would require massive styling changes. i just told him how to not get errors.

    Perhaps the better title.

    "This theme requires Vanilla application 2.1.x"

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    jeongwee
  • jeongweejeongwee Vanilla version 2.6 ✭✭
    edited November 2013

    @peregrine said:
    Underdog - for this theme to work in 2.0.18 if would require massive styling changes. i just told him how to not get errors.

    Perhaps the better title.

    "This theme requires Vanilla application 2.1.x"

    sry for the bad english :(

    i have changed the description.

    thx for pointing it out.

Sign In or Register to comment.