Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

[Solved] Vanilla Forum not working on PHP 5.4.x?

shotashota New
edited January 2014 in Vanilla 2.0 - 2.8

Hello everyone,

Has been running vanilla forum on NGINX+PHP-FPM (php 5.3.28 or older) without issues.
Updating to 5.4.23 or 5.5.X (latest from remi repository) throws fatal exception: class 'Gdn_Url' not found in /library/core/functions.general.php on line 335"
Searched the google, and the discussion board here without success. Only downgrading to PHP 5.3.x solves the issue. Even more, the same error when trying to install a fresh distributive of vanilla forum downloaded from here.

Please help!
Running on Windows Azure OpenLogic CentOS 6.3
NGINX 1.4.4
PHP with PHP-FPM 5.4.23

Tagged:

Comments

  • Options
    UnderDogUnderDog MVP
    edited January 2014

    Usually when you get class 'Gdn_Url' not found then you have to clear the .ini files in the cache directory. But since you did a clean install I don't know if it helps in this case.
    Do you have error_reporting enabled? I'm on Windows with php 5.4 I think

    There was an error rendering this rich post.

  • Options

    Yes, the same error once the distributive archive unpacked and just starting to install. It hangs with this error message at once, so I can't even install it.

    Yes, error_reporting is logging all errors into the log file.

  • Options
    hgtonighthgtonight ∞ · New Moderator

    Welcome to the community!

    What version number of Vanilla are you running?

    I have successfully run 2.0.18.8, 2.1b1+, and 2.2+ on PHP 5.3, 5.4, and 5.5.

    That said, I run it on 5.3 on my production sites.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    shotashota New
    edited January 2014

    Tried 2.0.18.4 and 2.0.18.10.
    Haven't tried 2.1 and 2.2.

  • Options
    hgtonighthgtonight ∞ · New Moderator

    I am not suggesting you use beta software.

    Just adding some data points. :D

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    Just tried to install Vanilla 2.1b2 - the same error. Tried to remove php and all libs (like apc, etc.) but still the same error message.

    Seems Vanilla Forum is not compatible with official release of PHP 5.4.x+/5.5.x got from REMI repository.

    How to report an official bug here?

  • Options
    peregrineperegrine MVP
    edited January 2014

    How to report an official bug here?

    they don't call'em bugs - they call'em issues. innocent until proven guilty.

    there is a link on the documentation page. look for "issue tracker"

    or you could scan 5 messages up to underdog's signature "report a new vanilla issue on github" and click on it. :)

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    • meant to remove and re-install php, php-pdo and php-fpm from the scratch.
  • Options

    Reported an issue. Hope they will be able to close it soon.

  • Options

    I somewhat cyclical this is lack of support because the class is there it should have loaded. @hgtonight already said he has used it on a functionally identical version.

    I would suspect it has do with the modules/options that was compiled with that distro package.

    Any software is not going o track of the the nuances of every third party repository package.

    I would compile from source maybe.

    grep is your friend.

  • Options

    perhaps you can compare your version with hgtonight

    grep is your friend.

  • Options
    LincLinc Detroit Admin

    @shota said:
    Seems Vanilla Forum is not compatible with official release of PHP 5.4.x+/5.5.x got from REMI repository.

    How to report an official bug here?

    Unless you can report exactly what's causing the issue, there's no bug to report yet. Vanilla definitely works with PHP 5.4 and 5.5, so this isn't a case where you can say "compatibility issue" and call it a bug report.

  • Options

    Lincoln,
    I've reported the standard case of installing NGINX+PHP-FPM (with PHP 5.4.x/5.5.x) through REMI repository that seems to be not compatible with Vanilla Forum (even with bare new latest distro).

    Installing with REMI repository is the standard way to install PHP 5.4.x/5.5.x on *nix machines.

  • Options
    hgtonighthgtonight ∞ · New Moderator

    @shota said:
    Installing with REMI repository is the standard way to install PHP 5.4.x/5.5.x on *nix machines.

    Simply untrue. The REMI repo is a third party repo that is not included with yum on CentOS. You have to add it yourself.

    Source: http://wiki.centos.org/AdditionalResources/Repositories

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    x00x00 MVP
    edited January 2014

    Installing with REMI repository is the standard way to install PHP 5.4.x/5.5.x on *nix machines.

    This is not really the case if you are talking broadly about *nix machines.

    However this irrelevant as any package from any system, from any distro may not be configure or complied the same, and may not have the same modules or setup.

    grep is your friend.

  • Options

    from experience there is often no official repository of for RPM regarding distros therefore in that case there is no official package to benchmark against. I may be mistaken but that has been my experience thus far.

    grep is your friend.

  • Options

    Well... The internet is full of step-by-step guides to install php 5.4/5.5 with php-fpm and all them pointing to remi repository.

    I'll try to find an alternative repository with php 5.4/5.5 and will write here any result.

  • Options
    LincLinc Detroit Admin
    edited January 2014

    "It doesn't work" isn't a bug report. Especially when there's hundreds counterexamples. If you can tell us why it doesn't work, we can start to discuss a potential resolution.

  • Options

    Issue solved.

    Let's keep it here in case anybody experiences the same issue:

    For unknown reason, the exception was thrown if PHP-FPM conf file includes:

    php_admin_value[error_reporting] = E_ALL & ~E_NOTICE

    Commenting it out helps to run vanilla forum 2.0.x without any issues.

Sign In or Register to comment.