Please upgrade here. These earlier versions are no longer being updated and have security issues.

Registration/Login 404 in Firefox when embedded

Only in firefox, both links cause a 404 - but only when the forum's embedded

The forum is embedded at http://fabulouspanda.co.uk/macminer/forum/ and not embedded at http://forums.fabulouspanda.co.uk/

Any ideas on how I can fix this?

«1

Comments

  • hgtonighthgtonight ∞ · New Moderator

    Welcome to the community!

    I just tested and was able to register/sign in on the embedded version in FF.

    Is it a WP 404 you get?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Thanks for getting back to me - it's the 'Page Not Found' that comes with Vanilla - It's FireFox for Mac by the way and also reported in SeaMonkey

  • hgtonighthgtonight ∞ · New Moderator

    I don't have an OS X system anymore, so I can't attest to that.

    If it is Vanilla showing the 404, what is the URL of the page when it 404s?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • I can't tell as it's embedded however perhaps there's a clue in the fact that in Firefox the link for sign in shows Target=categories/discussion at the end but elsewhere Target=categories$2Fdiscussion

  • hgtonighthgtonight ∞ · New Moderator

    This means it is a soft 404 (Vanilla generates the 404, not the server software (e.g. Apache)).

    Does it work normally in Safari and Chrome?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Yeah, totally fine in both of those and even in Opera!

  • hgtonighthgtonight ∞ · New Moderator

    I am guessing it has something to do with malformed headers.

    This will require some JS debugging to find the actual issue though.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • does this happen with embed theme, no plugins enabled except the vanilla embed?

    what version of vanilla does it happen in?

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Version 2.0.18.10 - it doesn't happen with the embed theme, I guess I should compare that to the Glass theme I modified

  • hgtonighthgtonight ∞ · New Moderator

    @FabulousPanda said:
    Version 2.0.18.10 - it doesn't happen with the embed theme, I guess I should compare that to the Glass theme I modified

    Make sure that you leave the foot asset in any master view file you modify (e.g. in Smarty {asset name="Foot"}) as this is the place definitions are placed. Definitions are used primarily for JS.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited February 2014

    The Glass theme is php and the embed friendly theme is tpl. if you are going to compare it with something it is best to compare it with the default theme. That is what I used to craft the glass theme as a base for it.

    You do not have Rewrite Urls True in the config, please also check the htaccess file

    this the registration link on the non embedded

    http://forums.fabulouspanda.co.uk/entry/register?Target=categories/discussions

    this is the registration link in the embedded

    http://fabulouspanda.co.uk/macminer/forum/

    Notice the difference in the links ?

    That has to do with RewriteURL and Vanilla htaccess

    The link to registration should be http://fabulouspanda.co.uk/macminer/forum/entry/register

    with clean urls

  • Thanks for the Glass theme! $Configuration['Garden']['RewriteUrls'] = TRUE; is set - what should be in the .htaccess or apache conf?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    The htaccess file is in the root of the forum directory and it should look like this

    # Modified
    # If you modify this file then change the above line to: # Modified
    <IfModule mod_rewrite.c>
       RewriteEngine On
       # Certain hosts may require the following line.
       # If vanilla is in a subfolder then you need to specify it after the /. 
       # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
       RewriteBase /forum
       RewriteCond %{REQUEST_FILENAME} !-d
       RewriteCond %{REQUEST_FILENAME} !-f
       RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    </IfModule>
    
  • It's set up like that, and I'm fairly sure apache is set up to AllowOverride - do you know of some way I can test that?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited February 2014

    Are you hosting this yourself ? if not then you need to ask the host to turn on htaccess.

    Are you embedded in Wordpress or what is it embedded in.

    First get the forum urls to work right, then see about the other htaccess files you have on the embedding site.

    http://httpd.apache.org/docs/2.0/mod/core.html#allowoverride

    I'm not aware of a simple, direct method of Testing for this.

    For those who have http use of the folder you need to look if you can write something into the .htaccess file which will trigger a particular type of output.

    For instance, you can set a header (it has an additional reliance upon mod_headers, though):

    <FilesMatch ".(php)$">  
    
    <IfModule mod_headers.c>  
    
    Header set htaccess_works "yes"  
    
    </IfModule>  
    
    </FilesMatch>  
    

    make a request from PHP, and see the response headers, e.g. using curl's CURLOPT_HEADER. When they retain the htaccess_works header, it really works.

    Another terrible method but certain to work individually from specific Apache modules would be to programmatically write gibberish in to the .htaccess file, then to create a curl request like above, and also to look into the 500 status code. Whether it throws a 500, the .htaccess file got construed. But as stated, this really is terrible - if at all possible, opt for the headers method rather.

    AllowOverride could be set to None or All, but too to some specific listing of terms: AuthConfig, FileInfo, Indexes, Limit, Options. So you may be permitted to utilize a Header instruction although not Deny, for instance.

    So a method to test the actual worth of AllowOverride would be to add this for your .htaccess:

        #AuthConfig  
    
        AuthName "Secret"  
    
        #FileInfo  
    
        ErrorDocument 404 index.php  
    
        #Indexes  
    
        DefaultIcon /icon/unknown.xbm  
    
        #Limit  
    
        Allow All  
    
        #Options  
    
    Options FollowSymLinks  
    

    Then for those who have an 500 error comment lines to identify which words (sections) are forbidden. You will get an error 500 before you remove every forbidden instruction. When you know which are the permitted sections you will need to look into the documentation for the complete listing of permitted instructions.

    If you don't have error you've AllowOverride None or All. Then affect using the Deny/Let it:

    Deny All  
    

    If you get the 403 result it is an AllowOverride All.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    This may be a bug related to having the landing page be the categories page.

    I tested it with my own forum. I know htaccess works and it also worked for you since you had pretty url in the stand alone forum.

    I think the issue happens when you get redirected back to the categories page. The route may need to be adjusted in the config to display clean url. Possibly. I am going to test it.

  • Thanks, I checked the Override was on and it was. It's peculiar that it's just in Firefox/Seamonkey and only when it's embedded!

  • FabulousPandaFabulousPanda London New
    edited February 2014

    Oh I tried switching up the default page btw to one without a / and it didn't help

  • FabulousPandaFabulousPanda London New
    edited February 2014

    It seems to be working now, for no obvious reason… maybe as something was cached and a change to the httpd conf did it?

Sign In or Register to comment.