Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Registration/Login 404 in Firefox when embedded

2»

Comments

  • Options

    I lied, it DOES work when homepage is set to /discussions, but NOT when /categories/all or /categories/discussions

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited February 2014

    Yes that is what I suspected. Similar bug in 2.1 where the sign in button send you to a 404 if you are in the categories page and hit sign in...

    The only thing that affects that is the Route, the default controller . In the entry controller

    this the mechanism that redirects a user after

     if ($this->_RealDeliveryType != DELIVERY_TYPE_ALL && $this->_DeliveryType != DELIVERY_TYPE_ALL) {
                   $this->RedirectUrl = Url($Route);
                } else {
    
                   if ($Route !== FALSE) {
                      Redirect($Route);
                   } else {
                      Redirect(Gdn::Router()->GetDestination('DefaultController'));
    

    And that Route is determined in the dashboard Routes and saved in config.php

    Somewhere in that process of redirecting, the clean urls are not working as they should.

  • Options

    Well, it does work when it's not embedded, and I can easily enough make it looks exactly the same without embedding, and for the meantime I'll use a different homepage. Do you take Bitcoin tips? :D

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    Yes embedding sucks , you can make better use of the forum as a stand alone and make it look identical.

    Do you take Bitcoin tips?

    lol , Iove that !! <3 but no not yet , save it for a rainy day :)

    I am just glad to be able to help in some way...

  • Options
    hgtonighthgtonight ∞ · New MVP

    @FabulousPanda said:
    Do you take Bitcoin tips? :D

    Now there is an idea for Shwaipbot to implement.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    @hgtonight said:
    Now there is an idea for Shwaipbot to implement.

    test test test

    @Minion 5million Bitcoins on hgtonight now !!

    chirp chirp :(

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited February 2014

    @FabulousPanda

    I just realized something , your forum is in a root subdirectory http://forums.fabulouspanda.co.uk/

    so the htaccess RewriteBase should be /

    It is the same as if it it were http://www.fabulouspanda.co.uk/

    The root of the forum is the relative root of where it is installed. Might check that out. It may not fix the issue about embedding , but I think that is how the htaccess should be set.

  • Options

    Thanks for saying! It's actually on a server I installed WHM and cpanel on and that appears to have set the correct RewriteBase for me on install. I've actually turned off the embed plugin already and jazzed up the forum homepage :)

Sign In or Register to comment.