Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

why am I gettin the bonk screen after moving to a new server?

I just moved from a shared server to a managed server but my domain name stayed the same. The only change was the server name, user name, and DB name. I edited the config file to point to the new server and I get the bonk screen, but if I point back at the old server it works again :(. I tried turning on error reporting but still only get user friendly error message, please help!

«1

Answers

  • Options
    hgtonighthgtonight ∞ · New MVP

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    I have never used vanilla before however I am trying to pick up where the original developer left off. please bare with me.... I do not know how to find the version of vanilla and as i said before I cannot get it to display an actual error even after adding $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

  • Options
    hgtonighthgtonight ∞ · New MVP

    I am happy to help. If you read the link I gave you, it doesn't mention that config item at all.

    Please read both of the links and answer the questions so we can help.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    SQLSTATE[HY000] [1045] Access denied for user

  • Options

    trigger_error(ErrorMessage('An error occurred while attempting to connect to the database', $this->ClassName, 'Connection', $ex->getMessage()), E_USER_ERROR);

    61: }

  • Options

    seems to be an error connecting to the new database but I have checked and rechecked all the con/config settings and they all match up with the new server

  • Options
    hgtonighthgtonight ∞ · New MVP

    The configurations you are using for your new database connection are most likely wrong.

    Please double check the username and password, as well as the host config items and try again.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    Everything is correct username, server name, host, and password

  • Options

    is the database correct?

    grep is your friend.

  • Options

    You will need to provide more details.

    Provide the credential minus the password. Or if you can't do that preserve the jist of the credentials.

    grep is your friend.

  • Options

    // Database
    $Configuration['Database']['Name'] = 'db516515546';
    $Configuration['Database']['Host'] = 'localhost:/tmp/mysql5.sock';
    $Configuration['Database']['User'] = 'dbo516515546';
    $Configuration['Database']['Password'] = '';

  • Options

    host is looking into the issue now

  • Options

    try localhost;unix_socket=/tmp/mysql5.sock as the host

    grep is your friend.

  • Options

    from the docs

    If you must use Vanilla with a database socket connection, use this syntax for the database host: localhost;unix_socket=/tmp/mysql5.sock

    grep is your friend.

  • Options

    when I use that syntax it says that vanilla has already been installed

  • Options

    navigate elsewhere.

    grep is your friend.

  • Options

    make sure conf/config is writable by the process user, delete *.ini files in cache

    grep is your friend.

  • Options

    deleted .ini files from cache and also checked permission they are set to 644 also tried with them set at 777

  • Options

    @ghost_reload said:
    deleted .ini files from cache and also checked permission they are set to 644 also tried with them set at 777

    you shouldn't need to set anything to chmod 0777, don't start me off on a rant.

    grep is your friend.

  • Options

    so what you are saying it is keeps going back to dashboard/setup? no mater if you navigate away from this?

    What is the value of Garden.Installed in config?

    grep is your friend.

Sign In or Register to comment.