Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Twitter issue : SSL is required

Hello everybody,

I installed Vanilla 2.1b1 on my server (1and1) and I've tried to get Twitter working properly since. I still get the message "SSL is required" when I try to register using Twitter. The URL of my forums is :
My consumer key and consumer secret are correctly entered in the admin.

Any idea of what the problem is ?

Thanks in advance.


  • Options
    hgtonighthgtonight ∞ · New Moderator

    The API calls need to be made over https, IIRC.

    You can find more info here:

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    Problem solve. Thanks a lot!

  • Options

    Hi There,

    Kind of a newb here, so sorry if I am missing something.

    I was having the same of ["SSL required"] for the twitter same twitter login issue as the OP. I have folllowed the link to the link and corrected code by hgtonight, but the class.twitter.plugin.php seems to have changed, as my version not the same as the linked code.

    I have installed vanilla version Here my pligininfo array, which is not compatible with the fix linked to. Am I missing something here?

    // Define the plugin:
    $PluginInfo['Twitter'] = array(
            'Name' => 'Twitter',
       'Description' => 'This plugin integrates Twitter with Vanilla. <b>You must r$
       'Version' => '0.1a',
       'RequiredApplications' => array('Vanilla' => '2.0.12a'),
       'RequiredTheme' => FALSE,
       'RequiredPlugins' => FALSE,
            'MobileFriendly' => TRUE,
       'SettingsUrl' => '/dashboard/settings/twitter',
       'SettingsPermission' => 'Garden.Settings.Manage',
       'HasLocale' => TRUE,
       'RegisterPermissions' => FALSE,
       'Author' => "Todd Burry",
       'AuthorEmail' => '',
       'AuthorUrl' => ''
  • Options
    AdrianAdrian Wandering Spirit Montreal MVP
    edited April 2014

    @mbjvfx the issue is Twitter made is so all calls to the api need to go to https. So just do a CTRL+F in the file and make sure all links to Twitter that show HTTP, now show HTTPS

    public static $BaseApiUrl = '';
    public static $BaseApiUrl = '';

    $Url = "{$Data['oauth_token']}";
    $Url = "{$Data['oauth_token']}";

  • Options

    Thanks Adrian Will do

  • Options

    Fixed my issue too.

Sign In or Register to comment.