Please upgrade here. These earlier versions are no longer being updated and have security issues.

No utility/update

I upgraded my new forum from 2 to 2.1beta1 and I followed the documentation here http://vanillaforums.org/docs/installation-upgrade

But when it says for me to go to mysite.com/utility/update I get a file not found error. Inside of my directory I don't even have a utility folder.

Not sure what to do now.

Comments

  • Should have mentioned that I did search these forums for help, and did not find a whole lot to help me.

  • LincLinc Senior Bard Detroit Admin

    Try mysite.com/index.php?p=/utility/update

    You probably didn't copy the htaccess file, aren't using Apache, or don't have RewriteUrls enabled in your config.

  • edited March 2014

    Ok, so index.php?p=/utility/update doesn't work.

    I did copy the htaccess file from my old to the new. I'm not sure about the apache. And I don't know about rewriteurls, whatever the default install is, that's most likely what I have as I had not done a ton of configuring.

  • hgtonighthgtonight ∞ · New Moderator

    What does a URL look like when you are looking at a discussion?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • hgtonighthgtonight ∞ · New Moderator

    http://247bama.com/dashboard/utility/update is what you are looking for.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Thank you, any reason it would be in a different directory than the upgrade instructions?

  • all the options can work with and without dashboard.

    it may be that you are having issues with it - is due to
    your .htaccess or rewrtite urls

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Ah, I didn't even realize that I was uploading to a beta that was old... stupid me. Just going to do a fresh install anyways, but this is good help anyways. Thanks again all.

  • always check the index.php before installing. you will see the version in that file.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Honestly, I didn't even think about it. I know I had installed 1.something and then I saw there was a 2 something. I think the download page should be more descriptive about what's available for download.

  • peregrineperegrine MVP
    edited March 2014

    http://vanillaforums.org/addon/vanilla-core

    http://vanillaforums.org/discussion/comment/192085/#Comment_192085

    • The expectation (be that as it may) is that all users use 2.0.18.10. with the expectation that people familiar with the ins and outs of development and other versions to use other versions for testing. But you are right, how would they know easily?

    • but as you say putting a few notes in the description on the add-ons section (e.g. cutting and pasting Dr. sommers summary into the description) on http://vanillaforums.org/addon/vanilla-core

      • certainly couldn't hurt anybody and would greatly improve the experience

    lincoln, wdyt?

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    insanemustang
Sign In or Register to comment.