Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Update for critical security issue in PHPMailer included in release Vanilla 2.3.1
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Bonk Error with Email Confirmation

I'm getting a bonk error when confirming an email address.

I did the debug configuration so you'd know what the error message is. Here is the link to the fatal error I'm getting. http://inspiringwomenmagazine.com/iwm-forum/

Thank you for the help!

Comments

  • why not just post the error on this forum instead of a link. because the error won't be visible to other users once you fix it, and consequently it won't help others with same problem.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • I'll add both - copy and paste and an attached image. Thank you!

    Fatal Error in Gdn_Autoloader.RegisterMap();
    Only variables should be passed by reference
    The error occurred on or near: /home2/hapamamm/public_html/inspiringwomenmagazine/forum/library/core/class.autoloader.php

    382: $Options['MapIdentifier'] = $MapIdentifier;

    383: $MapHash = md5($MapIdentifier);

    384:

    385: // Allow intrinsic ordering / layering of contexts by prefixing them with a context number

    386: $MapHash = 'context:'.GetValue($ContextType, array_flip(self::$ContextOrder)).''.$Extension.''.$MapHash;

    387:

    388: if (!is_array(self::$Maps))

    389: self::$Maps = array();

    390:

    Backtrace:

    [/home2/hapamamm/public_html/inspiringwomenmagazine/forum/library/core/class.autoloader.php:386] PHP::Gdn_ErrorHandler();

    [/home2/hapamamm/public_html/inspiringwomenmagazine/forum/library/core/class.autoloader.php:142] Gdn_Autoloader::RegisterMap();

    [/home2/hapamamm/public_html/inspiringwomenmagazine/forum/library/core/class.autoloader.php:95] Gdn_Autoloader::AttachApplication();

    [/home2/hapamamm/public_html/inspiringwomenmagazine/forum/bootstrap.php:73] Gdn_Autoloader::Attach();

    [/home2/hapamamm/public_html/inspiringwomenmagazine/forum/index.php:41] PHP::require_once();

    Variables in local scope:

    [MapType] 'controller'

    [ContextType] 'application'

    [SearchPath] '/home2/hapamamm/public_html/inspiringwomenmagazine/forum/applications/dashboard/controllers'

    [Options] array (
    'SearchSubfolders' => false,
    'Extension' => 'dashboard',
    'ContextPrefix' => 'a',
    'ClassFilter' => '*',
    'SaveToDisk' => true,
    'MapIdentifier' => 'controller|application|dashboard|/home2/hapamamm/public_html/inspiringwomenmagazine/forum/cache',
    )

    [DefaultOptions] array (
    'SearchSubfolders' => true,
    'Extension' => NULL,
    'ContextPrefix' => 'a',
    'ClassFilter' => '*',
    'SaveToDisk' => true,
    )

    [Extension] 'dashboard'

    [Hits] 1

    [MapRootLocation] '/home2/hapamamm/public_html/inspiringwomenmagazine/forum/cache'

    [MapIdentifier] 'controller|application|dashboard|/home2/hapamamm/public_html/inspiringwomenmagazine/forum/cache'

    [MapHash] '3b0399a935b72a3307750ae9cef468c6'

    Need Help?

    If you are a user of this website, you can report this message to a website administrator.

    If you are an administrator of this website, you can get help at the Vanilla Community Forums.
    Additional information for support personnel:

    Application: Vanilla
    Application Version: 2.0.18.10
    PHP Version: 5.4.26
    Operating System: Linux
    Server Software: Apache
    Referer: http://inspiringwomenmagazine.com/iwm-forum/
    User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:27.0) Gecko/20100101 Firefox/27.0
    Request Uri: /forum/index.php?p=/&t=1396981670376&remote=http%3A%2F%2Finspiringwomenmagazine.com%2Fiwm-forum%2F
    Controller: Gdn_Autoloader
    Method: RegisterMap
    
  • peregrineperegrine MVP
    edited April 2014

    php version 5.4 and above can do this. deprecation and/or turn off debug mode.

    see hgtonight's comments and resolutions in links below.

    http://vanillaforums.org/discussion/comment/203874/#Comment_203874

    http://vanillaforums.org/discussion/comment/203638/#Comment_203638

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • The reason why I had it on debug mode was to try to correct a bonk error when sending a confirmation email. Here is a link to the error - it's at the bottom of the page. When you click "here" it gives you a bonk error. http://inspiringwomenmagazine.com/iwm-forum/

    Thank you!

  • peregrineperegrine MVP
    edited April 2014

    try different version of php, maybe 5.3 if it is easy for you to change and see if you get error.
    if you still get bonk error after changing to php 5.3 report that new error.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • wild guess in the dark if you can't debug errors because of ver php 5.4 with vanilla 2.0.18.10

    http://vanillaforums.org/discussion/comment/199382/#Comment_199382

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • My cPanel doesn't have an option for 5.3. Also, I read this at top of my cPanel page. " If you are not familiar with these options, do NOT change them.
    This can cause all PHP scripts on your site to stop functioning if misconfigured."
    So I'm reluctant to change the settings!

  • peregrineperegrine MVP
    edited April 2014

    you can always change it back. one would assume. vanilla 2.0.18.10 works fine with 5.3

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • peregrineperegrine MVP
    edited April 2014

    or maybe change the error reporting to

    ini_set("error_reporting", E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED);

    or perhaps change...

    iirc it is in index.php

    error_reporting(E_ERROR | E_PARSE | E_CORE_ERROR | E_COMPILE_ERROR | E_USER_ERROR | E_RECOVERABLE_ERROR);
    ini_set('display_errors', 'on');

    to

    error_reporting(E_ERROR | E_PARSE | E_CORE_ERROR | E_COMPILE_ERROR | E_USER_ERROR | E_RECOVERABLE_ERROR);
    error_reporting(error_reporting() & (-1 ^ E_DEPRECATED));
    ini_set('display_errors', 'on');

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • I replaced:

    ini_set('display_errors', 'on');
    ini_set('track_errors', 1);

    with your:

    ini_set("error_reporting", E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED);

    and I still got a bonk error. :(

    Can you suggest another fix?

    I can't change the php to 5.3 because my cPanel doesn't have that option. Thx!

  • peregrineperegrine MVP
    edited April 2014

    try changing to this, might work...

    error_reporting(E_ERROR | E_PARSE | E_CORE_ERROR | E_COMPILE_ERROR | E_USER_ERROR | E_RECOVERABLE_ERROR);
    error_reporting(error_reporting() & (-1 ^ E_DEPRECATED));
    ini_set('display_errors', 'on');

    I don't run php5.4 and vanilla 2.0.18.10 - so I'm just taking guesses of what might work. maybe someone else can help.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Just tried and it didn't work. Thank you for trying to help! When I test, I'm able to get access the forum from my test account, it just give the bonk error and i don't get the email confirmation.

  • you would still get the bonk screen if you have other errors, but it may help with the first error.

    Fatal Error in Gdn_Autoloader.RegisterMap(); Only variables should be passed by reference The error occurred on or near: /home2/hapamamm/public_html/inspiringwomenmagazine/forum/library/core/class.autoloader.php

    if you change the config.php to see the actual error (to find out cause of bonk), do you have a different one with the error reporting changes.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • hgtonighthgtonight ∞ · New Moderator

    Welcome to the community!

    Changing the PHP version won't get rid of your Bonk error (well it probably won't). It will get rid of the autoloader deprecation warning and show you the actual error.

    Search first

    Check out the Community Wiki! We are always looking for new content.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • I really appreciate @peregrine and @hgtonight trying to help. I don't really understand what you're both trying to say. I get a bonk error when you click on the "here" at the bottom of this page. http://inspiringwomenmagazine.com/iwm-forum/#

    I tried to change some code so we can actually see what was wrong and that's when I got the "Fatal Error in Gdn_Autoloader.RegisterMap(); " error. I thought that was the one that needed to be fixed? But then I thought that @peregrine was telling me that because I tried to debug that's why I got the error?

    I'm not getting an email confirmation when my test email address is used, and when I try to send one from the "here" link it gives me a bonk error.

    Thank you both! Alison

  • hgtonighthgtonight ∞ · New Moderator

    You need to either switch to PHP 5.3 or modify your index.php file to disregard deprecation errors. Something like: error_reporting(E_ALL ^ E_DEPRECATED); should work.

    Search first

    Check out the Community Wiki! We are always looking for new content.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • So do I replace one of these lines in the index.php file with the "error_reporting(E_ALL ^ E_DEPRECATED);"?

    // Report and track all errors.
    error_reporting(E_ERROR | E_PARSE | E_CORE_ERROR | E_COMPILE_ERROR | E_USER_ERROR | E_RECOVERABLE_ERROR);
    ini_set('display_errors', 'on');
    ini_set('track_errors', 1);

  • This is the error:

    Fatal Error in PHPMailer.SmtpSend();
    SMTP Error: The following recipients failed: astripling@gmail.com
    The error occurred on or near: /home2/hapamamm/public_html/inspiringwomenmagazine/forum/library/vendors/phpmailer/class.phpmailer.php

    751:

    752:

    753: if (count($bad_rcpt) > 0 ) { //Create error message for any bad addresses

    754: $badaddresses = implode(', ', $bad_rcpt);

    755: throw new phpmailerException($this->Lang('recipients_failed') . $badaddresses);

    756: }

    757: if(!$this->smtp->Data($header . $body)) {

    758: throw new phpmailerException($this->Lang('data_not_accepted'), self::STOP_SERVER);

    759: }

    Backtrace:

    [/home2/hapamamm/public_html/inspiringwomenmagazine/forum/library/vendors/phpmailer/class.phpmailer.php:577] PHPMailer->SmtpSend();

    [/home2/hapamamm/public_html/inspiringwomenmagazine/forum/library/core/class.email.php:202] PHPMailer->Send();

    [/home2/hapamamm/public_html/inspiringwomenmagazine/forum/applications/dashboard/models/class.usermodel.php:2092] Gdn_Email->Send();

    [/home2/hapamamm/public_html/inspiringwomenmagazine/forum/applications/dashboard/controllers/class.entrycontroller.php:1339] UserModel->SendEmailConfirmationEmail();

    [/home2/hapamamm/public_html/inspiringwomenmagazine/forum/applications/dashboard/controllers/class.entrycontroller.php:1339] EntryController->EmailConfirmRequest();

    [/home2/hapamamm/public_html/inspiringwomenmagazine/forum/library/core/class.dispatcher.php:322] PHP::call_user_func_array();

    [/home2/hapamamm/public_html/inspiringwomenmagazine/forum/index.php:54] Gdn_Dispatcher->Dispatch();

    Need Help?

    If you are a user of this website, you can report this message to a website administrator.

    If you are an administrator of this website, you can get help at the Vanilla Community Forums.
    Additional information for support personnel:

    Application: Vanilla
    Application Version: 2.0.18.10
    PHP Version: 5.4.26
    Operating System: Linux
    Server Software: Apache
    Referer: http://inspiringwomenmagazine.com/forum/
    User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:27.0) Gecko/20100101 Firefox/27.0
    Request Uri: /forum/entry/emailconfirmrequest
    Controller: PHPMailer
    Method: SmtpSend
    
    hgtonight
  • hgtonighthgtonight ∞ · New Moderator

    Do you have SMTP credentials entered in the dashboard?

    Search first

    Check out the Community Wiki! We are always looking for new content.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • I tried to get the right inputs there... LOL. I even when to my cPanel to look. Do you think I did something wrong? Thank you!!!

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Is there a SMTP server running on myhost:myport?

    Try using TLS on port 587 instead of SSL 465

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    You should be able to send using the normal mail, without smtp. You are using your email from your forum not gmail or anything external.

    Just input the email in the top field and unselect smtp. Otherwise check with your host to make sure.

  • Okay I made possibly the goofiest error of all time. I typed my email address in wrong in the settings. That was the extent of the error. Yes, people, it was my fault to begin with. Totes embarrassing. Well, I have another question to post...hopefully the next one will be better. LOL

    vrijvlinderhgtonight
  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited April 2014

    @‌ alisonstripling

    It happens more than you think, to me at least and some others at times. You need not be embarrassed .

    In fact thanks to you, From now on if this happens again to someone else the first thing we will ask them is Did you enter your email correctly ?

    I often think that the simplest answer is the correct one most of the time. Ocam's Razor.

    Welcome to Vanilla :)

    alisonstripling
  • @alisonstripling said:
    Okay I made possibly the goofiest error of all time. I typed my email address in wrong in the settings. That was the extent of the error. Yes, people, it was my fault to begin with. Totes embarrassing. Well, I have another question to post...hopefully the next one will be better. LOL

    yes but it helped you solve an issue that can be more wide reaching.

    grep is your friend.

    hgtonightalisonstripling
  • @x00 said:

    @alisonstripling said:
    Okay I made possibly the goofiest error of all time. I typed my email address in wrong in the settings. That was the extent of the error. Yes, people, it was my fault to begin with. Totes embarrassing. Well, I have another question to post...hopefully the next one will be better. LOL

    yes but it helped you solve an issue that can be more wide reaching.

    @vrijvlinder said:
    @‌ alisonstripling

    It happens more than you think, to me at least and some others at times. You need not be embarrassed .

    In fact thanks to you, From now on if this happens again to someone else the first thing we will ask them is Did you enter your email correctly ?

    I often think that the simplest answer is the correct one most of the time. Ocam's Razor.

    Welcome to Vanilla :)

    I made the same mistake of not entering the correct email address. So simple but could cause a lot of confusion

Sign In or Register to comment.