Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.

Upgrading Markdown lib

JasonBarnabeJasonBarnabe Cynical Salamander ✭✭

(I'd post this in Development, but I can't, apparently)

Vanilla 2.1.3 and what's in master in GitHub use PHP Markdown 1.0.1n/Extra 1.2.4. It was upgraded 1.0.2/Extra 1.2.8, but then reverted. The latest version is 1.4.1 (the versioning scheme seems to have changed).

My users would like to use certain Markdown features available in 1.4.1, like fenced code blocks. I can upgrade it myself easily enough, but I'm concerned that there was something incompatible with the newer versions. @Linc or someone else, can you tell me why it was downgraded?

UnderDog

Comments

Sign In or Register to comment.