Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Seeing JSON Response when posting new discussion.

Using Vanilla 2.1.8p2, when I post a new discussion, a lightbox pops up with something similar to this:

{"DiscussionID":"","DraftID":"16555","FormSaved":true,"DeliveryType":"VIEW","Data":"PGRpdiBpZD0i[...TRUNCATED]","InformMessages":[{"CssClass":"Dismissable AutoDismiss","Message":"Draft saved at 2:56PM"}],"ErrorMessages":"","RedirectUrl":""}

The discussion posts, but it does not redirect to the newly created discussion.

Comments

  • Options
    hgtonighthgtonight ∞ · New MVP

    Hallo!

    Do you have any errors in your web console or on your server?

    Generally JSON data showing up in inform messages is due to your server outputting data but returning an "error" status code.

    What plugins are you running?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    Thank you for the quick reply.

    Not getting much info from error log:
    PHP Fatal error: Exception thrown without a stack frame in Unknown on line 0, referer: http://www.ronsgoldclub.com/vanilla/post/discussion/

    Enabled Plugins:
    Flagging
    GC Points
    Role Titles
    Tagging
    Vanilla Proxyconnect

    GC Points is a custom plugin I wrote, but the error was happening before enabling that plugin.

  • Options

    Okay...looks like it may be solved...

    When I read your question about which plugins were installed, I went ahead and disabled all of them (except ProxyConnect and HtmLawed), and it fixed the problem. I reenabled one by one until the error returned. It was actually the "Getting Started" plugin that caused the problem. I didn't realize it was active until I looked at my config file.

    Thanks for the assistance!

  • Options
    hgtonighthgtonight ∞ · New MVP

    Does the problem occur with just Getting Started and HTMLawed enabled?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options

    Yes. It occurs when only those two plugins are enabled.

  • Options
    LincLinc Detroit Admin

    FWIW, I am extremely curious to know how Getting Started caused the autodraft endpoint to break.

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    There is some bad implemented redirect issue on your page. If I open up http://www.ronsgoldclub.com/vanilla/categories I see a Vanilla forum for a second and then I'm redirected to your custom "Become a member" page. So I can access whichever content I like without registration.

    I guess the way the redirection is implemented is the real cause for your problems.

Sign In or Register to comment.