HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[error] Installing 2.2.100.2 errors on db setup page

hello all, I have been trying to figure out exactly what is wrong with this install script for about a day now and I cant figure it out. maybe someone on the boards here have had a similar situation.
Here are the steps I have taken so far.
1. git clone master fron vanilla git repo
2. set up my local db to use with installer
3. set up localhost
4. accessed site at local.vanilla.com <- my local address
5. enter db credentials and admin username password

Upon pressing continue it starts to do its thing and then kaboom! i get the following errors. (debug is enabled via config.php)
/private/var/www/vanilla22/library/database/class.database.php(422) [internal function]: Gdn_ErrorHandler(256, '', '/private/var/ww...', 422, Array) /private/var/www/vanilla22/library/database/class.database.php(422): trigger_error('', 256) /private/var/www/vanilla22/library/database/class.sqldriver.php(1663): Gdn_Database->query('insert GDN_Perm...', Array, Array) /private/var/www/vanilla22/library/database/class.sqldriver.php(1083): Gdn_SQLDriver->query('insert GDN_Perm...', 'insert') /private/var/www/vanilla22/library/database/class.sqldriver.php(1155): Gdn_SQLDriver->insert('Permission', Array) /private/var/www/vanilla22/applications/dashboard/models/class.permissionmodel.php(223): Gdn_SQLDriver->replace('Permission', Array, Array, true) /private/var/www/vanilla22/applications/dashboard/settings/structure.php(324): PermissionModel->define(Array) /private/var/www/vanilla22/applications/dashboard/controllers/class.setupcontroller.php(197): include('/private/var/ww...') /private/var/www/vanilla22/applications/dashboard/controllers/class.setupcontroller.php(67): SetupController->configure() /private/var/www/vanilla22/library/core/class.dispatcher.php(329): call_user_func_array(Array, Array) /private/var/www/vanilla22/index.php(40): Gdn_Dispatcher->dispatch() {main}

I have cleared the cache in the cache dir many times before running again.
I have also made sure that the config, uploads and cache dir have full write permissions.

Strange thing is that some of the db tables get generated. heres a list.
GDN_AnalyticsLocal GDN_Permission GDN_Role GDN_Session GDN_User GDN_UserAuthentication GDN_UserAuthenticationNonce GDN_UserAuthenticationProvider GDN_UserAuthenticationToken GDN_UserMeta GDN_UserPoints GDN_UserRole

I have also tried using different php version from 5.4-5.6
Installing 2.1.x i have no problems but for some strange reason 2.2 just doesnt wana do its thing.

any ideas?

Comments

  • hgtonighthgtonight ∞ · New Moderator

    Welcome to the community!

    You didn't post the error you received, just the trace. From the trace alone, I can theorize that there is a PDO error.

    The short story is that 2.2.100.2 is not released as stable for open source. The 2.2 branch is releasing as beta soon.

    Use the branch 2.1.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • LincLinc Former Staff Detroit Admin

    Is MySQL strict mode enabled on your server? Permission setting errors are typically related to that.

  • LincLinc Former Staff Detroit Admin

    I'd welcome a specific bug & patch for this. We'd like to start supporting strict mode going forward.

  • innodb strict is off but mysql strict is on. swappin mysql strict to off kinda breaks a lot of things and I dont know if I want to deal with all those headaches right now lol

  • edited June 2015

    This should be mentioned somewhere in the docs if Vanilla doesn't support mysql strict mode. Most default installations of mysql have strict mode enabled by default. Found this thread because even I got the exact same error on installing and disabling strict mode helped. Though I was trying the beta on Localhost, the install script kept timing out. Had to increase the maximum execution time for the installer to work.

    Update

    And I just noticed that you are shipping a very (very) old version of Smarty Template Engine. This was the debug notice I got on the forum page after installation

    preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in \vanilla\library\vendors\Smarty-2.6.25\libs\Smarty_Compiler.class.php line 270

    Disappointing.

  • Can't edit the post so saying here. Just checked the library/vendors directory. Almost all the libraries you are shipping are outdated. Some are as old as 2008. Why can't you ship latest version of these libraries?

Sign In or Register to comment.