Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Moving install between servers

MaddawgX9MaddawgX9 New
edited December 2015 in Vanilla 2.0 - 2.8

I just tried moving my working install on one server to another by creating a fresh MySQL db, copying the vanilla directory over, and clearing the cache files. I'm now getting a ton of errors that seem to be related to accessing the database:

limit 1 in /var/www/sites/ on 30209 Dec 2015 - 17:34:14 Garden #0 [internal function]: Gdn_ErrorHandler(256, 'Table 'forum.GD...', '/var/www/sites/...', 302, Array)09 Dec 2015 - 17:34:14 Garden #1 /var/www/sites/ trigger_error('Table 'forum.GD...', 256)09 Dec 2015 - 17:34:14 Garden #2 /var/www/sites/ Gdn_Database->Query('select *?from G...', Array, Array)09 Dec 2015 - 17:34:14 Garden #3 /var/www/sites/ Gdn_SQLDriver->Query('select *?from G...')09 Dec 2015 - 17:34:14 Garden #4 /var/www/sites/ Gdn_SQLDriver->Get()09 Dec 2015 - 17:34:14 Garden #5 /var/www/sites/ PermissionModel->PermissionColumns()09 Dec 2015 - 17:34:14 Garden #6 /var/www/sites/ PermissionModel->CachePermissions(0)09 Dec 2015 - 17:34:14 Garden #7 /var/www/sites/ UserModel->DefinePermissions(0)09 Dec 2015 - 17:34:14 Garden #8 /var/www/sites/ Gdn_Session->Start(false, false)09 Dec 2015 - 17:34:14 Garden #9 /var/www/sites/ Gdn_Auth->StartAuthenticator()09 Dec 2015 - 17:34:14 Garden #10 /var/www/sites/ require_once('/var/www/sites/...')09 Dec 2015 - 17:34:14 Garden #11 {main}^X<

Any ideas?


  • I ended up doing a fresh install and copying over my config, plugins, themes, and a couple other directories I had customized. This seemed to work, although it would be nice if I could have just moved the whole directory.

  • LincLinc Detroit Admin

    Your database connection info probably needed to be updated in conf/config.php.

  • That was one of the first things I checked, and then I double checked, and then I triple checked, but it wasn't the case.

  • hgtonighthgtonight ∞ · New Moderator
    edited December 2015

    Did you try clearing out your cache folder?

    EDIT - Just realized your issue was resolved.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Yes, I had tried clearing the cache folder as well. That solution didn't work. Again, I was able to resolve through creating a fresh install, but I really wish I didn't have to go that route.

  • LincLinc Detroit Admin

    @MaddawgX9 said:
    I was able to resolve through creating a fresh install

    Unfortunately that doesn't tell us much about root cause. That just covered up whatever the issue was. I'm glad it's sorted, but there's not much to follow up on here as far as improving things to work smoother.

  • I suspect that it was an issue with database initialization. I had created the correct user account and given it access to the mysql db, but I think some db initialization occurs when you first set up the site and enter db info/admin info/config stuff. All I had to start and a blank database in mysql and I had given full access to it for the vanilla forums user account. Apparantly this wasn't enough for an already-configured vanilla forums.

    I know this because after I did a fresh install and got it working, I deleted the vanilla forums (left the db as-is), and copied over my version and it worked fine.

    I wonder...does the config automatically come up if config.cfg is not found? Perhaps all I needed to do was delete my config page?

Sign In or Register to comment.