Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Novice cannot enable Conversations/private messaging add-on

Novice here, admin for our forum. We had to migrate from a previous Vanilla Forum because our admin literally died in his sleep with all domain/hosting passwords. 35 years old. Anyway, on the "Conversations" (i.e., private messaging) feature, I have that add-on enabled, but when you try to send a message, then you hit "submit," you get a big, angry emoticon, and this message: "Something has gone wrong. We've run into a problem and are unable to handle this request right now. Please check back in a little while."

We have installed version 2.2.1. Is there a known issue, or am I overlooking something incredibly simple?


  • Options
    help_mehelp_me New
    edited November 2016

    That's a great question! I have the same problem!

    Surely someone here has the answer!!!

  • Options
    help_mehelp_me New
    edited November 2016

    Novice/Old Man, do not look so angry.

    I know a nice person on here will come to our rescue!

  • Options

    Old Man, I would like to private message you right now!!!

    But, alas, I cannot!

  • Options

    Private messaging is such a basic functionality of any forum-hosting software.

    I'm sure it is a very, very simple thing that you and I do not have sufficient brain cells to understand.

    Someone with much gray matter will soon comment, and show us how stupid we are!

  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP


    Try searching this forum for 'something has gone wrong' and you will see many. many threads explaining the steps you need to take to find the actual error message.

    If you don't understand that error message, post the details here and someone will try to help you.

  • Options

    My condolances for his family and friends.

    Of course, you can never anticipate on people dying so young, but for the future might I suggest using a password manager like Keepass to store important passwords?

    People move away, or maybe even leave after a falling out all the time. It's important that multiple people have access to the passwords to prevent things like this happening in the future.

    I'd start by disabling all plugins and themes and then if private messages can be send reenabling them one by one until you get the error again.

    Also add this line to config.php $Configuration['Debug'] = TRUE; to enable better error messages.

  • Options


    BTW, I'm sure you know that Old Man and help_me are one in the same.

    Old Man is so old he lost his password for this help forum, so used an alt email to change names.

    Thanks for not being put off by my sad effort at humor.

    Will try your suggestions and report back.

  • Options

    Disabling the plugins does not seem to work. Enabled the debugger, and got this error message: AssetModel::CssPath() with direct paths is deprecated . . . /public_html/library/core/functions.general.php line 913

    Could this be related?

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    This is only a notice and you can ignore it.

    With the debug config set, you should try to write a message (since that is what isn't working) and see if you can find more information about the error this way.

  • Options

    Duh. =)

  • Options
    help_mehelp_me New
    edited November 2016

    OK, got this:

    The error occurred on or near: /home/ . . . . . /public_html/library/database/class.database.php

    418: $this->closeConnection();
    419: continue;
    420: }
    422: trigger_error($message, E_USER_ERROR);
    423: }
    425: }

    Again, to remind, this is the error we get when hitting submit on a private message (i.e., conversation). Correct window comes up, you can type your message, and then when you hit submit the error occurs.

  • Options

    Do you need the "backtrace" and "variables" portions?

  • Options

    /public_html/library/database/class.database.php:422] PHP::trigger_error();
    /public_html/library/database/class.sqldriver.php:1663] Gdn_Database->query();
    /public_html/library/database/class.sqldriver.php:1083] Gdn_SQLDriver->query();
    /public_html/applications/conversations/models/class.conversationmodel.php:505] Gdn_SQLDriver->insert();
    /public_html/library/core/class.form.php:2224] ConversationModel->save();
    /public_html/applications/conversations/controllers/class.messagescontroller.php:96] Gdn_Form->save();
    /public_html/applications/conversations/controllers/class.messagescontroller.php:96] MessagesController->add();
    /public_html/library/core/class.dispatcher.php:329] PHP::call_user_func_array();
    /public_html/index.php:44] Gdn_Dispatcher->dispatch();

  • Options

    Variables in local scope:
    [Sql] 'insert vf_Conversation
    (InsertUserID, DateInserted, InsertIPAddress, UpdateUserID, DateUpdated, UpdateIPAddress)
    values (:InsertUserID, :DateInserted, :InsertIPAddress, :UpdateUserID, :DateUpdated, :UpdateIPAddress)'
    [InputParameters] array (
    ':InsertUserID' => '3',
    ':DateInserted' => '2016-11-04 17:34:21',
    ':InsertIPAddress' => '',
    ':UpdateUserID' => '3',
    ':DateUpdated' => '2016-11-04 17:34:21',
    ':UpdateIPAddress' => '',
    [Options] array (
    'Type' => 'insert',
    'Slave' => NULL,
    'ReturnType' => 'ID',
    [ReturnType] 'ID'
    [tries] 2
    [try] 0
    [PDO] array (
    [PDOStatement] array (
    'queryString' => 'insert vf_Conversation
    (InsertUserID, DateInserted, InsertIPAddress, UpdateUserID, DateUpdated, UpdateIPAddress)
    values (:InsertUserID, :DateInserted, :InsertIPAddress, :UpdateUserID, :DateUpdated, :UpdateIPAddress)',
    [ex] array (
    [message] NULL
    [code] NULL
    [state] '00000'

  • Options

    I should also clarify: this is not a problem with just one user. It is a problem for every person on the forum. No one can initiate a conversation/send a PM.

  • Options

    I have found this value:

    ->column('Contributors', 'varchar(255)')

    Is this the culprit?

  • Options


    I put a "null" value in after the varchar(255) line in the structure table.

    I also upgraded the PHP from 5.4 to 5.6.

    As a rookie, I did not know to go in and disable an then re-enable the Conversations Application to see if some of these fixes worked. I did these two things to no effect, and then when I re-booted the app it was fine.

    So, I can't tell you which of these fixed it, but one of them did.

  • Options

    I'd say it's the disabling and reenabling that did it, possibly combined with the php upgrade.
    Glad it worked out!

  • Options
    hgtonighthgtonight ∞ · New Moderator

    It sounds like your DB wasn't all there. Generally speaking, disabling and reenabling runs the structure methods (which make sure the DB has the fields you are looking for). You can also look for structure changes by visiting /utility/structure.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

Sign In or Register to comment.