Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Just upgraded all pages not loading going back to index :(

UKguyUKguy
edited December 2016 in Vanilla 2.0 - 2.8

https://lowpricehosts.com/ please look and help me resolve any help would be much appreciated i thank you for your time.
Upgraded using softaculous. Anyone know what the error is please need to fix urgently.

I can not access admin page either.

«13

Comments

  • omg why did i upgrade :( tried all php versions too help!

  • Upgrade destroyed my forum ah

  • done this: Cache folder , delete all .ini files

    Clear local cache too

  • i can access the admin page now will just restore i guess, upgrading should help improve my site not destroy it..

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    @sz1hosting

    Using an auto installer really isn't a good idea.

    Have you checked that you have PHP 7 installed?

    UKguy
  • i have php selector i own the hosting company i have gone back to 2.2 i haven't got time for this, thank you for the reply i will wait till there is a stable release or better instructions. doesn't work with any php version and i have then all 1 click php changer. Must be something i am missing in the upgrade process or just a bug?

  • Sorry did drive me kindah mad lol a bit frustrated ^_^

  • This is why you should never blindly update on a production server!

    UKguy
  • Very nice lol this is why vanilla shouldn't release updates without testing it properly but hey i get it free so i still love vanilla not as if i could code this all up my self i appreciate the work people do on vanilla just got a bit frustrated.

  • x00x00 MVP
    edited December 2016

    what makes you think they haven't tested it properly?

    It has been through a long beta test, and release candidate it has been tested for many months. Apha testing over years.

    Note they can only test the core, they can't test against thing like your own themes or third aprty plugins, which may be out of date. Vanilla is flexible and for the flexibility have to be prepared to get your hands dirty.

    Using softaculous is not advised becuase, it relies on their installer being correct an up to date. Beter to install or update following the instructions given by the core team.

    I think if you own a hosting company (I presume shared hosting), you mush have some server management skills. You would know how to look at your error logs.

    Like Swennet says, you should do dry runs. Any server software in a important production environment, it the done think to have a work flow such as dev, stagigng and production steps. A professional would do this, rather than just install in a production environment.

    If you have this trouble, how do you deal with your customer questions?

    grep is your friend.

    UKguy
  • I fixed the error i own over 10 dedicated servers and 5 cpanel nodes, the problem was i like to use softaculous so that is where the issue is from, i like to do things the easy way and so do my customers :) i own over 5 hosting companies and yes i am not the most advanced, will just stick to 2.2 for now as time is money you see.

  • UKguyUKguy
    edited December 2016

    @x00 said:

    If you have this trouble, how do you deal with your customer questions?

    I have advanced technicians for difficult stuff but can not ask them to fix my personal site need to do that myself, if your so clever how to fix the issue as you clearly have no clue and you are telling me to check error logs and enable debugging because you have no clue yourself mr super genius ^_^

  • Everything goign back to index implies a routing issue. Again server admin skill can help. You are running nginx, look at your server rules. Are you using reverse proxy.

    Note have even read the release note as to which environment are tested on? It rans on many environment including nginx, however that depends on the setup e.g. reverse proxy and so forth.

    You run a hosting company, do you no have sever admins that can do this or are you a re-seller selling packaged cheap hosting?

    grep is your friend.

    UKguyRiver
  • @x00 said:
    Everything goign back to index implies a routing issue. Again server admin skill can help. You are running nginx, look at your server rules. Are you using reverse proxy.

    Note have even read the release note as to which environment are tested on? It rans on many environment including nginx, however that depends on the setup e.g. reverse proxy and so forth.

    You run a hosting company, do you no have sever admins that can do this or are you a re-seller selling packaged cheap hosting?

    Thank you for replying btw your info has been helpful, i run nodes selling VPS ovz kvm all sorts been doing it for years, the only time i get issues is with stuff like this. Well basically the upgrade process is not working for me with any php version so i give up. Using apache 4 with all plugins and mods needed. Can you point me to the upgrade instructions for 2.3?

  • And if the mods could update softaculous so it doesn't break the forum? Login softaculous and update that is what needs to be done i don't like doing things manually i like an easy life. Click click done! I know i must sound like a right douche sorry haha

  • @sz1hosting said:

    I have advanced technicians for difficult stuff but can not ask them to fix my personal site need to do that myself, if your so clever how to fix the issue as you clearly have no clue and you are telling me to check error logs and enable debugging because you have no clue yourself mr super genius ^_^

    You respond in a way, most people who are here as volunteer have no interest in responding to. Regardless of your frustration you should know better.

    Believe me I have more clue that you, it It not me that has trouble with upgrading. I develop on this platform, I have management many server for clients.

    The idea that you think that this software when through no testing, is ridiculous. I suggest you change your setup so you have a realease flow, so production environment is kept a stable as possible.

    grep is your friend.

    UKguyR_J
  • UKguyUKguy
    edited December 2016

    @x00 said:

    @sz1hosting said:

    I have advanced technicians for difficult stuff but can not ask them to fix my personal site need to do that myself, if your so clever how to fix the issue as you clearly have no clue and you are telling me to check error logs and enable debugging because you have no clue yourself mr super genius ^_^

    You respond in a way, most people who are here as volunteer have no interest in responding to. Regardless of your frustration you should know better.

    Believe me I have more clue that you, it It not me that has trouble with upgrading. I develop on this platform, I have management many server for clients.

    The idea that you think that this software when through no testing, is ridiculous. I suggest you change your setup so you have a realease flow, so production environment is kept a stable as possible.

    thanks for your time.

  • @sz1hosting said:
    And if the mods could update softaculous so it doesn't break the forum? Login softaculous and update that is what needs to be done i don't like doing things manually i like an easy life. Click click done! I know i must sound like a right douche sorry haha

    I'm not sure the core team are involved with softaculous. It also depend on whethe the softaculous version has been updated.

    grep is your friend.

    UKguy
  • someone delete this thread please i seem to have lost my mind.

Sign In or Register to comment.