Please upgrade here. These earlier versions are no longer being updated and have security issues.

Pockets plugin

This discussion is related to the Pockets addon.

Pockets plugin not working with 2.3

Tagged:

Comments

  • Just upgraded to Vanilla 2.3 - unfortunately, Pocket plugin does not work.
    I need assistant please.

  • I just setup my discussion board over the past couple of days using Vanilla 2.3 - I installed Pockets just last night and it seems to be working fine for me?

    http://cordcuttertalk.com/

  • ProsperProsper ✭✭
    edited May 2017

    @StanleyH - really, I don't think so. Pocket does not work on Vanilla 2.3.
    Are we (@Ionmarcu and @Prosper) the only ones having this problem.

    @Todd, @Linc, @vrijvlinder, @R_J, @whu606, @River, @hgtonight - assistance is needed please.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
  • ProsperProsper ✭✭
    edited May 2017

    @vrijvlinder - I tried the recently updated pocket - https://github.com/vanilla/addons/tree/master/plugins/Pockets. I got error message below;

    `Fatal Error in SettingsController.xsetHighlightRoute();

    The "SettingsController" object does not have a "xsetHighlightRoute" method.

    The error occurred on or near: /home4/xxxxxxx/public_html/library/core/class.pluggable.php

    172: // Make sure that $ActualMethodName exists before continuing:
    173: if (!method_exists($this, $ActualMethodName)) {
    174: // Make sure that a plugin is not handling the call
    175: if (!Gdn::pluginManager()->hasNewMethod($this->ClassName, $ReferenceMethodName)) {
    176: trigger_error(ErrorMessage('The "'.$this->ClassName.'" object does not have a "'.$ActualMethodName.'" method.', $this->ClassName, $ActualMethodName), E_USER_ERROR);
    177: }
    178: }
    179:
    180: // Make sure the arguments get passed in the same way whether firing a custom event or a magic one.
    Need Help?

    If you are a user of this website, you can report this message to a website administrator.

    If you are an administrator of this website, you can get help at the Vanilla Community Forums.

    Additional information for support personnel:

    Application: Vanilla
    Application Version: 2.3
    PHP Version: 5.6.29
    Operating System: Linux
    Server Software: Apache
    Referer: http://www.xxxxxxxxx.com/settings/plugins/all
    User Agent: Mozilla/5.0 (Windows NT 10.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36
    Request Uri: /settings/pockets`

    vrijvlinder
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Did you delete the old plugin before using the new one ?

  • ProsperProsper ✭✭

    No, I did not. I uploaded the new one to overwrite the old one.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Sometimes if a file is in the wrong place, you don't overwrite that one. It is best to disable, delete and re upload.

    This happened with the YAGA plugin. The author updated it and had changed the location of some files which did not get overwritten and made the plugin malfunction.

    Try that and report back.

  • ProsperProsper ✭✭

    Ok but will I loose the html files on have on the old Pocket plugin if I delete Pocket plugin first before uploading new one?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Save what you entered in the the old plugin, then delete the plugin. Yes you might lose it..

  • ProsperProsper ✭✭

    @vrijvlinder - it seems class.pocket.php file is missing.
    Can you take a look?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    No, it is there.. it is in the library folder of the pockets plugin. Please look at it at github. it shows every file and folder.

  • ProsperProsper ✭✭
    edited May 2017

    I have uploaed version 1.3 latest edited version from github, yet got this message;

    The addon could not be enabled because it generated a fatal error:
    Pockets is missing the following requirement(s): Vanilla 2.4.

    I edited

    'RequiredApplications' => ['Vanilla' => '2.4'],
    to
    'RequiredApplications' => ['Vanilla' => '2.3'],

    Still got the error information

    The addon could not be enabled because it generated a fatal error:
    Pockets is missing the following requirement(s): Vanilla 2.4.

  • ProsperProsper ✭✭
    edited May 2017

    It seems to work but clicking on setting button throws "Fatal Error page" shown below. Also both disabled and enable html codes already on the pocket plugin all seems enabled. Thiis just strange. What can I do next?

    Fatal Error in SettingsController.xsetHighlightRoute();
    The "SettingsController" object does not have a "xsetHighlightRoute" method.
    The error occurred on or near: /home4/xxxxxx/public_html/library/core/class.pluggable.php
    172: // Make sure that $ActualMethodName exists before continuing:
    173: if (!method_exists($this, $ActualMethodName)) {
    174: // Make sure that a plugin is not handling the call
    175: if (!Gdn::pluginManager()->hasNewMethod($this->ClassName, $ReferenceMethodName)) {
    176: trigger_error(ErrorMessage('The "'.$this->ClassName.'" object does not have a "'.$ActualMethodName.'" method.', $this->ClassName, $ActualMethodName), E_USER_ERROR);
    177: }
    178: }
    179:
    180: // Make sure the arguments get passed in the same way whether firing a custom event or a magic one.
    Need Help?
    If you are a user of this website, you can report this message to a website administrator.
    If you are an administrator of this website, you can get help at the Vanilla Community Forums.
    Additional information for support personnel:
    Application: Vanilla
    Application Version: 2.3
    PHP Version: 5.6.29
    Operating System: Linux
    Server Software: Apache
    Referer: http://www.xxxxxxxxxx.com/dashboard/settings/emailstyles
    User Agent: Mozilla/5.0 (Windows NT 10.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14393
    Request Uri: /settings/pockets

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    @Prosper said:
    Just upgraded to Vanilla 2.3 - unfortunately, Pocket plugin does not work.
    I need assistant please.

    "Does not work" is hard to debug. I used the old 1.1.2 version and it did work for me. Now I've installed the version 1.1.3 and it is still working.

    Afterwards I've tried version 1.2 from https://github.com/vanilla/addons/archive/release/2.2.zip which is also working for me.

    The most current version from GitHub, which explicitly states that it needs 2.4, is not suited for your 2.3 forum.

    So please delete the current folder /plugins/Pockets, download the version 1.2 from here (I have just uploaded it) and tell us what "not working" means in detail.


  • ProsperProsper ✭✭

    Pocket version 1.2 just updated few hours ago works.
    Problem solved.
    Thanks @vrijvlinder, @R_J , @StanleyH

    R_J
  • Hi Guys, I tried to delete and disabled the plugin (Pockets) before installing the latest version at the moment with latest vanilla forum but the plugin doesn't seem to show the updated version. Is it because of cache? How do we delete the cache? I need some tip. Thanks.

  • Will try this out. Be right back.

Sign In or Register to comment.