Users cant edit own posts [RESOLVED]

jhayes88jhayes88 New
edited January 28 in Vanilla 2.6 Help

Hi. I have an issue and yeah I've checked google. When members post, they can't edit. Even immediately after posting. Under posting options in the dashboard, it is set to "Authors may always edit".

What do I need to do to allow them to edit their own posts? In the forum permissions, when I set the member role to edit, they can edit other users posts and I don't want that.

Thanks!!!

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator
  • jhayes88jhayes88 New
    edited January 27

    Tried that. Changing it to 5 minutes didnt work. Tried 5min and reposted. Didn't work. Tried 15min and reposted. Didn't work. Set it to -1 in the config file and tried again. No luck. My member account can't edit its own posts.

  • jhayes88jhayes88 New
    edited January 27

    The issue they had was actually different than mine. They stated that when a normal user clicked on the edit link, it took them to a 404 page. With my forums, there's no edit option for normal users. This isn't a feature that had been modified.

    Admins can edit their posts, but for normal users there's no edit option despite having it enabled in the post settings, so I'm confused. Is it possible for normal members with vanilla forums to edit their own posts? Because enabling that option doesn't work.

  • LincLinc Director of Development Detroit Vanilla Staff
    edited January 27

    This is the second time I've seen someone say members get a 404 on the edit link. If the edit link is present for them, then Vanilla appears to be respecting your time limit - otherwise it would hide the link entirely. Even if you pasted an "Edit" link into a discussion for them to try clicking, it should trigger a 403 (Permission) error, not a 404.

    I suggest going to the default theme and disabling any third-party addons you have enabled and try again.

  • I feel like an idiot. I feel stupid for making this post. Suggesting I disable third party add-ons helped me narrow it to the gamification application aka yaga. It has a ranks feature and the lower ranks can't edit their posts. Fixed that.

    If anyone else has this issue and you have the application YAGA installed, check that.

    R_J
Sign In or Register to comment.