Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

ButtonBar v1.1 released!

This discussion is related to the Button Bar addon.


  • that'll probably be it - no i dont. doh.
  • jspautschjspautsch Themester ✭✭✭
    that'll probably be it - no i dont. doh.
    Don't feel bad, I didn't even know it was a plugin. ;)
  • Back to my issue - willing to pay someone to get this thing working for me. Shoot me a pm if interested. Riches beyond imagining.
  • jspautschjspautsch Themester ✭✭✭
    edited November 2011
    Any chance we could have a look at the forum? Might be able to see what's going on.
  • I did a test install and buttonbar works fine so It must be a JS conflict. Other wysiwygs work fine though.

    The problem version is at - this isn't live or open to the public yet so you wont be able to sign up although I could create an account for anyone that wanted a closer look.
  • I figured it out... for some reason ButtonBar doesn't like my non-default theme. Switching to the default "Vanilla" theme makes it work. Hmm. I'm using public_vforg by the way.
  • Fixed! I was using a custom comment.php in my theme's design/views/post/comment.php. I copied the version over from applications/vanilla/views/post/comment.php, inserted the code I needed to, and now it's working... almost. Now it works, but only if I click somewhere on the page. Not sure why that'd be...

    @DirtyDog, hopefully that's what's wrong on your end too.
  • Upon further investigation, if the "Quote selection" plugin is enabled, the button bar works properly after I click somewhere on the page (and after doing the fix I mentioned above). If it's disabled, the button bar doesn't work at all.

    I later found out that after disabling the WhosOnline plugin, that issue no longer occurs and I don't have to click in order for the ButtonBar to start working... it works right away.

    Now, a while back I modified the WhosOnline plugin JS file as explained here, to fix an infinite loop issue:

    After reverting that change, everything works perfectly together, even if the WhosOnline plugin is enabled -- however, the infinite loop issue with the WhosOnline plugin still exists, unfortunately. According to someone else, the infinite loop issue is probably being caused by the theme I (and others) are using (not sure if this is true).

    So it's looking like this is a theme-related issue again. Hope I wasn't too confusing in my post.

    Side note, @Tim, it'd be cool if the button bar was disabled (or better yet, hidden) when "previewing" a post.
  • ShmizzleShmizzle New
    edited November 2011
    Figured it out! In my theme's .tpl file, it had custom HTML inside of <div id="Foot"></div>, but no {asset name="Foot"}. After adding {asset name="Foot"} in between the "Foot" div, everything seems to be working perfectly now (knock on wood).
  • For those interested, I modded my discussion.js file to hide the bar when previewing, and re-show it when the user clicks the "write" tab again by adding $(".ButtonBar").hide(); and $(".ButtonBar").show(); in (what looks to me like, and seems to be) the right positions in said discussion.js file.

    I put the $(".ButtonBar").hide(); after line 166 (v2.0.18.1), directly underneath the following lines of code:

    // Remove any old errors from the form $(frm).find('div.Errors').remove(); if (json.FormSaved == false) { $(frm).prepend(json.ErrorMessages); json.ErrorMessages = null; } else if (preview) { $(frm).trigger('PreviewLoaded', [frm]); $(parent).find('li.Active').removeClass('Active'); $(btn).parents('li').addClass('Active'); $(frm).find('#Form_Body').after(json.Data); $(frm).find('#Form_Body').hide();

    And I put the $(".ButtonBar").hide(); after line 24 (v2.0.18.1), directly underneath the following lines of code:

    // Reveal the textarea and hide previews. $('a.WriteButton, a.Cancel').livequery('click', function() { if ($(this).hasClass('WriteButton')) { var frm = $(this).parents('.MessageForm').find('form'); frm.trigger('WriteButtonClick', [frm]);

    @Todd, et al, do you think there's a better way to do this or a better place to put the .hide and .show?
  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭
    looks like @Shmizzle is after button-bar today

    Theme Charcha for great desktop and mobile experience! - drop me a message :)

  • looks like @Shmizzle is after button-bar today
    Yeah, I did it for the riches beyond imagining.
  • going back to the spoiler/bbc discussion. If I enable BBC and open a new discussion and try to use the spoiler tag I get this
    <div class="UserSpoiler"><div class="SpoilerTitle">Spoiler: </div><div class="SpoilerReveal"></div><div class="SpoilerText">adf</div></div>
    I tried to use the spoiler tag around the text "adf".

    I get this when using the quote button
    <blockquote class="UserQuote"><div class="QuoteText"><p>afdfad</p></div></p></div></blockquote>

    and nothing happens when I use the link button
  • ok, so I changed my format to BBCode, then back to HTML code. But now when you start a new discussion the buttons on the button bar are broken. The bar works fine as an HTML bar in old threads.... Any ideas?
  • I've also installed a fresh version of the button code.
  • TimTim Operations Vanilla Staff
    When you're in BBCode mode and are starting a new thread, examine your page using FireBug or Chrome's Toollbar. Look at the Foot element of the page, found here:
    body #Frame #Foot.

    Inside that you should find the #Definitions at div #Definitions.
    What does the "InputFormat" definition contain?

    Vanilla Forums Senior Developer [GitHub, Twitter,]

  • edited November 2011
    I will check that when I get home....
    With it set back to html, no old threads that you post in will accept any html, but it has the html buttonbox
    A new thread still has a BBCode box, but it isnt' usable.
    Also if you try to use the HTML box in an old thread the code and link buttons place the actually text box code in the very top along side the links to "dashboard discussions activity etc" this is using the imbeded theme.

    And to repeat this button box did work before I tried to change it to bbcode.
  • the bittonbar is not showing on "sent message" direkt to a user, or in editing an post which had been postet before. its just for new postings working. any hint? thx

Sign In or Register to comment.