HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Can I turn off 'Activity' and 'Inbox' (private messages)?

nicepaulnicepaul
edited August 2012 in Vanilla 2.0 - 2.8

Can't find a way of turning this stuff off to simplify the forum.

I can revoke Members' permission to see the Activity, but I can't remove the link from the navigation (no option to do so, not enough CSS hooks to hide it), and they just see a 'permission denied' page if I do that.

thanks,
Paul

Comments

  • $Configuration['Garden']['Profile']['ShowActivities'] = FALSE;

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • In /conf/config.php?

    That's already set to False.

  • $Configuration['EnabledApplications']['Conversations'] = '';

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • That worked for the Inbox, thanks!

    peregrineUnderDog
  • if the activity link still shows and you want to remove it - modify your theme

    in default.master.tpl or default.master.php - search for activity and comment it out.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDogjone68cools
  • Thanks!

    Had a dig around, found that in /themes/mytheme/views/default.master.php

    UnderDog
  • LincLinc Detroit Admin
    edited August 2012

    For the Inbox, the saner way is to simply go to "Applications" in your Dashboard and turn off the Conversations app.

    peregrine
Sign In or Register to comment.