Please upgrade here. These earlier versions are no longer being updated and have security issues.

About the Vanilla 2.1 release cycle

24

Comments

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    @Pixelian

    No.

    KasperUnderDog
  • OlivawOlivaw New
    edited December 2012

    @newhorizonte said:
    I would like to know the brand new things that will come with the 2.1 :-(

    I'm curious like a monkey :-)

    aery
  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    @Olivaw

    So get the latest version from Github and have a play...

  • edited March 2013

    did a backup of one of my bigger forums (200+mb db) and installed locally to play around and I must say I am really liking it.

    as per usual, I first deactivated all the plugins that don't ship with the software just to avoid the surprise compatibility issues.

    In case it helps someone else testing - the only catches I had during the upgrade were
    - user error caused - did not visit the upgrade script first and I had to manually add the column "AllIPAddresses" to gdn_user to get around it
    - minify needs to stay disabled. causing issues when enabled
    - had to change library/core/class.controller.php: if ($DebugAssets) to: if (!$DebugAssets) to get styles to load on the local host (as per this post)
    - the facebook & twitter icons in the social admin panel are not loading ** it is because I don't have curl enabled on my test server **

    Anyway, testing it and it is really snappy. Looking forward to the gold release!

    aeryUnderDog
  • LincLinc Senior Bard Detroit Admin

    Minify should be deleted. It has been removed from core.

    You'll want to set $Configuration['DebugAssets'] = TRUE; in your config rather than changing the class.controller.php.

    Thanks for relating your experience! Useful to know.

  • Thanks @Lincoln!

    I know better than to edit core - Just did it in a hurry :) Thanks for the tip and of course all you guys do around here!

  • Hi guys, long time no see :) I was holding off on upgrading to Vanilla 2 from Vanilla 1 because of the bug where if you post a comment it shows up twice. I installed the latest version today and it still happens.
    Is the bug still in the latest code? Thanks

  • LincLinc Senior Bard Detroit Admin

    @SubJunk We haven't seen this bug. Can you break down how it's happening?

  • A user submits a post and it appears to them twice.
    The duplicate is gone when they or anyone else goes to the page again. I haven't looked into it since I didn't want to fix it if it had already been fixed, but I'm guessing it happens when the user submits their comment at the same time as the ajax check for new comments (which I have set at 10 seconds), which would explain the appearance of two new posts.

  • LincLinc Senior Bard Detroit Admin

    Ah. We disabled the auto-refresh feature because of some issues like that one. I'm not sure if we just hid it or really disabled it. In any case, I'm sure it could use some TLC before it returns.

  • @Lincoln just curious, im having a self-hosted vanilla, and it's a huge community im handling. i wanna know if this new release is much lighter for self-hosted vanilla ?

  • LincLinc Senior Bard Detroit Admin

    @fr3333333x Yes, there was a lot of SQL query optimization done. Also, if you're using memcached, there's a lot more support for caching too.

  • @Lincoln i cant wait for the new release :D

    aery
  • @Lincoln: Ah I see, I'll disable the auto-refresh and see if that fixes it. I just had another similar bug happen where the whole thread (8 replies) got returned and printed on the screen so there were duplicates of everything, so I assume that is related to the auto-refresh too. Cheers!

  • ZhaanZhaan Professional fool ✭✭

    Ugh, I'm dying to get my dirty hands on 2.1 D:

  • ZhaanZhaan Professional fool ✭✭
    edited January 2013

    By the way.. does anyone have a 2.1 test site running somewhere? I'm not at home this month, so I can't set up one myself.

  • stilfxstilfx New
    edited January 2013

    After installation ( Version 2.1a33 ) I can get to the dashboard, but not the forum index — error:

    Class Smarty not found while trying to get an object for Smarty. Check the path /home/XXXXXXX/public_html/forum/library/vendors/Smarty-2.6.25/libs/Smarty.class.php.

  • GaryFunkGaryFunk Senior Application Developer ✭✭

    @Zhann I have 2.1 up at http://4sqbadge.com/

  • I see strange behaviour after installing 2.1 on localhost (xampp):
    First, after succesful instalation, I have created 4 new discussions, next trying to add some comment to any of this discussion, but it doesen't adding it, when I click "Post comment" button, it show full list of topics (in single discussion page), but comment is not added.
    Example:
    http://imgur.com/a/HgceF

Sign In or Register to comment.