Please upgrade here. These earlier versions are no longer being updated and have security issues.

Users to edit own posts?

Hi,

Vanilla 2.1

I am trying to fathom roles and permissions but I think I need a little help. I'd like users to be able to edit their own posts for 1hr. I can see the drop down list in advance but it won't stay on any of the options apart from 'users may never edit'. When selecting another option, you click save, go off the page and back again and it returns to users may never edit.

I have tried to set the edit in the roles and permissions but it allows users to edit all posts.

Can anyone here give me any instruction as to how to allow users to edit their own posts only please?

Thank you!

UnderDog

Comments

  • use Always Edit plugin..

    http://vanillaforums.org/addon/1249/always-edit

    i'm currently using that plugin to one role members could edit their post any time :D

    UnderDog
  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    @Lilylu‌

    That setting should work, so something needs changing in your Vanilla set up.

    What does this line in conf/config.php say?

    $Configuration['Garden']['EditContentTimeout'] = '350';

    I think for one hour it should be 3600

  • Hi whu606,

    Thank you for your help :)

    Mine says 900 - have changed to 3600 however drop down still won't stay on one hour and no cogs appear for posters. Do I need to change anything in my dashboard settings?

  • LilyluLilylu New
    edited August 2014

    I have no idea why it's added stars in place of the word h e l p!

  • hgtonighthgtonight ∞ · New Moderator

    Help and save appear to be blocked?

    help
    save
    test

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • hgtonighthgtonight ∞ · New Moderator

    @Lilylu do you have a caching system enabled?

    Are you able to change other configurations?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    peregrine
  • caching was the problem with the last user. as hgtonight seems to be eluding to.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Hi peregrine :D:D

    Yes hgtonight I can change all sorts of things, I can allow users to edit posts in permissions but it allows them to edit all posts not just their own, so I definitely get changes to show on the forum itself.

    Where do I enable caching? Have deleted my ini files in the past on the server.

    Are members supposed to be able to edit their own posts by default? I can see how it works on this forum as you can edit up to 15 minutes which is perfect.

    I read the other members post who had a similar issue, and I too can change the discussion / comment per page but there didn't seem to be a resolve there.

    What should I try next do you think?

  • if you want to troubleshoot and debug.

    follow instructions in this link:

    http://vanillaforums.org/discussion/26786/tutorial-how-to-enable-a-debug-log-and-collect-debugging-information

    AND also do this - after you did the above.

    change this  around line 200  applications/vanilla/views/discussion/helper_functions.php
    
    $TimeLeft = '';
    
    
    
    to 
    
    $TimeLeft = '';
    
     LogMessage(__FILE__,__LINE__,'Object','Method',"my timeout is $EditContentTimeout and can edit is  $CanEdit");
    

    e.g. if my config says:

    $Configuration['Garden']['EditContentTimeout'] = '14400';

    my advanced edit pages

    says users my edit for 4 hours.

    21 Aug 2014 - 20:12:40: [Garden] /var/www/vanilla/applications/vanilla/views/discussion/helper_functions.php, 201, Object.Method(), my timeout is 14400 and can edit is

    when i click on one of my discussions (one that I posted) on the discussion listings page

    21 Aug 2014 - 20:13:17: [Garden] /var/www/vanilla/applications/vanilla/views/discussion/helper_functions.php, 201, Object.Method(), my timeout is 14400 and can edit is 1

    what do you get when you set the config statement to

    $Configuration['Garden']['EditContentTimeout'] = '14400';
    

    and then setup debug logging.

    what log message do you get.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Just wanted to post in case anyone else had this issue. My hosting company hard coded a line in my config file as one of the plugins (don't know which one) seemed to have broken something. Its all working now and members can post for up to 1 hour :) Thank you everyone here for helping!

  • rustmanrustman New
    edited November 2014

    I'm having the exact same problem!

    How did you fix it Lilylu? Your hosting company added a line to vanilla config.php?

    I've been able to fix it with always edit plugin, without it any option I choose in Forum>Advanced reverts to 'users may never edit'.

  • peregrineperegrine MVP
    edited November 2014

    @rustman said:
    I'm having the exact same problem!

    How did you fix it Lilylu? Your hosting company added a line to vanilla config.php?

    I've been able to fix it with always edit plugin, without it any option I choose in Forum>Advanced reverts to 'users may never edit'.

    what does it say for

    $Configuration['Garden']['EditContentTimeout'] =

    in your config.php

    post your config.php (minus any personal info like passwords, email, etc)

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    kelime
Sign In or Register to comment.