Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.

Vanilla is proud to present version 2.2

LincLinc Director of DevelopmentDetroit Vanilla Staff
edited November 2015 in Releases

Vanilla 2.2 - the stable gold release - can now be downloaded. The upgrade instructions are in the README.md as part of the download.

Vanilla 2.2 requires PHP 5.3. This is a change from the 2.1 series which only required PHP 5.2. The next release (2.3) will require PHP 5.4. We strongly recommend upgrading to PHP 5.6 as soon as possible. Contact your host and request it if you don't have control over it. It's IMPORTANT!

Critical upgrading notes:

  • You must follow the normal upgrade process, including running /utility/update.
  • You CANNOT DOWNGRADE after upgrading because 2.2 contains a change in password hashing that is irreversible. You would lock yourself (and anyone else who's logged in since the upgrade) out of your account by downgrading.
  • If you are using a locale, please note the naming standard changed in 2.2 so you MUST update your locales as well.

We strongly recommend testing your plugin and theme compatibility in a safe place before upgrading your production forum.

IF YOU HAVE TROUBLE UPGRADING AND NEED ASSISTANCE, PLEASE START A NEW DISCUSSION. If you are a developer and locate a reproducible issue, please file it on our GitHub tracker, noting your version as 2.2 exactly. We greatly appreciate the assistance.

Support for 2.1 ends immediately. Please upgrade to 2.2 as soon as possible.

TimphreakJoZ3_69wptolikVizionStudios2steamDr_SommerpdqlinuxtrinadorMakke375VanillaplusVisionStudioschriskingPamelaItsVizionTv

Comments

  • Just Thanks for That Nice 2.2 Version I'm Just Happy!!

    LincAdrian
  • chanhchanh OngETC.com - CMS Researcher ✭✭

    Sound great! Thanks for the effort to get this out.

    LincAdrian
  • Thank you for this great work !!

    LincAdrian
  • Great stuff guys, thanks!

    LincAdrian
  • brilliant, thank you!

    LincAdrian
  • "Upgrade was a success"

    yeSSSSSSS.

    Thank you so much for your work!

    LincAdrian
  • phreakphreak VanillaAPP - Your white label app for Vanillaforums MVP

    Amazing work! Thank you all DEVs and BugSquashers

    LincAdrian
  • JasonBarnabeJasonBarnabe Cynical Salamander ✭✭

    Is the password hashing the only thing that prevents downgrading? I use jsConnect only, so I assume that's not an issue for me.

  • LincLinc Director of Development Detroit Vanilla Staff

    @JasonBarnabe said:
    Is the password hashing the only thing that prevents downgrading? I use jsConnect only, so I assume that's not an issue for me.

    Should be. And yes, using jsConnect would circumvent that issue.

    But you should also know that downgrading makes the Vanilla gnomes cry.

    R_J
  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    A great ThX to the Devs and the Community... :+1: :pleased:

    LincAdrian
  • FerrariSteveFerrariSteve Seattle
    edited November 2015

    Many thanks! Had a bit of trouble on the upgrade, but the issue was two pesky plugins (CloudFlare Support and Logger) and now seems to be up and running smoothly. :)

    LincAdrian
  • Upgraded without any obvious hitches, and all plugins seem to be operational. Great work - I love the sleek button bar.

    LincAdrian
  • Wow, thank you! It's tiime to plan some updates… B)

    LincAdrian
  • What do I do when I get the "Something has gone wrong"-screen and there is no debug info despite the plugin being enabled? Upgraded to php 5.5, fresh install to avoid plugin issues, I can get to the dashboard no problem, but not the forum, no matter what I do. Suggestions?

  • LincLinc Director of Development Detroit Vanilla Staff

    @defilor said:
    What do I do when I get the "Something has gone wrong"-screen and there is no debug info despite the plugin being enabled? Upgraded to php 5.5, fresh install to avoid plugin issues, I can get to the dashboard no problem, but not the forum, no matter what I do. Suggestions?

    Start a new discussion after following this guide: http://docs.vanillaforums.com/developers/troubleshooting/

  • Any link to read on locales standard change? Can i suggest a template en_US locale file in locales folder so we can have a base to work on?

  • I'll answer myself about locale. My locale (Slovenian) works as it did on 2.1 so no change there.

    And maybe my experience about going from 2.1.13p1 to 2.2 on test env (Ubuntu 14.04 with php 5.5.9) - all went well. I did follow peregrines fool proof tutorial.

    Only issues for me are Resized Image Lightbox does not work for some reason, Quotes work but they are in Reactions area and i prefer them in the commentinfo area. Other working plugins are: Add Registration Question, All Viewed, CommentsRSS, Jump to Top, Role Titles, Split/Merge.

    P.s. Did anyone upgrade on PHP 5.3? Is there a checkbox in the dashboard do disable file uploads? Or is that only possible by editing config.php?

  • peregrineperegrine MVP
    edited November 2015

    @CrazyLemon said:

    P.s. Did anyone upgrade on PHP 5.3? Is there a checkbox in the dashboard do disable file uploads? Or is that only possible by editing config.php?

    for options in dashboard.

    you would need to enable either advanced editor or fileupload plugin.

    if you enable file upload plugin - you may have more control on uploads and downloads permissions in roles.

    with advanced editor there is not as much control via dashboard for both uploads and downloads. Advanced editor is not as fine-grained in this regard.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • edited November 2015

    I only have editor (advanced editor) enabled and i saw 2 entries in config.php.
    Even tho there is no file upload directory in plugins/ there is an entry $Configuration['EnabledPlugins']['FileUpload'] = false;
    The one i changed was $Configuration['Garden']['AllowFileUploads'] = false; (default is true) which then affects advanced editor (no more upload image button).

  • Using Advanced Editor, WYSIWYG mode ... the 'Quote' button now strips out all BR tags and the link to the person that said the last thing, in the new quote.

    Fixable?

  • @Simeon_Griggs said:
    Using Advanced Editor, WYSIWYG mode ... the 'Quote' button now strips out all BR tags and the link to the person that said the last thing, in the new quote.

    Fixable?

    ...actually this appears to only relate to pre-upgrade posts

  • XfronterXfronter New
    edited December 2015

    Failure

    The update was not successful.

    :(

    My Current Vesion - Version 2.1.11

  • LincLinc Director of Development Detroit Vanilla Staff

    @Xfronter Try reading the original post in this discussion.

  • RaizeRaize vancouver ✭✭
    edited January 2016

    I just upgraded from 2.0.18, the new forum looks sharp and works great with Bootstrap 2 theme.

    Linchgtonight
  • Hi there,

    could someone point to the documentation regarding this one - "If you are using a locale, please note the naming standard changed in 2.2 so you MUST update your locales as well.". Or maybe someone knows, how it should be renamed? Thanks!

  • hgtonighthgtonight ∞ · New Moderator

    @Minde said:
    Hi there,

    could someone point to the documentation regarding this one - "If you are using a locale, please note the naming standard changed in 2.2 so you MUST update your locales as well.". Or maybe someone knows, how it should be renamed? Thanks!

    From what I can tell, they dropped the country code and extra folder. For example, instead of /locale/en-CA/definitions.php it is now /locale/en.php.

    That said, I believe the line is telling developers that locales need to be updated as the crawling just spits out a notice on the current version of Vanilla.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Hello is this something to do with this update I been using Vanilla Forums with namecheap since the 1,0 update and after reinstalling my forums I'm now getting this error \/
    https://vanillaforums.org/discussion/31766/cant-get-in#latest

Sign In or Register to comment.