Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6.1 is here with critical security patches. One of them has been publicly disclosed.

Vanilla 2.3 release candidates (now: RC2)

LincLinc Director of DevelopmentDetroit Vanilla Staff
edited November 2016 in Releases

This is not the final 2.3 release. "Release candidate" is a final testing phase before it is considered production approved. Read about new features in the 2.3 beta discussion. It is possible this will be the final step before the final release of 2.3.

Download 2.3 rc1.

Download 2.3 rc2.

Report issues on GitHub by specifying that you are using the 2.3rc1 release or start a new discussion under the "Vanilla 2.3. Help" category.

Changes since beta:

  • Fix a security issue in Tagging (via @River).
  • Upgrade htmLawed to v2.1.22 (security fix).
  • Fix an issue with category depth during setup & category updating.
  • Fix default height & width of image uploads. (by DataTables)
  • Update Facebook API to use versioned endpoint.
  • Profile Extender: Improve Unicode character support & fix offset error.
  • Add BeforeCheckPreference event to ActivityModel. (by @R_J)
  • Updated README.
  • Default Garden.RewriteUrls to true (IMPORTANT: ability to NOT use rewrite is being removed in 2.4).
  • Fix MySQL version get.
  • Improve permission checks and messaging during initial forum setup.
  • Add an upgrade warning for PHP and MySQL to all settings pages.

Changes since rc1:

  • Fix data coercion error when managing categories.
  • Fix issue with stash().
  • Fire "CategoryWatch" as an event of CategoryModel.
  • Fix issues with index photos on mobile table layout.
  • Let messages accept a "Subject" parameter via URL & validate any username passed.
  • Add $Comment to EventArguments on DeleteComment.
  • Hide "Dismiss" option from guests.
  • Don't add NewDiscussionModule to postController (it didn't show anyway).
  • Correct field length of GDN_Tag.FullName.
  • Don't show Google+ login when not configured.
  • Prevent erroneous rendering when OpenID URL is invalid.
  • Fix conversations permission check when adding button.
  • Fix typo in style.css.
  • Fix signin popup displaying scrollbar when not needed.

Last call for issues and pull requests.

rbrahmsonphreakwptolikVivantRiverItsVizionTvhgtonightThemeSteam

Comments

  • LincLinc Director of Development Detroit Vanilla Staff
    edited October 2016

    If you take a look at 2.3 rc1 by test-installing or test-upgrading and doing some QA, please let us know here.

    • Fresh install or upgrade?
    • What did you test?
    • What is your test platform?

      • PHP version
      • database type + version
      • server type + version
      • OS
    • Any problems?

    ItsVizionTv
  • LincLinc Director of Development Detroit Vanilla Staff
    edited October 2016

    I expect to do the final release this week, so please do not delay with your testing. An immediate patch release is not likely.

    ItsVizionTv
  • Has anybody updated yours forum to RC1? I do want but I am afraid.

    ItsVizionTv
  • LincLinc Director of Development Detroit Vanilla Staff

    @Ivan_Gurin said:
    I do want but I am afraid.

    Here are some things you can do to alleviate your trepidation: https://vanillaforums.org/discussion/32716/getting-ready-for-vanilla-2-3

    ItsVizionTv
  • RiverRiver MVP
    edited October 2016

    @Linc said:
    If you take a look at 2.3 rc1 by test-installing or test-upgrading and doing some QA, please let us know here.

    I saw the part about starting a new discussion in the the opening post but also saw...
    let us know here, by "here" you mean this discussion? split the comment to a new discussion if you want. but all the issues in this discussion could be handy.

    • Fresh install or upgrade?
    • What did you test?
    • What is your test platform?

      • PHP version
      • database type + version
      • server type + version
      • OS
    • Any problems?

    positive test results

    I downloaded the zip from the add-ons.
    I did several test fresh installs, an update from 2.21 and an update from 2.1b3 all to 2.3rc1

    I tested with both php versions 5.6 and 7.0
    I tested with both sql versions 5.5 and 5.6
    I used apache and linux.

    All the installation and upgrades worked. I did have one stall on the installation screen and it seemed to hang on the page even though it created database and the config file, So I just reloaded the page in browser and it went straight to the discussion page without an issue (this was an off-line install). I couldn't replicate. In any event all installs and updates worked.

    the key to a good install and update

    • make sure ownership and permissions for file folders are readable and
    • make sure config, upload, cache and their respective sub-folders are writeable. And delete your ini files.
    • reset your your locale via the dashboard. so it is reset.
    • I found that memcache sometimes made adding plugins and folders and updating problematical at times but I used this technique

    http://serverfault.com/questions/259114/how-to-restart-clear-memcache-without-restarting-the-whole-web-server

    e.g. on my localhost.

    telnet localhost 11211
    flush_all
    quit

    I did the basic adding comments and discussions and deleting, applying for membership all worked. tested splitting discussions and adding images. the image upload inserted properly via the editor plugin.

    One issue I had after update was adding a category.

    the coercedata method not in controller

     protected function coerceData($row, $strip = true) {
    

    because the code is not in the zip in the add-ons but the coerce function is on github for 2.3rc1
    build issue???

    I couldn't find this method in the addon-zip
    https://github.com/vanilla/vanilla/blob/update/readme-2.3/library/core/class.model.php#L590-L653

    https://github.com/vanilla/vanilla/blob/update/readme-2.3/applications/vanilla/models/class.categorymodel.php#L2271

    As of today - apparently the github has the routine

    https://github.com/vanilla/vanilla/blob/update/readme-2.3/library/core/class.model.php#L590-L653

    but the add-on is missing the routine in the library/core/class.model.php

    https://vanillaforums.org/addon/vanilla-core-2.3rc1

    minor inconvenience but couldn't replicate.

    after an upgrade. I tried adding a discussion without selecting a category. then I got a ValidationRequest message instead of the Category is needed message. I fixed it by re-saving the locale via the dashboard. I could never replicate the error again after removing from config or deleting cache. So, if you have the issue resave the locale in dashboard.

    On a side note -

    The warning message indicating sql version and php version should be updated in the dashboard screens is great idea..
    also like the idea of defaulting the rewrite urls. should make things simpler.

    nice job.

    stream of consciousness question:

    @linc stream of consciousness question: If you have cache enabled and memcache installed, why do you prevent the writing of locale_map.ini in the cache folder it was very handy for troubleshooting locale issues. the other mappings are not prevented.

    possible feature request. pre 2.3 release or for 2.4 would be nice

    make ALL themes viewable in both the theme option in dashboard as well as the mobile theme option in dashboard.
    and make only themes with 'IsMobile'=>true, ONLY appear in the mobile theme options. it would be easier to select ANY theme for mobile and the desktop themes for desktop. And use the same theme for mobile and desktop,

    re: https://vanillaforums.org/discussion/32713/mobile-view-of-my-site-not-working


    I attached the faulty file from the rc1 downloadable release - so you can easily see it is missing the coercedata method.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

    R_JItsVizionTvhgtonightgracylayla
  • RiverRiver MVP
    edited October 2016

    @Linc

    update: I looked at readme-2.3 version (which has the private coerce method)

    https://github.com/vanilla/vanilla/blob/update/readme-2.3/library/core/class.model.php#L590-L653

    vs. release 2.3 version apparently doesn't have the coercedata method which I should have looked at

    https://github.com/vanilla/vanilla/blob/release/2.3/library/core/class.model.php#L578

    in any event the coercedata method seems to be missing on both the downloadable zip from the add-ons and in release/2.3 on github and I'm :confused:

    yet its called from applications/vanilla/models/class.categorymodel.php as well as other places.

    I modified things to bypass the issue for myself, but in any case if someone else has the issue they know where the problem lies.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

    ItsVizionTvhgtonightgracylayla
  • LincLinc Director of Development Detroit Vanilla Staff

    @River Nice catch on coerceData(). I missed a separate pull request back in April that also needed to be cherry-picked to this release branch. I've grabbed it now.

    ItsVizionTvhgtonight
  • Ivan_GurinIvan_Gurin Moscow
    edited October 2016

    I've updated my forum. All are still doing well. It works on php 7.0 :)

    Also, as @River, I have a problem with creating categories. But it is not critical now because I don't need to create new categories.

    Also I have a trouble with Discussion Polls plugin. Now when I trying to create new discussion - checkbox of discussion poll is ON by default.

    ItsVizionTv
  • Ivan_GurinIvan_Gurin Moscow
    edited October 2016

    I've found a new bug. Toolbar of comment editor has disappeared. How can I return it back?

    ItsVizionTvRiver
  • LincLinc Director of Development Detroit Vanilla Staff

    @Ivan_Gurin said:
    I've found a new bug. Toolbar of comment editor has disappeared. How can I return it back?

    Which comment editor were you using? Is the addon still on?

  • I am using Advanced Editor. It is enabled.

    But it doesn't visible:

  • When I create new discussion or create activity entry toolbar is visible.

  • RiverRiver MVP
    edited October 2016

    @Ivan_Gurin said:
    I am using Advanced Editor. It is enabled.

    Ivan - I can replicate your problem with a mobile device and WYSIWYG editor in the comments.

    For me, other formatting for the mobile device worked fine : html, text, textex, markdown as I recall.

    try changing your formatting in the settings and see if you see changes in mobile device settings or desktop settings format for the advanced editor. to see which text formatting causes you the issues, and whether it is mobile or desktop related.

    Also when you test things to isolate problems - you might consider disabling other community plugins to see if they interfere or create the issue and test with default theme.

    check your config settings for

    $Configuration['Garden']['MobileInputFormatter']
    $Configuration['Garden']['InputFormatter']
    

    which formats do you have problems with? try a different one. WYSIWYG seems to cause the issue for mobile.

    I've updated my forum. All are still doing well. It works on php 7.0 :)

    Also, as @River, I have a problem with creating categories. But it is not critical now because I don't need to create new categories.

    if you need to add a category you can temporarily comment out the line
    https://github.com/vanilla/vanilla/blob/update/readme-2.3/applications/vanilla/models/class.categorymodel.php#L2271

    add your category and uncomment it afterwards.

    Also I have a trouble with Discussion Polls plugin. Now when I trying to create new discussion - checkbox of discussion >poll is ON by default.

    you might want to add this to the discussion polls plugin - so the author knows. https://vanillaforums.org/addon/discussionpolls-plugin and choose ask a question when you are at the link.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • I've tried to change format of editor and disable plugins. But nothing is happening. Аnd desktop and mobile version have same behavior - there is toolbar in activity and discussion creation and there isn't in comment creation.

  • Ivan_GurinIvan_Gurin Moscow
    edited October 2016

    I've detected a plugin which hides the toolbar. This is Author Selector plugin by Matt Lincoln Russell.

  • wptolikwptolik Auroville New

    My server:

    • PHP 5.6
    • db: mySQL 5.6
    • server: nginx (1.10.1) + php5-fpm
    • OS: Debian 7

    Forum updated from version 2.2.1

    No problem, Good update. =)

    ItsVizionTv
  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    @Linc said:

    Last call for issues and pull requests.

    Give me some time to backport all the PRs I've made against the master branch. I never thought about also making that changes against a 2.3 release.

    RiverhgtonightItsVizionTv
  • LincLinc Director of Development Detroit Vanilla Staff

    Adding this many changes to an RC is making me super sad. We had the beta out for 5 months; this is what it was for.

    ItsVizionTv
  • LincLinc Director of Development Detroit Vanilla Staff

    @Linc said:
    Adding this many changes to an RC is making me super sad.

    I'll walk this back a little bit; I do very much appreciate the time taken to get these patches in. I'm just reticent to make a bunch of changes at the last second.

    I've reviewed these now; with the exception of two I've accepted them all because they have very narrow consequences. One rejected was a code-cleanup, and the other was a structure-check change that may have unintended consequences. Thanks for improving 2.3.

    RiverItsVizionTvR_Jhgtonight
  • LincLinc Director of Development Detroit Vanilla Staff

    why do you prevent the writing of locale_map.ini in the cache folder it was very handy for troubleshooting locale issues. the other mappings are not prevented.

    I believe it's simply that we don't use it anymore, so we're not going to continue writing cache files we don't need/use.

    ItsVizionTvRiver
  • LincLinc Director of Development Detroit Vanilla Staff

    @Ivan_Gurin said:
    This is Author Selector plugin by Matt Lincoln Russell.

    I have no idea who that is. :silenced:

    https://github.com/vanilla/addons/pull/421

  • RiverRiver MVP
    edited October 2016

    @Linc said:

    why do you prevent the writing of locale_map.ini in the cache folder it was very handy for troubleshooting locale issues. the other mappings are not prevented.

    I believe it's simply that we don't use it anymore, so we're not going to continue writing cache files we don't need/use.

    • ok thanks. I can always turn off cache to look anyway. since the locale_map.ini is created when cache is disabled. I was confused why other mappings were created but others not when cache is enabled but your answer explains some of my confusion.

    • were you able to replicate the issue I saw. - wysiwyg w/ mobile theme emulation causes the comment toolbar to disappear. The js changes the css to make the toolbar hidden.

    It doesn't matter to me I don't use wysiwyg, but was curious if this is an edge problem, or just that wysiwyg is not supported in mobile or just a glitch with the mobile.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • Update on when 2.3 will be noob ready?

    phreakK17
  • RiverRiver MVP
    edited November 2016

    I see no need for weapons on the forum. there are too many wars and weapons already.

    if you have a downloadable zip (e.g. 2.3rc2) for all the changes you made 20 days ago. I'd be glad to test and try to find more bugs for you. if that is the reason for the delay. lack of people testing.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

  • Waiting for 2.3rc2 as well! :)

  • Hi, I did a clean installation to test the new in vanilla 2.3 and I found a error when I try create categories, or modify the general category, I always receive this error message.

    hgtonight
  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    @JoZ3_69 The error message has been reported and it should be fixed in the final 2.3 release: https://vanillaforums.org/discussion/comment/243819/#Comment_243819

    JoZ3_69hgtonightLincphreak
  • LincLinc Director of Development Detroit Vanilla Staff

    I have updated the OP with details for RC2. Thanks to @R_J for most of the backporting work.

    JoZ3_69CaylusphreakSwennet
  • SwennetSwennet New
    edited November 2016

    Just a heads-up. The "on Github" URL in the OP doesn't actually link to Github at all.

  • LincLinc Director of Development Detroit Vanilla Staff

    @Swennet said:
    Just a heads-up. The "on Github" URL in the OP doesn't actually link to Github at all.

    Thanks. Fixed.

    Swennet
Sign In or Register to comment.