Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla Stats empty / no data

currently stats are not working in my vanilla installation. Tried to reinstall the plugin, but this does not help.
Anyone an idea why there is no data? (Forum runs since 6 months)




  • Following...I'm experiencing the same problem.

  • I think a lot of these issue are to do with them moving data centres.

    grep is your friend.

  • topcheesetopcheese DevOps Montreal Moderator

    We believe this is an issue related to forcing HTTPS on our Vanilla Stats server(s). It might be related to us moving data centers. However, dashboards loading under HTTP are trying to access the Vanilla Stats server via HTTP, which is causing a redirect and that seems to be triggering these failed preflight/CORS checks. If you check your browser dev console you can probably see the errors I'm talking about.

  • Yes, I can confirm that. With https it's working normal again! Thanks!

  • Yes, there is an error.

    Failed to load

    How would I fix it?

  • topcheesetopcheese DevOps Montreal Moderator

    Is your forum served over https/ssl ?

  • Is installing a cert the only option to fixing this?

  • topcheesetopcheese DevOps Montreal Moderator

    We plan on it being fixed in the next release, but I can provide some guidance on how to do the code fix directly if it comes to that.

  • @topcheese - it looks like my forum is on http. I'm in the process of moving to https but not yet

  • topcheesetopcheese DevOps Montreal Moderator

    @LeftBrain said:
    @topcheese - it looks like my forum is on http. I'm in the process of moving to https but not yet

    Would like for me to tell you what to change and in what file while you are waiting on the next release / updating your forum to https ?

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP


    If you could post the fix here, that would help, I think.

  • @topcheese - yes, that would be great. thanks

  • @topcheese, thx... but those changes did not work for me. (it took down my site and I had to revert).

  • topcheesetopcheese DevOps Montreal Moderator

    What was the error message?

  • topcheesetopcheese DevOps Montreal Moderator
    edited August 2018

    Subsequent code change that was probably your problem.

  • #18 /home/directory/subdomains/forums-dev/library/core/class.dispatcher.php(274): Gdn_Dispatcher->dispatchController(Object(Gdn_Request), Array)
    #19 /home/directory/subdomains/forums-dev/index.php(29): Gdn_Dispatcher->dispatch()
    #20 {main}
      thrown in /home/directory/subdomains/forums-dev/library/core/class.statistics.php on line 78
    [15-Aug-2018 15:37:58 UTC] PHP Fatal error:  Uncaught ParseError: syntax error, unexpected 'AnalyticsMethod' (T_STRING) in /home/directory/subdomains/forums-dev/library/core/class.statistics.php:78
  • topcheesetopcheese DevOps Montreal Moderator

    This seems like you had an error in your code, perhaps a copy paste gone wrong ? How did you go about updating those files ?

  • Looks like you found the problem with those latest changes.. thx.

  • Excellent, that worked for me! Thanks!!

Sign In or Register to comment.