Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.

Vanilla Porter Version 2.4 with PHP 7.X ?

This discussion is related to the Vanilla Porter addon.

seems this is still not working ?

Comments

  • LincLinc Director of Development Detroit Vanilla Staff

    What error are you getting?

  • DwarfDwarf New
    edited March 25

    We want to migrate from VB 5.5.1 to latest Vanilla but need to be sure Porter wil work with PHP 7.x

    Can someone confirm Porter will work with PHP 7.x ?

    This is the error we are getting;


  • azizaziz New

    similar problem...

  • Same here. Any info on how to get around this? I have an old forum that needs rescuing.

  • charrondevcharrondev Application Developer (PHP, JS) Montreal Vanilla Staff

    It does work w/ PHP 7, but you need themysqli extension. The mysql package doesn't exist in PHP 7.x

  • So i installed mysqli but its needed mysql functions so the last comment does not work out. as Summary almost 1 Year no Updated shows me vanilla is not interested that people are moving to vanilla - really sad i wanted to give it a try but .......

  • PatchesPatches Moderator

    There was in fact an issue with the version 2.4 of the Porter. A new version has been uploaded today. Please let us know if you run into any other issue while using this version.


    The PDO extension is used by default. This can be changed by modifying the value of the DB_EXTENSION constant in the vanilla2export.php file, like in the example below.

    define('DB_EXTENSION', 'mysqli');
    


    Sorry for any inconveniences this issue might have caused.

Sign In or Register to comment.