HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla 2023.001 Open Source Release - PHP 8 Works! (Built From Source)

2

Comments

  • pioc34pioc34 Pézenas ✭✭
    edited January 2023

    @BlackMale Yes, i delete the old yaga folder and replace it with the new and everything is ok. Thanks!

  • BleistivtBleistivt Moderator
    edited January 2023

    For your info, I had to set $Configuration['Conversations']['MaxRecipients'] = 0; (= unlimited) since regular users could not create new conversations otherwise. Not sure yet wether that is a bug or relates to my setup only.

  • @Bleistivt I tried what you suggested and its a no go... I tried compiling... I tried removing the config.js and all I get is dashboard/setup not found I don't know what you mean by merge your applications back in there are no other plugins or applications I use this is a blank clean empty forum with no content plugins or anything as soon as I put the old files back into place the forum works and loads up like nothing has happened... I left the config and uploads folders in place and replaced the rest with the new stuff downloaded from this post and I just get a blank screen e.g PHP seems to crash there is 0 code if I load the page source to be honest I wanted to start using vanilla but if it has to be so much hassle just to get an update working I probably have to start looking for another solution I was hoping once you figured out how this works it would be OK for future versions as well but I've been mucking around for 2 days now and it really has put me off using vanilla...

  • @Patmac If you get a blank screen the first step is to enable debug mode by adding this to your config.php:

    $Configuration['Debug'] = TRUE;
    

    and if that doesn't help change ini_set("display_errors", 0); to 1 in index.php

  • @Bleistivt The first thing I did was enable debug in the config file to no avail However ini_set("display_errors", 1); did throw some errors which were easy to fix after that it would still throw me a blank screen in PHP 8.2.1 there were 2 warning about json being deprecated (Which I suspect has nothing to do with the actual functionality of the website) and in PHP 7.4.33 the page is blank and error free is looks like is just doesn't want to load at all it hangs on some PHP code somewhere... I'm gonna look into file and folder permissions today and the actual config file the furthest I have gotten was the unhappy smiley face with "Oops something went wrong" when I disabled stuff in the config.php file. Now because you all claim it works it must be something on my site thats different from your set up so that would be the config.php file what strikes me as odd though is that when I rename it to config.old e.g a fresh install sort of speak it wants to load /dashboard/setup but the browser throws me a file not found page... Its a very odd problem and because of the lack of documentation I'm shooting in the dark... By the way this has been tested or attempted now on a Debian 10 (Buster) Distro running Nginx and Plesk and both PHP 7.4.33 and PHP 8.2.1 and on a machine running debian 11 (Bullseye) with apache2 PHP 7.4.33 and 8.2.1 and on both the 2021.012 runs (The version before they started the whole OSS crap)

  • BleistivtBleistivt Moderator
    edited January 2023

    @Patmac

    the furthest I have gotten was the unhappy smiley face with "Oops something went wrong" when I disabled stuff in the config.php file

    This page appears when debug mode is not enabled.

    Have you tried deleting /cache/addon.php after updating (and also manually disabling plugins/themes in config.php)?

  • @Bleistivt I got the smiley face because I'm trying stuff debugger of and on whatever I do it just does';t want to play ball just a recap so we are clear in what steps I'm taking....

    Install version 2021.012 Works fine no problems

    Put version 2021.012 in a sub folder called OLD All Files so I now have one folder on my document root called OLD

    put the downloaded files in the document root...

    put the config file from the OLD folder into the new installation.

    move the .htaccess over from the old installation

    CHMOD conf cache uploads and conf/config.php to 777

    empty the cache folder except the .htaccess or empty the folder completely or leave the folder alone doesn't make a difference

    Variant I tried... are Change the PHP version, Compile the version using /bin/release which gives me an error about not being able to move vanilla-2023.001.zip to /build/temp

    Build with composer using composer install

    CHMOD everything to 755 and to 777 just as a test

    edit the config file add debug edit the index.php file set errors to 1 throws an error about json in PHP 8.2.1 but nothing in 7.4.33

    Disable all plug ins in config.php as I understand it it will fall back on the default config file...

    Delete or rename the config.php which results in a page not found error

    All of the above gives me the same a blank page with nothing... Internal server error 500 (Depending on which browser I use)

    When I move the files back from the OLD folder everything works fine again without a problem

  • @Bleistivt Update I actually managed to get it to work on the actual server now however during and after installation it is saying version unknown... Is this normal with this version? Obviously after all the hassle I'm still very wary about it working etc.

  • pioc34pioc34 Pézenas ✭✭

    It's normal version.json file is missing in root directory.

  • @Bleistivt Just to explain what seemed to have solved the problem on the actual server:

    After copying all your files over e.g the 2023.001 again I got a internal server error 500 when looking in the plesk log files it seemed to point to SQL errors so I renamed config.php to config.old and went to dashboard setup which loaded up this time after that I just performed a normal install and it was up and running... So it seems to be an outdated SQL database for some reason doesn't explain why it didn't work on my test setup though (Which I still want to find out) but there you go...

    Bleistivt
  • Can I ask if you were using Composer 1 or 2?

    ceffah
  • KasparKaspar Moderator

    Sorry, you comment was stuck in the spam filter.

  • If you have errors like "update fail" "schema error" when you do /utility/update

    You need to export new SQL structure (blank site), export your "old" forum/production SQL structure and diff the two versions. I need to manually edit database structure of my production forum.

  • Vanilla OSS 2023.002 raw build (no real php8 support,etc)

    pioc34
  • @AstRuc Could you clarify "no real php8 support,etc"?

    Since 2023.001 does support PHP8, why shouldn't 2023.002 do so as well?

  • AstRucAstRuc New
    edited February 2023


    I haven't really tested (a quick test failed). I'm stuck with profile extended fields permissions problems since 2023.001 (I'm also tired of the fragility of the OSS forum).

  • Ok, another try : It seems working with php8.1

  • Important message to anyone attempting to build this release themselves: the files as provided in the release are NOT PHP 8 ready, nor Composer 2 ready, nor Node 17 ready.

    composer.json contains these problematic dependancies:

    • ralouphie/mimey: This has not been updated in a while, seems to be a dead package, and requires PHP 7.4. I'm attempting to work with xantios/mimey instead.
    • smarty/smarty: The version of this package (3.1.47) requires PHP 7.4. Updating this to 4.2.1 should resolve this.

    package.json says that it can be used with node < 18, but also includes a requirement of Fibers. On the npm page for Fibers, there is a big note stating "this package will no longer be updated" followed by another message of "Fibers is not compatible with nodejs v16.0.0 or later". Fibers might be removable as I don't think I see any place it is called/included, but I'm running into other issues with this update and am unable to test this.

  • Failed to build with composer 1 under ubuntu (I user ./bin/release.sh).

    Builded with composer 2.54 / php 8.1 / node 14.21 / yarn 3.11 under wsl. No composer update (failed dependencies). I was surprised my previous trials (2019) composer v1 was mandatory.

    Warns around yarn / react but correct zip is built. File vanilla-2023.002 is the file generated ./bin/release.sh without any modification.

Sign In or Register to comment.