Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.




  • Are you using Lowcal vanilla extensions that compresses all javascript files.
    its the same problem rising again. we don't yet have a good solution to the path problem.
  • @# ChadFenwick

    stage6 and brightcove are added in the new version. once i fix the webroot issue i'll upload the new one
  • Its strange because I've had the same setup for months now and just recently did this start happening.

    The extensions I have running are:

  • Its this line that is creating problems
    qmediaPath.webRoot = jqmediaPath.getRootPath('script', 'src', 'js/global.js');
    its returning false cause it cannot find the global.js file
  • It should work with:
    qmediaPath.getRootPath('link', 'href', /themes\/.*\/styles\/.*\/vanilla.css/)
    qmediaPath.getRootPath('a', 'href', /people\.php.*$/);
  • Uploaded version 0.6 of JQMedia.
  • Uploaded version 0.6.1 of JQMedia.
  • Uploaded version 0.6.2 of JQmedia.
  • Uploaded version 0.6.3 of JQmedia.
  • JQmedia has had a name change
    you won't be able to update it via vanill'as update manager.
    please download jQmedia again and overwrite your previous directory.
    Don't just copy over the files copy the whole folder
  • There is an error with this plugin. the line that reads "if(jQuery.browser.msie){ $el[0].outerHTML = $el[0].outerHTML; }" (line 202) of jqmedia.js throws a javascript runtime error in IE7 and IE6 after the first media instance is replaced, thus preventing any further media instances from being replaced. commenting the line out works (actually, just commenting out the block fixes it, so it's not a problem with the if() statement itself), but I'm not sure what it's supposed to do ("// Eolas workaround for IE (Thanks Kurt!)") so I imagine it might be necessary in some circumstances. hope this helps! oh, and otherwise it's a rad plugin. thanks!
  • Since MS lost the case against Eolas, now all flash embed or any activex embeds cannot play on its own. they have to be activated by a click. This code is supposd to do that, so you don't have to activate them. you should disable javascript debugger. the workaround fails during debugging
  • Duh, Eolas. I think I just refuse to remember it because it's such a pain in the A. At any rate, I'm not experiencing this as you describe. if the Eolas workaround is not commented out it causes errors whether debugging is enabled or disabled. And when it is commented out it does not cause internet explorer to alert.(see: However, the fact that this script is dynamically inserting the embedded objects after the DOM is created (Im assuming using jquery's $(document).ready(function(){}); or $(function(){});) means that the plugin itself works as a workaround as IE only triggers that horrible alert if it encounters embeds or objects while the page is loading.
  • Is it possible to change the mediaplayer.swf to another flashplayer? I tried it with 2 or 3 diffrent players but it didn't work.. I'd need a player that loops the files..
  • if you know what you're doing then use this <blockquote>repeat (true,false,list): By default, the players will stop playback after every item to preserve bandwidth (repeat=false). You can set this to "list" to playback all items in a playlist once, or to "true" to continously playback your song/movie/playlist.</blockquote> if not then wait for me to update jQmedia
  • line 126 in jqmedia.js
    this.repeat=((cls.match(/repeat:(true|false)/)||[])[1]) ||'false'; // whether the file should repeat or not this.flashvars='file='+ videoID + '&lightcolor='+ this.lightcolor+ '&backcolor='+this.backcolor+'&frontcolor='+this.frontcolor+'&showdigits=false&repeat='+this.repeat;},

    then you this as the link to the mp3 file
    <a class="repeat:true" href="song.mp3">Play my song!</a>
  • thanx for your help! couldn't test it yet, but I think I'll try it this weekend..
  • I'm also having problems with this extension. When it is enabled, I cannot view any comments on the entire forum. I'm not sure what happened, becasue nothing changed during the time it worked and the time it decided not to work. I have since upgraded Vanilla to 1.1.4 and I am running jqmedia 0.6.3 and jquery v14-1.2.1. I'm not a code expert, so some of the conversations are over my head on this issue. Any help would be great, this is a fantastic extension when it works of course.
  • i'm a little slow :) I found a permission issue on the server, and corrected that. Now everything is back to normal.
  • hello,

    is there a way to get rid of those links below (under those players and youtubes).

    i want to remove them completely ...if possible.

    big thanks in advance ... as usual :D
Sign In or Register to comment.