Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.




  • mattmatt ✭✭
    Hey David, great work.

    The only thing I can spot is that the location zooms out when you edit a location. If you're only editing the position of the pin this is a real pain. Could the location on main map pass over to editLocation page?

  • says my google api key is invalid, and so i inserted a new one. now all my pinpoints are gone. :(
  • How did you do this? If you uninstalled by unchecking the extension, then I think re-activating might actually do that as it resets the tables.

    If that has happened, do you have backups of your SQL database? All of the locations are in the database in a table called LUM_GoogleMapDirectory_Locations. If you restore that table you have all of your pinpoints back.

    You have a backup policy right? (Please say you do)
  • Basically if this line is absent from your conf\settings.php file:

    Then it will drop and re-create the pinpoints table.
  • i do but not daily... ill talk to my server guy. i just rewrote the extension rather then enabling and disabling it. i guess that was dumb but i have another bug on my forum that wont let me enable or disable any extensions (among other things) that has yet to be resolved.
  • somehow this got written to my conf/settings.php file


    causing my forum to go down... im having a lot of problems with vanilla since the 1.1.2 update :(
  • I'm kind of new at vanilla and I'm having a little trouble with the google map add on. I feel like I installed it correctly because I was able to install fckeditor, which was much more difficult. Either way. Before I make Vanilla accessible to my client I would like to have it running properly. So here is my problem. Once the GoogleMapDirectory is activated I can see the map just fine. When I click on the tab for GoogleMapDirectory it give me the option to "Start an new discussion" or "Add a Location". When I'm in either the admin or a guess I get an error which posts right above the map saying this Notice: Undefined variable: setLatitude in /home/content/j/d/e/jdemaria/html/vanilla/extensions/GoogleMapDirectory/default.php on line 184 I can find the line but I have know idea what is wrong. I had .3, uninstalled it, fix a line of code on the extenstion.php from the vanilla directory and I don't know what else to do. Can someone help?
  • Did you get your GoogleMap API Key?
  • can i delete posts?
  • Yeah, I actually got one three times because I couldn't get back to the orignial, either way, I believe I set it up properly. You can check out the error yourself a go ahead and sign up to see what's going on. I also just check to make sure if the position get saved in MySql and it does. It just doesn't have any points in the locations.
  • Hi All,

    - 128 -
    Sounds like you should try and sort out your vanilla in general before trouble shooting the extensions. I did say to back up the table first...! To explain, I've tried to incorporate an upgrade path now while aligning the naming structure so all Config variables are prefixed with "GOOGLEMAPDIRECTORY_". This means the new detection for if the script is installed is now called "GOOGLEMAPDIRECTORY_SETUP" rather than "EXTENSION_GOOGLEMAPDIRECTORY_SETUP". When running version 0.4 it checks for this, sets the older one to "0" and ammends the existing table rather than deleting and creating a new one. It was the only way i could see to keep data while changing the table structure. Hope that helps some trouble shooting.

    - emsef (hi matt!) -
    The location on the edit page is centred on the position of the edit point in question, I suppose I can up the zoom level though. Will add to next revision.

    - jdemaria -
    Not sure why that's happening, though it could be you've a cached version of one of the 0.3 pages which wouldn't included the GET variable $setLatitude causing the error quoted. Try refreshing a lot, clearing cache or a mates machine and see if you get any better results.

    - iamglenn -
    Yes you can delete locations now, there's a setting added to the admin page that can be set to admin only, locations editors or any member. It's default is admin and the delete button now appears on the edit page of that location rather than in the map balloon as before.

    - DavidK -
    Thanks for helping on the troubleshooting!
  • Sigh. My previous data also got erased when I upgraded. So was I suppose to deactivate it before I install over? I too got the same error when I tried adding a location: Notice: Undefined variable: setLatitude in /nfsn/content/artmgs/public/forum/extensions/GoogleMapDirectory/default.php on line 184 I tried clearing caches, used different browsers, logging in and out, etc. Still the same?
  • Hmm, I'm unable to replicate this error Kifo/jdemaria. If either of you could supply me with a link I'll have a sniff around and see what I can deduce from your errors. I still feel like this could be cached javascript or something similar as it sounds like its looking for a variable that only existed in the latest version, makes me feel one of the scripts/pages hasn't updated...

    As for the wiping of previous data and for anyone else out there about to upgrade - I have stressed a few times you should back that table up first just in case - it seems to be having quite varied results although I think it's been a successful upgrade path for most.
  • Maybe this is too stupid to ask but what URL shall I register to Google? <site>/forum/ or <site>/forum/extensions/GoogleMapDirectory/ or something eles? I tried those two with no luck...
  • Just the domain name, so: <site>
  • I just upgraded my extension and now I get a JS error:
    invalid flag after regular expression (line 103 map.js)
  • I'm trying to deploy the extension but users entries don't appear on the map. They end up in the database ok, but they are not marked on the map, nor is there a list below the map. Any ideas?
  • Hi Skube/Mvhaen, Without examples to look at myself the only explanation I can find for these messages would be cache of js script files so the server side and client side data is out of sync. A few have posted your problem mvhaen, and it suggests that data gets passed to the server fine but can't display it as the javascript bins out. I suggest looking at Firefox's excellent plugin Firebug: to help you pin point where in the script its falling over (good chance its line ala skube's problem). Many many people have this plug in working fine now, so I suggest its an installation/upgrade issue. try ripping all out and starting afresh with version 0.4.
  • Hi davidk43, thanks for your response. I have a working forum here I still cannot add any locations to the google map directory because of the problem I am facing. Thanks!
  • I got the following output from Firebug, unfortunately my javascript skills aren't that great, but it looks like the same bug as Skube all right. invalid XML markup InitiateXmlHttpRequest()ajax.js (line 39) LoadData("extensions/GoogleMapDirectory/ajax.php?action=getLocations&Search=")ajax.js (line 51) getLocations("")map.js (line 103) getMap(600, 600, 51.183542, 4.416065, 12, "")map.js (line 31) onload(load )extension.php (line 1) [Break on this error] (<?\n About uninstalling can I just remove the DB table and delete the folder of the extension or do I need to know about anything else? I installed v0.4 to begin with.
Sign In or Register to comment.