Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.




  • RabbitAbout:

    Not sure on the sitemaps extension. I'll install the extension myself and see if I can sort something out. More than likely, the original Blog extension has the same issue.

    And as far as Nuggets, I'm using it fine and I don't think I had to modify it. You might need to go back to each Nugget and select the Blog page, to make sure it adds them there. Nuggets allows you to only put certain nuggets on certain pages, and the default is to not add them. So adding a new page, means no nuggets!


    Installing WordPress looked a mess, so I didn't bother doing it. That's why I wrote this extension. There are two ways that come to mind, both of which involve coding. One is to an extra insert SQL query, which puts the post in both databases, which has the problem of sysnchronisation of updates. The second would be edit the WordPress code to join with the Vanilla database to fetch any BlogThis posts, aliasing column names to fit. Neither of these are ideal in my books, and I have no intention of coding them - I'd sooner add more features to this Extension.

    There isn't a stand alone RSS feed for this extension, but I've added code into the Search function so that the FeedPublisher extension can search for only Blogged posts. It works flawlessly, and is very very easy to set up. I guess it might be nice to add RSS code into this extension, but I imagine all I'd be doing is taking FeedPublisher and just customizing it towards the Blog - which wouldn't be a bad idea I guess. But the whole point of Vanilla is that when you want new features, you add them later. Not everyone will want RSS :)

    So in summary, install FeedPublisher and try and find a WordPress plugin to take advantage of it :)

    Everyone Else

    Any other feature requests are welcome! And if you've got this setup on your sites, please either post them in this thread, or e-mail me so I can check them out!
  • spode, Many thanks for your suggestions. I have checked the blog box for the Nuggets, but still nothing. Also, I notice that my blog tab does not change colour when on the blog screen. In the BlogThis settings screen, click to see examples under Blog Post date format does not work either. I wonder if I have not installed correctly, or if I have a conflict with another extension...
  • I'll take a look at the examples, that's just a style sheet issue. I noticed yesterday that I've not changed a number of "Blog" references to "BlogThis", so that may well be causing issues.

    Another thing you might have to do for nuggets, is make sure they are called on extension.php. Most extensions seem to check for index.php, search.php etc. and leave out extension.php.

    The Blog Tab not working is confusing too, the code is pretty simple to cover that and came directly from the Blog extension, so should be working. Do you have page manager installed? Might need to resync. If you have this live online, drop me an e-mail so I can take a look.
  • Many thanks spode, Page manager. That was the answer. I resync'd and another 'Blog' page appeared (one that i had previously deleted when trying out) So this was deleted again and all is working fine now. Tabs and Nuggets. Thanks for your help. Brilliant Extension!
  • Not a problem. Let me know any problems/suggestions and I'll add them to my current to-do list :)
  • Hi spode, I'm having a little problem of my own - it's really minor, but I thought I'd post and ask. It appears when a non-logged in person is browsing the site, they get this error at the top: Warning: mysql_query() [function.mysql-query]: Access denied for user 'www-data'@'localhost' (using password: NO) in /home/marrow/public_html/vanilla/extensions/BlogThis/default.php on line 62 Warning: mysql_query() [function.mysql-query]: A link to the server could not be established in /home/marrow/public_html/vanilla/extensions/BlogThis/default.php on line 62 Warning: mysql_query() [function.mysql-query]: Access denied for user 'www-data'@'localhost' (using password: NO) in /home/marrow/public_html/vanilla/extensions/BlogThis/default.php on line 68 Warning: mysql_query() [function.mysql-query]: A link to the server could not be established in /home/marrow/public_html/vanilla/extensions/BlogThis/default.php on line 68 It seems obvious to say that I need to correct the mysql database details, but I can't find where to do that. Any help would be much appreciated, thanks.
  • Hmm. Odd. I'm not having that problem at all. It uses the same username/password as Lussumo is set up with, as it uses the Vanilla functions to parse the query. Is www-data with no password, how you usually access the database?
  • Hey Spode, pretty cool extension :)

    However, I've tried it on a "twin" forum (two installations on the same database using different prefixes) and something went quite wrong.

    Here's what happened:
    - I disabled the Blog extension which I was previously using.
    - I enabled BlogThis
    - The result when I click on the blog tab is a fatal error:

    Error Message
    An error occurred while fetching the list of blogs.
    Affected Elements

    The error occurred on or near: Table 'mybase.LUM0_User' doesn't exist

    LUM0_ is the prefix I use for one of my vanilla install (the other one being LUM_). Everything else works fine, and since I'm far from being a PHP or MySQL guru, I've no idea what is causing the problem.

    My database.php file got somewhat corrupt during the process (I installed & reinstalled Blog & BlogThis several times trying to figure what was going on). The last few lines of the file were copied twice and were causing an error because the PHP tag was closed too early. I managed to fix this, but I still get the fatal error when BlogThis is enabled.

    So... I've no idea how to make BlogThis work :/
  • Hi Ø,

    The error message is pretty clear, it's suggesting that the User table doesn't exist in the database - although your prefix appears to prefix the database name too, I'm not sure if that's causing the issue. i.e it should be "LUM0_User" not "mybase.LUM0_User". What do you have in your control panel settings? This could because I used raw SQL rather than SQLBuilder - perhaps the framework has a way of dealing with these issues ;)

    The corrupt database.php was a fear of mine, as it manipulates the database file directly. I just copied it directly from the Blog extension. As I'm learning more about the Framework, I'm realising where this extension could be improved.

    I have tested it on clean installs, only with LUM_ mind you. The key is somewhere in your prefix. Do you have something like phpmyadmin installed?
  • Yep, I've phpMyAdmin installed. I've had a look and I've got a BlogThis column at the end of LUM0_Comment. The LUM0_UserSearch table exists, but it seems empty. What do you mean by "what do you have in your control panel settings"? BlogThis' settings?

    The extension somewhat works because I can blog/unblog comments. The error only occurs on the blog tab. Could it have something to do with Page Manager?
  • Uploaded version 1.06 of BlogThis.
  • Ah yes, try resyncing in page manager - it could well be that causing an issue, still having Blog instead of BlogThis code for example.

    I've just updated the version very slightly with some code clean ups, Google Adsense optimisations and some better error handling for database.php etc.
  • Uploaded version 1.06 of BlogThis.
  • I've updated to version 1.06 (and resynced Page Manager) but now I get a fatal error when going to the settings tab:

    Error Message
    The "BlogForm" class referenced by "BlogForm" does not appear to exist.
    Affected Elements

    The blog tab doesn't appear anymore.
  • Accidentally uploaded a version with a typo :S Try upgrading again.

    I don't think it affected the settings page though - looking at that now.
  • Oh, and make sure you're uploading the whole folder - not just default.php. I've renamed a couple of files - that could be causing your error.
  • Ok well... I've updated, resynced, hacked the hell out of my database and switched LUM0_ with LUM_ and now everything seems to work!

    I have no use for a blog tab on the other forum (it's an issue tracker) so the prefix issue isn't really a problem in my case.

    Now I think I'm going to mess a bit with the theme in order to make category icons appear instead of "in [category]".I'll cry for help if I don't succeed :)
  • Weird that it didn't work with your other database prefix - I just copied the code from the original Blog extension for getting the prefix, and it seems to work!

    Drop the URL here when you're done so we can see it in working.
  • Hi again Spode, Sorry for the slow reply, I don't have the internet at home at the moment. It seems a fresh install of Vanilla and all add-ons fixed it. Must have been some problem when I flattened and reinstalled Vanilla the first time over. No I don't run my mysql database as www-data with no password, so I don't really know where it got that from. The rest of the forums were working perfectly with the actual username and password, and actually, so was BlogThis. It was saving new posts fine.
  • Very strange. I can't every try and suggest what was causing that. It works on my install, and the fresh install I use as a test platform - that's about as far as I go in testing it!
Sign In or Register to comment.