Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.

Vanilla 2.0.18 (beta 2) is now available

This discussion is related to the Vanilla addon.
123457»

Comments

  • edited September 2011
    Just upgraded from 2.0.17 to 2.0.18b2 and am getting BONK. Luckily I had dashboard open on other browser and was able to see the problem. I am getting a FATAL ERROR IN: Gdn_Database.Query()."Table 'wordpress.gdn_log' doesn't exist" select count(l.LogID) as `CountLogID` from GDN_Log l where Operation in ('spam') LOCATION: C:\inetpub\trav\community\library\database\class.database.php
  • LincLinc Director of Development Detroit Vanilla Staff
    Go to /utility/upgrade so it fixes your database structure.

    Also note that you're using a beta product, not a stable release. .18 hasn't been released yet.
  • There doesn't appear to be a utility/upgrade folder. Where can I find this.
  • There doesn't appear to be a utility/upgrade folder. Where can I find this.
    Download the 2.0.18b2 package again and just upload the /utility/upgrade folder

  • It's not a folder, it's an url you've got to browse to on your forum, so it launches stuff to upgrade your database structure.
  • I noticed people can post even before confirming their emails. This is "spammer-friendly"
  • ToddTodd Chief Product Officer Vanilla Staff
    @tedel, That's only true if a forum admin configures their forum that way. There is a confirm email role and you can remove its post permissions.
  • Hey. Are there any new strings to translate? Just wondering whether I have to update the German locale.
  • LincLinc Director of Development Detroit Vanilla Staff
    @dakira There are a TON of changes, so I would imagine so.
  • I did this:
    a. downloaded beta package
    b. unzipped
    c. upgraded "vanilla" to "vanilla" on my server and answered "yes" to all over-writes
    Now when I try to go to forums, I get BONK!
    when I try to go to vanilla/utility/upgrade -> page not found
    I am not sure what to do!!!

  • LincLinc Director of Development Detroit Vanilla Staff
    It's /utility/update, not upgrade.
  • LincLinc Director of Development Detroit Vanilla Staff
    I've fixed this for future versions. You're not the first people to mis-remember what path to type, so I added it as an alias.
This discussion has been closed.