Vanilla 2.0.18.2 release

This discussion is related to the Vanilla addon.
LincLinc Director of DevelopmentDetroit Vanilla Staff
edited January 2012 in Releases

This release brings minor tweaks, and is likely to be the last update to the 2.0.18 branch. If you're happily using 2.0.18.1 already with no issues, I would regard this upgrade as optional.

Changelog:

  • 2011-12-21 Fixed bug where Gravatar was using name instead of email for Vanillicons
  • 2011-12-20 Pass the real folder name to autoloader instead of app name
  • 2011-10-31 Fixed misformed options array in entry/connect
  • 2011-12-05 vBulletin import: Use new profile custom prefix
  • 2011-11-11 vBulletin import: Support ProfileExtender for seamless future transition
  • 2011-11-11 Importer: vBulletin only needs the Photo field
  • 2011-12-02 Replace periods with dashes in URLs
  • 2011-12-02 Fix checkcolumn for jQuery 1.6.
  • 2011-11-29 Added code to help with Win7 servers that do not allow renaming over an existing file.
  • 2011-11-27 Fixed bug where SSO would not work with non-English translations.
  • 2011-11-01 Embed: Better place to end execution of local.js
  • 2011-11-01 Embed: Fixes force redirect
  • 2011-11-09 Fixes Tagging issue where tags could disappear. Remove tag module from discussion.
  • 2011-11-08 Setup: Fixes malformed HTML (no /form on 2 page)
Tagged:
[Deleted User]AoleesahotataranericgilletteJoZ3_69sunset_bc
«13

Comments

  • good work

    grep is your friend.

  • lucluc ✭✭

    Thanks.
    I don't currently have the time to follow the forum (especially as the css/js is from http://autostatic.cl1.vanilladev.com which is blocked at work, hence the forum is unusable there), but still following the commits.

    Looking forward to 2.1.

  • There is now a package for vanilla 2.0.18.2 available for Arch Linux:

    https://aur.archlinux.org/packages.php?ID=56016

  • i dont think i need that yet, ill wait for the next release.

  • When can we expect the upgrade with all of the badge/medal system goodies? :D

    simonleuf
  • I have the same problem as sternman, I don't know what I'm doing wrong :-D
    please Help me :-D

  • valajbegvalajbeg New
    edited January 2012

    it seems that one day when i open http://vanillaforums.org, it will be 100% proprietary, 100$/month forum engine...

    i'm afraid you guys go in wrong direction...too greedy...

    consequences would be 0 community commits, 0 new innovative integration and finally turning to other blogging engines... i'm already looking for new one...

    You don't have any serious developer docs, code is hell, and you claim "opensource"?... pushing ppl to buy something would not result in prosperity IMHO

  • sahotataransahotataran Developer, Bay Area - CA ✭✭✭

    ^^^^^^^ dislike. developers are already doing their best to give us the best out of box.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    valajbeg - they're giving it to you for free.

    You are free to look elsewhere if you think you can find a better solution to your needs.

    Personally, I'm delighted with Vanilla, and so are my users.

  • ToddTodd Chief Product Officer Vanilla Staff

    @valajbeg, Vanilla is released under GPLv2. That actually has a meaning which completely contradicts what you are saying.

    I must say that when people like you post ignorant comments it does annoy me a little bit. Maybe you can actually look into the meaning of open source or stop talking about it hmm?

  • TimTim Operations Vanilla Staff

    @valajbeg have you signed the Contributors Agreement?

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • TimTim Operations Vanilla Staff
    edited January 2012

    Nevermind, it looks like you haven't. Which means you haven't made any contributions to the code either.

    Which means keep your ignorant, uninformed comments to yourself. Having read through a brief google search of your email address, it looks like you whine on the support forum of several other projects too: wordpress, netbeans, kannel.

    The problem is you.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • ercatliercatli
    edited January 2012

    I'm very new to Vanilla 2, and things are a bit different to the Vanilla 1 I was once familiar with. Can anyone help me with a couple of very simple questions please:

    1. How do I determine exactly which version of vanilla I have? There used to be a notice at the bottom of the sidebar, but I can't find anything like that now. Or do I have to keep track of that each time I upgrade?

    2. Is there any simple way to upgrade without re-loading every file? (There used to be a list of changed files for each version change, but I can't find that either now.)

    3. I cannot get two plugins to work on v18, even though they worked on 17. Could this latest upgrade help that???

    Thanks for putting up with my obviously dumb questions! : )

  • TimTim Operations Vanilla Staff

    Your version number can be found at the bottom right of any screen in the Dashboard.

    Right now we upgrade manually. We've got plans for an updater, it just keeps getting sidelined.

    Which plugins?

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • lucluc ✭✭

    For upgrades, the easiest way is using git.

  • edited January 2012

    Eek, where isn't a theme being applied after completing an upgrade?

    I just upgraded by following these instructions: I backed up my MySQL DB and forum files, remained logged in on userid=1, copied the unpacked contents of new version zip to forum directory overwriting the old files, deleted .ini files, and ran /utility/structure (successfully). It was when I ran utility/structure that I noticed my forum was devoid of a theme.

    The forum appears to basically function properly (and the mobile theme renders just fine on my iPhone 4s, on which I was also logged in as userid=1) but is devoid of styles. Do I have a permissions issue, or is something else happening? Thanks in advance for any help - I love Vanilla Forums. It's really helped my organization improve its communication and build a strong community.

    FYI, I am re-uploading the new version files again to see if that magically solves my problem. #shotinthedark Edited: It did not work.

  • edited January 2012

    I just noticed that my config.php has not been updated. I am going to try changing permissions on that file and running utility/update again.

    My apologies. It actually has been updated. Still no theme, though.

  • Nevermind...it was an incompatible plugin (of course).

  • lucluc ✭✭

    NorthwestVeloSite said:
    Nevermind...it was an incompatible plugin (of course).

    Might be a good idea to let us know which one.

  • Fatal error: Wrong parameters for Exception([string $exception [, long $code ]]) in /var/www/site.com/library/core/class.userexception.php on line 23

Sign In or Register to comment.