HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Upgrading from 2.0.18.4 to 2.1b - AllIPAddresses error

I followed this page to the letter, but got a bonk when going to the /utility/structure page. Turnning on debugging I see that it's the ALLIPAddresses error.

I also see that it's a known issue here, but can't nail down a known solution. I see export/import, try the "update" page a few times til it works (update page bonks too), and simply add the column to the User table in PHPMyAdmin. That last one sounds the best, but I didn't want to mess with my database until I knew the exact info.

Does the column's placement in the GDN_User table matter? This discussion says it should be varchar(100), is that correct?

I'm looking forward to another upgrade attempt tonight, and wanted to get over this hurdle using the best solution possible, thanks :)

UnderDog
«1

Comments

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    AfaI remember, if you manually add the All IP table it then comes up with another couple of missing tables.

    In the end I wen a slightly different route.

    I installed a clean version of 2.1b.

    Then I used http://vanillaforums.org/addon/porter-core to export my 2.0.18 db and imported it into the 2.1b install.

    If you do that, export a copy of the 2.0.18 permissions table.

    I found that I couldn't change permissions in 2.1, so ended up importing the old permissions table. which sorted things.

    hgtonightUnderDogperegrine
  • LincLinc Detroit Admin

    @StumpyJoe Yeah, you can just add the column. No, order does not matter.

    hgtonightUnderDog
  • StumpyJoeStumpyJoe
    edited August 2013

    Thanks guys :) The good news is I was able to update to 2.1b1 after adding that column, hooray! I think! My utility/structure gave me an error the first time I ran it, but after rescanning I had way less scripts to run, and running it again seems to have caught me up to speed. (Rescanning gives me "There are no database structure changes required. There may, however, be data changes.")

    Unfortunately I'm getting a 500 Server Error on my discussions and category pages. Example:
    index.php?p=/discussions OR index.php?p=/categories/entertainment

    HOWEVER, it seems I can view most other pages, like inbox, dashboard, profiles...in fact if I visit a profile, and go into an individual discussion from there like index.php?p=/discussion/23698/test I can view the discussion just fine, AND post.

    I don't know if this is related or not, but I thought the culprit was a plugin, so I disabled them all. Now when I try to re-enable them I get "The addon could not be enabled because it generated a fatal error" and then it shows my site's 404 page in the dashboard pane (same thing happens when I try switching themes)

    I e-mailed my ISP to see if they could shed any light on the 500 error, but might anyone have some advice for the problems above based on the info I gave? Thanks.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    You need to enable the add on and applications and themes from the dashboard :)

  • @vrijvlinder which Addon do you mean?

    When I look at Applications, both Vanilla 2.1b1 and Conversations are running, and like I said when I disabled all my plugins to see if one of them was causing the 500 server error, I'm now unable to turn ANY back on--when I try, the dashboard says there's a fatal error, and shows a messed up version of my site's 404 screen. When I go to the themes page in my dashboard it says my current theme is the custom one I was using before, but when I try changing to a different theme I get that weird fatal flaw/404 error.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    edited August 2013

    @StumpyJoe

    You need to manually set the plugins you want in your conf/config.php file

    You can also change the theme in there.

    e.g. $Configuration['EnabledPlugins']['Gravatar'] = TRUE;

    The name of the plugin should be whatever the name of the plugin folder is, afaIk, respecting upper and lowercase.

    I have a local install to test on, so what I normally do is activate the plugin in my local site, then just copy and paste the config line to my live site.

    StumpyJoe
  • Hmmm I thought I saw them enabled in my config file, but I'll check again when I get home from work, thanks :)

    Speaking of config file, I noticed one line that said I was at version 2.1b, but then another that said 2.0.8.14... is there old stuff I should remove from my config after this update?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited August 2013

    change all the parts that say 2.0 to say 2.1b1 , seems like the installation was not 100% successful.

    as Whu606 said, I meant to say you need to enable from the config.php not the dashboard... like I wrote above sorry for the mistake..

    Remove from the config any setting from plugins that were not compatible with the new version. Remove plugins by deleting the folder in the file manager in the server, not from the dashboard.

    Some plugins will not show in the config if they are not enabled so you must put the whole line in manually to enable them.

    $Configuration[EnabledPlugins][Name of plugin]=TRUE;

  • Thanks, plugins seem to be enabled (example, I see VanillaStats in the dashboard now), but I'm still getting a 500 Server Error on my main discussions and category pages. Example: index.php?p=/discussions OR index.php?p=/categories/entertainment

    In other words, I can see my main page, which is my main categories page: index.php?p=/categories but if I click on "Discussions" or any of the Category links, I crash to the 500 error (still haven't heard from my ISP)

    I can view most other pages, like inbox, dashboard, profiles...in fact if I visit a profile, and go into an individual discussion from there like index.php?p=/discussion/23698/test I can view the discussion just fine, AND post.

    I feel like the issue is with how my categories are set up or being displayed? But I don't know where to look or what to change, as I haven't changed anything in the first place, and I don't think it's a plugin, now that you guys have helped me get those enabled (and thanks!)...also because I can go into an individual discussion and post just fine. I'd love more advice, as I'm a little stumped (and thanks again! haha)

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited August 2013

    sounds like a php problem? make sure your server is using the latest version

    HTTP Error 500 Internal server error

    The Web server (running the Web Site) encountered an unexpected condition that prevented it from fulfilling the request by the client (e.g. your Web browser for access to the requested URL.

    This is a 'catch-all' error generated by the Web server. Basically something has gone wrong, but the server can not be more specific about the error condition in its response to the client. In addition to the 500 error notified back to the client, the Web server should generate some kind of internal error log which gives more details of what went wrong. It is up to the operators of the Web server site to locate and analyse these logs.

    500 errors in the HTTP cycle

    Any client (e.g. your Web browser) goes through the following cycle when it communicates with the Web server:

    Obtain an IP address from the IP name of the site (the site URL without the leading 'http://'). This lookup (conversion of IP name to IP address) is provided by domain name servers (DNSs).
    Open an IP socket connection to that IP address.
    Write an HTTP data stream through that socket.
    Receive an HTTP data stream back from the Web server in response. This data stream contains status codes whose values are determined by the HTTP protocol. Parse this data stream for status codes and other useful information.
    This error occurs in the final step above when the client receives an HTTP status code that it recognises as '500'.

    Fixing 500 errors - general

    This error can only be resolved by fixes to the Web server software. It is not a client-side problem. It is up to the operators of the Web server site to locate and analyse the logs which should give further information about the error.

    Fixing 500 errors -

    Please contact your host whenever you encounter 500 errors

  • @StumpyJoe said:
    In other words, I can see my main page, which is my main categories page: index.php?p=/categories but if I click on "Discussions" or any of the Category links, I crash to the 500 error (still haven't heard from my ISP)

    As soon as you get that 500 (Apache) error, take a look in your Apache logs, the real error is mentioned there.
    First thing I would look at in any case is the rights on /cache and /Smarty directories. See the many many discussions on this forum...

    Are you using default theme or custom theme? Which one?

    peregrine
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Yea and post the content of the config.php without the private information ...

    Because things for some reason were not writing to config unless you use the fix provided by hgtonight... it could be you don't have things enabled, that should be...
    you should check that you have all the files complete, like the config-defaults ...

    I would reinstall it but by overwriting certain folders not everything.

  • StumpyJoeStumpyJoe
    edited August 2013

    The server's php version is 5.3.27. I'm using my custom theme, which appears in tact but needs some minor tweaking. I don't think(?) it's a php or theme issue since I can go into individual discussions to view and post in them just fine...

    /cache was at 777 but /Smarty was at 755. I switched /Smarty it to 777 (is this what it should be?), but that didn't do the trick.

    I do remember when I was transferring files two failed uploading in the application/dashboard folder (I remember one was in /views). Both were configure.php, so I deleted them on the server and uploaded them from the 21b1 folders successfully.

    I wish I could view my apache error logs but when I try it's blank. Still waiting to here from the ISP on that.

    Here is my config.php with the database stuff removed (fyi my /root directory is /chatter):

    // Conversations
    $Configuration['Conversations']['Version'] = '2.1b1';
    
    // Database
    
    // EnabledApplications
    $Configuration['EnabledApplications']['Conversations'] = 'conversations';
    $Configuration['EnabledApplications']['Vanilla'] = 'vanilla';
    
    // EnabledPlugins
    $Configuration['EnabledPlugins']['HtmLawed'] = 'HtmLawed';
    $Configuration['EnabledPlugins']['BotStop'] = TRUE;
    $Configuration['EnabledPlugins']['ButtonBar'] = TRUE;
    $Configuration['EnabledPlugins']['CleanLog'] = TRUE;
    $Configuration['EnabledPlugins']['Emotify'] = TRUE;
    $Configuration['EnabledPlugins']['LastEdited'] = TRUE;
    $Configuration['EnabledPlugins']['Quotes'] = TRUE;
    $Configuration['EnabledPlugins']['SplitMergeFE'] = TRUE;
    $Configuration['EnabledPlugins']['StopAutoDraft'] = TRUE;
    $Configuration['EnabledPlugins']['VanillaStats'] = TRUE;
    
    // Garden
    $Configuration['Garden']['Title'] = 'Chatter';
    $Configuration['Garden']['Cookie']['Salt'] = '50D035KLVJ';
    $Configuration['Garden']['Cookie']['Domain'] = '';
    $Configuration['Garden']['Registration']['ConfirmEmail'] = '1';
    $Configuration['Garden']['Registration']['DefaultRoles'] = 'a:1:{i:0;s:4:"4661";}';
    $Configuration['Garden']['Registration']['ApplicantRoleID'] = '4667';
    $Configuration['Garden']['Registration']['Method'] = 'Invitation';
    $Configuration['Garden']['Registration']['ConfirmEmailRole'] = '4667';
    $Configuration['Garden']['Registration']['CaptchaPrivateKey'] = '';
    $Configuration['Garden']['Registration']['CaptchaPublicKey'] = '';
    $Configuration['Garden']['Registration']['InviteExpiration'] = '-1 week';
    $Configuration['Garden']['Registration']['InviteRoles']['4663'] = '0';
    $Configuration['Garden']['Registration']['InviteRoles']['4664'] = '1';
    $Configuration['Garden']['Registration']['InviteRoles']['4667'] = '0';
    $Configuration['Garden']['Registration']['InviteRoles']['4668'] = '0';
    $Configuration['Garden']['Email']['SupportName'] = 'Chatter';
    $Configuration['Garden']['Version'] = '2.1b1';
    $Configuration['Garden']['RewriteUrls'] = FALSE;
    $Configuration['Garden']['CanProcessImages'] = TRUE;
    $Configuration['Garden']['Installed'] = TRUE;
    $Configuration['Garden']['InstallationID'] = '4A8D-208CA84D-63D2A2E8';
    $Configuration['Garden']['InstallationSecret'] = '9fd29922428f0594192e110f63f5ded09611318d';
    $Configuration['Garden']['Logo'] = 'YKCPSM0U4SJR.png';
    $Configuration['Garden']['Format']['Hashtags'] = FALSE;
    $Configuration['Garden']['Theme'] = 'NeverWrong';
    $Configuration['Garden']['EditContentTimeout'] = '-1';
    $Configuration['Garden']['Profile']['ShowActivities'] = FALSE;
    $Configuration['Garden']['Messages']['Cache'] = 'a:2:{i:0;s:6:"[Base]";i:1;s:24:"Vanilla/Discussion/Index";}';
    $Configuration['Garden']['SystemUserID'] = '6551';
    $Configuration['Garden']['Errors']['MasterView'] = 'error.master.php';
    
    // Plugins
    $Configuration['Plugins']['GettingStarted']['Dashboard'] = '1';
    $Configuration['Plugins']['GettingStarted']['Categories'] = '1';
    $Configuration['Plugins']['GettingStarted']['Registration'] = '1';
    $Configuration['Plugins']['GettingStarted']['Plugins'] = '1';
    $Configuration['Plugins']['GettingStarted']['Profile'] = '1';
    $Configuration['Plugins']['GettingStarted']['Discussion'] = '1';
    $Configuration['Plugins']['CleanLog']['DCount'] = '0';
    $Configuration['Plugins']['BotStop']['Question'] = 'What is three plus three?';
    $Configuration['Plugins']['BotStop']['Answer1'] = '6';
    $Configuration['Plugins']['BotStop']['Answer2'] = 'six';
    
    // Routes
    $Configuration['Routes']['DefaultController'] = 'a:2:{i:0;s:14:"categories/all";i:1;s:8:"Internal";}';
    $Configuration['Routes']['DefaultForumRoot'] = 'a:2:{i:0;s:11:"discussions";i:1;s:8:"Internal";}';
    
    // Vanilla
    $Configuration['Vanilla']['Version'] = '2.1b1';
    $Configuration['Vanilla']['Categories']['MaxDisplayDepth'] = '3';
    $Configuration['Vanilla']['Categories']['DoHeadings'] = '1';
    $Configuration['Vanilla']['Categories']['HideModule'] = FALSE;
    $Configuration['Vanilla']['Discussions']['PerPage'] = '20';
    $Configuration['Vanilla']['Comments']['AutoRefresh'] = '0';
    $Configuration['Vanilla']['Comments']['PerPage'] = '30';
    $Configuration['Vanilla']['Archive']['Date'] = '';
    $Configuration['Vanilla']['Archive']['Exclude'] = FALSE;
    $Configuration['Vanilla']['Discussion']['SpamCount'] = '2';
    $Configuration['Vanilla']['Discussion']['SpamTime'] = '60';
    $Configuration['Vanilla']['Discussion']['SpamLock'] = '600';
    $Configuration['Vanilla']['Comment']['SpamCount'] = '5';
    $Configuration['Vanilla']['Comment']['SpamTime'] = '60';
    $Configuration['Vanilla']['Comment']['SpamLock'] = '240';
    $Configuration['Vanilla']['Comment']['MaxLength'] = '12000';
    $Configuration['Vanilla']['AdminCheckboxes']['Use'] = TRUE;
    
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Using permissions that high will open you to hacking and most hosts disallow it , 775 is the max you need on anything...

    please remove the installation secret etc. numbers.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited August 2013

    can you try to change this

        // Routes
        $Configuration['Routes']['DefaultController'] = 'a:2:i:0;s:14:"categories/all";i:1;s:8:"Internal";}';
        $Configuration['Routes']['DefaultForumRoot'] = 'a:2:{i:0;s:11:"discussions";i:1;s:8:"Internal";}';
    
    
    to this 
    
        $Configuration['Routes']['DefaultController'] = 'discussions';
    
    and remove this 
    
    $Configuration['Routes']['DefaultForumRoot'] = 'a:2:{i:0;s:11:"discussions";i:1;s:8:"Internal";}';
    

    add this too if it is not there

    // Vanilla
    $Configuration['Vanilla']['Version'] = '2.1b1';
    
    UnderDogStumpyJoe
  • hgtonighthgtonight ∞ · New Moderator

    Something in the discussions controller is messing up.

    Try putting $Configuration['Debug'] = TRUE; in your config and visit www.example.com/discussions to see if anything else shakes out

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

    UnderDogStumpyJoe
  • @vrijvlinder I'm afraid that didn't do the trick. Changing those routes made it so I couldn't see the main page anymore. Also when you say remove those installation numbers, I can't tell if you mean from the post or the config file...I can't edit my post anymore if you mean the former, should I contact a mod? I don't know how sensitive that info is, and thought you just meant to remove the database info... :(

    @hgtonight thanks, that's given me some info to work with. When I go to /discussions, I see:
    Fatal error: Call to undefined function AdminCheck() in /chatter/applications/vanilla/views/discussions/index.php on line 6

    Line 6 of that file is AdminCheck(NULL, array('', ' ')).

    Not only that, but my main page that I thought looked a-ok gave me a bunch of errors with this:

    Debug Trace
    Info     Need to re-index theme cache
    Info     Need to re-index plugin cache
    
    Notice   Undefined property: stdClass::$LastCommentUserID
    /chatter/library/core/functions.render.php line 641.
    /chatter/themes/NeverWrong/views/categories/all.php line 58.
    /chatter/library/core/class.controller.php line 767.
    /chatter/library/core/class.controller.php line 1233.
    
    Notice   Undefined property: stdClass::$LastCommentName
    /chatter/library/core/functions.render.php line 642.
    /chatter/themes/NeverWrong/views/categories/all.php line 58.
    /chatter/library/core/class.controller.php line 767.
    /chatter/library/core/class.controller.php line 1233.
    
    Notice   Undefined property: stdClass::$LastDiscussionTitle
    /chatter/themes/NeverWrong/views/categories/all.php line 67.
    /chatter/library/core/class.controller.php line 767.
    /chatter/library/core/class.controller.php line 1233.
    /chatter/library/core/class.pluggable.php line 210.
    

    According to a conversation by you two, the re-index messages are purely informational, and there's nothing I need to actually do about those?

    Thanks again for your help/advice.

    UnderDog
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    I remember getting that error ....

    http://vanillaforums.org/discussion/23401/vanilla-2-1b1-need-to-re-index-theme-cache-need-to-re-index-plugin-cache-debug

    I can say that all this got fixed by applying the fix/hack provided by hgtonight...

    UnderDog
  • peregrineperegrine MVP
    edited August 2013

    1) did you Also delete the ini files from the cache folder.

    2) This forum is running with vanilla 2.2.3.4 - it seems to work....
    why don't you download that version and retry.

    3) see this for debugging
    http://vanillaforums.org/discussion/20231/how-to-become-somewhat-adept-at-modifying-vanilla-to-meet-your-needs-for-free

    4) If it were me, i would also clean up the permissions table so it uses the standard permissions and ids. (which is a totally different thing.

    $Configuration['Garden']['Registration']['ApplicantRoleID'] = '4667';
    $Configuration['Garden']['Registration']['ConfirmEmailRole'] = '4667';
    $Configuration['Garden']['Registration']['InviteRoles']['4663'] = '0';
    $Configuration['Garden']['Registration']['InviteRoles']['4664'] = '1';
    $Configuration['Garden']['Registration']['InviteRoles']['4667'] = '0';
    $Configuration['Garden']['Registration']['InviteRoles']['4668'] = '0';
    

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • *) 2 other things : before you clean up the permissions table : backup, backup, backup please :-)

    *) Did you convert from other forum software to Vanilla?

    peregrine
Sign In or Register to comment.