CRITICAL: Vanilla 2.1.8 released

12346»

Comments

  • Chalipa, I got the same error the first time. However, I did it one more time and it worked. O.o

  • @Linc & @Bleistivt - I just duplicated my website onto a private server where I intend to try the upgrading process again. I'm going to pay much closer attention to what I do on each step this round so I can help troubleshoot a little more. I did make one rookie mistake before in that I did not disable my plugins before trying the update. However, since I now have a non-public playground, I will try replicate what I did before to see if my discussions table gets wiped out again. If I end up replicating the same errors then I would be happy to email over DB dump.

    Linc
  • Wow, I'm kind of dumb.

    I've just performed repeat installations of the new update. I installed, reverted, and installed again. I have good news concerning my issue with the truncated discussions table. Mainly, I figured out what I was doing wrong (yes, it's my fault), but I was also able to get the update working great.

    Before I started, I made sure to download the newest update copy, vanilla-core-2.1.8p2. In my previous update attempt I was using vanilla-core-2.1.8p1. I'm not sure if that makes any difference, but it's worth noting.

    So, the truncating errors - and probably all errors - were caused by a mistake on my end. While it's a bit embarrassing, I'll still share my experience so that nobody repeats what I did. Basically, this was my first time updating my forums, and I misinterpreted the instructions. I made a bad assumption based on an old habit learned from performing manual updates of older Wordpress sites (old 2.0+ versions, hosted on private internal servers where the automatic updates didn't always work). In those manual updates, there would occasionally be times when the newer version of Wordpress would slightly change the format of the config file - so I would move my database and site settings over manually before uploading and call it a day.

    That's what broke my forums update.

    The instructions clearly don't ask you to do that, so like I said, the only reason I can think that I did that is because it's an old habit.

    Anyway, for anyone curious, here's what happens when I try and visit /index.php?p=/utility/update after uploading the update with a manually updated config file

    1. It redirects to dashboard/setup (which I dumbly assumed might be intentional to force an update on the forums and admin account - again - first time updating)
    2. The first error after re-entering my admin info is the GDN_Tag issue that other users mentioned. The suggested fix for that is removing the index named UX_Tag from GDN_Tag table, and then rerunning the update url - which works.
    3. The next error is the FK_Comment_DiscussionID that others also mentioned. When I see this, the discussion table get's truncated.
    4. After that, if I run the update url again (as suggested to solve those issues), I get redirected to the homepage of the forums, with all discussions truncated but the new update is applied (with whatever credentials are supplied for the new admin account). The site works, accounts are still there, users are still there. Only discussions are truncated.

    Now, it's important to note that if I upload the new update without making any changes to the config file, the update runs perfectly.

    So.... yeah... totally my fault on this one. May we all learn from my mistakes and continue to read instructions literally. Hopefully this information is helpful to someone.

    hgtonightwhu606R_J
  • btw, I LOL to my own post.

  • defilordefilor New
    edited February 2015

    Guys, I am having some issues with the update process as well... any help would be appreciated. I have been running 2.0.18.x and had a good look at all the instructions floating around, including the troubleshooting guide before I started. After running the /utility/update it actually said success, which was nice.

    However, when I browsed to the site and tried to log in Chrome tells me to "try again", while it does give me the menu so I can go to "discussions" manually and see all the threads, but as soon as I click on any thread it goes to a blank page...

    When using Firefox the browser tells me "Error: damaged content" or sth like that (don't know the precise terminology they used to translate into German), but when I use the "back" button I get to the login screen again and get the "discussions" link as well which gets me to where I want to be. But still I cannot access any thread, Firefox won't even try to open anything after I click on it. I can get to all the pages (profile etc), but that's it, can't get to the core, an actual discussion thread.

    I had all plugins disabled, have deleted all the old obsolete ones, double checked my config.php, enabled the debugger which only tells me to "re-index the plugin/theme cache", which I found out is irrelevant. Creating a new thread works, but I cannot access it afterwards either.

    I'm just running this forum to keep in touch with a bunch of friends and don't know much about code, so if there is anything extremely dumb I may have done accidentally please be gentle... ;)

  • LincLinc Director of Development Detroit Vanilla Staff
    edited February 2015
    • Clear *.ini files from the cache folder.
    • Are you using the default theme?
    • Did you accidentally overwrite a custom .htaccess file? (Are you running Apache?)
    • Try re-uploading your new copy of Vanilla, and confirm all the files properly replaced.
    • See if you still have a file at /applications/dashboard/views/default.master.php (noting the PHP file extension). If so, delete it. It's been replaced by default.master.tpl.
  • All ini files had been cleared, browser cache as well, default theme was set, did delete the php file as well, triple checked. :) I am running the forum on my QNAP, so I do any changes in the live environment while doing backups before major changes. Replaced the new .htaccess with the backed up version, no change... when hovering above the links to the individual threads I don't even get the browser preview of the link, whereas it works fine on the profile pages for example. I will try to replace the config.php entirely with the old version bar the plugins to see what happens...

    Reinstall entire forum? Would let me keep the database, right?

  • LincLinc Director of Development Detroit Vanilla Staff

    Reinstalling doesn't do anything but overwrite your config.php file; there's no magic happening there. I guess it wouldn't hurt if you have everything backed up, but I'd go full-monty and delete the entire file structure and reupload the new one fresh with a new copy of your plugins & themes if you're doing that.

  • Thanks, will give it a try and report back... greetings to the "D"! ;)

  • defilordefilor New
    edited February 2015

    Ok, I did some further investigating and found that vanilla duplicates the port numbers in the links that don't work, so its "xxxx:8082:8082". I found this: http://vanillaforums.org/discussion/26840/vanilla-is-duplicating-the-port-number - I am assuming this hasn't been backported to 2.1.8p2? Can I fix this manually?

  • LincLinc Director of Development Detroit Vanilla Staff
    edited February 2015

    We fixed a bunch of port issues lately that aren't in 2.1.

    https://github.com/vanilla/vanilla/pull/2170
    https://github.com/vanilla/vanilla/pull/2365
    https://github.com/vanilla/vanilla/commit/c8a2bd9d3d70896a45de00bed4fd96ab50b280ab#diff-bd6912ff9a67e6509f4490a88dbb4dc4

    I'd do a manual fix, yeah. These will all be remedied for the upcoming 2.2.

  • defilordefilor New
    edited February 2015

    Hm, tried it several times, even copied the whole classRequest.php from GitHub, but I couldn't get it to work... :/ went back to the file from 2.1.8p2 to make it work again, but that of course doesn't solve my original issue. Any idea when the 2.2 branch will be out? Matter of weeks or months?

    Anyway, I will likely try to fiddle with it some more with my basic knowledge, but have had enough for today.

    Thank you for your support, Linc! Do you think this is also what's causing the funky login problems?

  • LincLinc Director of Development Detroit Vanilla Staff

    I'd imagine a nonstandard port could be causing just about any issue, yes. Probably more like months til 2.2 is ready.

    defilor
12346»
Sign In or Register to comment.