Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Update from 2.1.10 to 2.2b1 Problem

Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

OK, lets make a new entry for this... ;)

As described here, I have some update Issues with the new 2.2b1 Version:

I did the steps as told by @Linc in the above discussion:

  1. Made a working copy of my Forum (changed also the database connection in config.php to the database copy)
  2. Backup database, .htaccess and conf/config.php
  3. Upload the new release's files so they overwrite the old ones.
    But on step 4: "Go to yourforum.com/utility/update to force any updates needed."

I did "http://www.caba.de/tmp/copyforum/utility/update"

I get an Browser error: "This webpage has a redirect loop"...

And there I'm stuck... :(

I did not post this on Github, it's most certainly my error somehow... O.o=)

I also have to mention, the Copy is on the same Website as the working Forum, but in an other Folder... maybe Cookie Problems?? O.o=) (p.s.: I did clear the Cookies)

The link to the Copy is http://www.caba.de/tmp/copyforum/

I am updating from Version 2.1.10,
using:
Opera, Firefox and Iron as Browser
Apache/2.2.22 (Debian)
PHP Version 5.4.36-0+deb7u3
MySQL Server Version: 5.5.41-0+wheezy1

as @Linc sugested, I'll look into the php error log.... when I find out where it is... :D:D

## BUT HERE IS ANOTHER IDEA:

To checkout the new Forum, I did a clean Install of it to play around... and it works flawlessly... ;)
Could I just EXPORT my Database and then IMPORT it in the new Forum?? I tried that with the SQL Exportfile from phpmyadmin but thats not working.. :D Should I use the Porter?
That could be a second and maybe easy solution?

Thanks in advance... ;)

«1

Comments

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    First try to delete the *.ini files in /cache
    If that doesn't already solves your problem, please post your .htaccess

  • Options
    Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    Deleted all *.ini Files in Cache, tried the "http://www.caba.de/tmp/copyforum/utility/update" and still get the "This webpage has a redirect loop" Error...

    Here is my .htaccess:

    # Original
    # If you modify this file then change the above line to: # Modified
    <IfModule mod_rewrite.c>
        RewriteEngine On
        # Certain hosts may require the following line.
        # If vanilla is in a subfolder then you need to specify it after the /.
        # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
        # RewriteBase /
    
        RewriteCond %{QUERY_STRING} ^p=/?([^&]+)(&(.+))?$
        RewriteRule ^index\.php index.php/%1?%3 [E=X_REWRITE:1,L]
    
        # The basic rewrite rule.
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteRule ^(.*)$ index.php/$1 [QSA,E=X_REWRITE:1,L]
    
        # Add the proper X_REWRITE server variable for rewritten requests.
        RewriteCond %{ENV:REDIRECT_X_REWRITE} .+
        RewriteRule ^index\.php - [QSA,E=X_REWRITE:1,E=!REDIRECT_X_REWRITE,L]
    
        # 301 redirect urls that start with index.php
        #RewriteCond %{REQUEST_METHOD} GET [NC]
        #RewriteCond %{REQUEST_URI} ^(.*?)/index\.php(.*)$
        #RewriteRule ^index\.php /%1%2 [QSA,R,L]
    </IfModule>
    
    <IfModule mod_headers.c>
       <FilesMatch "(?<!embed)\.(css|js|woff|ttf|eot|svg|png|gif|jpeg|jpg|ico|swf)$">
          Header set Cache-Control "max-age=315360000"
          Header set Expires "31 December 2037 23:59:59 GMT"
       </FilesMatch>
    </IfModule>
    
  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP
  • Options
    hgtonighthgtonight ∞ · New MVP

    @Dr_Sommer said:
    ...

        # If vanilla is in a subfolder then you need to specify it after the /.
        # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
        # RewriteBase /
    

    Change the rewrite base to the appropriate folder name and uncomment the line (remove the #). Probably /tmp/copyforum.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    That was the magic trick... thx, @hgtonight <3;)

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    RJ deserves credit too because he is was the first to suggest the htaccess file was screwed up...and asked you to post it.

    The # disables the rules. How did you end up with that if you backed up your htaccess file?

  • Options
    Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    Yes, of course, you're absolutely right Vrijvlinder... Hands up for RJ... ;);):)

    I just made a backup of .htaccess and conf/config.php... did not know that you have to restore it again over the new ones??
    I did not have these issues with my normal forum on any updates before... maybe because the copyforum is in a SubSub Directory? Aaand I'm also not shure if the Apache2 config was OK, since I had to tweak it with AllowOverride All etc, after RJ pointed me in this direction... :D
    But luckily it is just a testforum to exactly clear out any problems as appeared now...
    So ThX again to all of you... love this Community... <3B)

  • Options
    Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭
    edited June 2015

    Sorry to bother you once more... :dizzy:

    Have another Problem... after doing an Update to 2.2b1, everything went flawless, but after signin out and trying to sign in again... there is only a empty login popup window:

    And after some Time it shows me an "This webpage has a redirect loop" error... ;(
    Also the "register window" has the same issue...
    I checked the .htaccess and everything seems all right... also copying the old one over has no effect... tried also the working htaccess from the copyforum... also not working...

    I think its a htaccess error again but I can't figure it out what it is... :anguished:

    Here's the .htaccess File:

    # Original
    # If you modify this file then change the above line to: # Modified
    <IfModule mod_rewrite.c>
        RewriteEngine On
        # Certain hosts may require the following line.
        # If vanilla is in a subfolder then you need to specify it after the /.
        # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
        RewriteBase /CaBaFoRuM
    
        RewriteCond %{QUERY_STRING} ^p=/?([^&]+)(&(.+))?$
        RewriteRule ^index\.php index.php/%1?%3 [E=X_REWRITE:1,L]
    
        # The basic rewrite rule.
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteRule ^(.*)$ index.php/$1 [QSA,E=X_REWRITE:1,L]
    
        # Add the proper X_REWRITE server variable for rewritten requests.
        RewriteCond %{ENV:REDIRECT_X_REWRITE} .+
        RewriteRule ^index\.php - [QSA,E=X_REWRITE:1,E=!REDIRECT_X_REWRITE,L]
    
        # 301 redirect urls that start with index.php
        #RewriteCond %{REQUEST_METHOD} GET [NC]
        #RewriteCond %{REQUEST_URI} ^(.*?)/index\.php(.*)$
        #RewriteRule ^index\.php /%1%2 [QSA,R,L]
    </IfModule>
    
    <IfModule mod_headers.c>
       <FilesMatch "(?<!embed)\.(css|js|woff|ttf|eot|svg|png|gif|jpeg|jpg|ico|swf)$">
          Header set Cache-Control "max-age=315360000"
          Header set Expires "31 December 2037 23:59:59 GMT"
       </FilesMatch>
    </IfModule>
    

    RewriteBase /CaBaFoRuM or RewriteBase / has the same effect...

    put also this line in the config:

    $Configuration['Garden']['SignIn']['Popup'] = FALSE;

    same error, but without popup...

    Tested if .htaccess is working (put trash in it, shows error!)

    hmm... anybody knows what could be wrong? ThX... ;)

  • Options
    Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    I also turned DEBUG on with $Configuration['Debug'] = true; , but all I get is a notice "AssetModel::CssPath() with direct paths is deprecated. in /var/www/caba/CaBaFoRuM/library/core/functions.general.php line 911", think thats not related to my login issue...

    AAHH!! ;(

    Everything else is working... had to make a emergency login, so people can log in... ;(

    ANY Help is really appreciated...

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    The "Anmelden" button is opening a popup link but you can openthat link directly: http://caba.de/CaBaFoRuM/entry/signin
    If you try to open up that link, you get a "The page isn't redirecting properly" error so you have a redirection error.

    Looking at the console I only find "Reload the page to get source for: http://caba.de/CaBaFoRuM/index.php?p=/entry/signin". When any other page works without problems I would
    a) reupload all the standard Vanilla files in case you messed with some of those files
    b) disable all plugins that have anything to do with the login process

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    Strange! I see that your emergency login redirects to http://caba.de/CaBaFoRuM/index.php?p=/entry/signin

    But if you call that link directly, it ends up in a loop... :confused:

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    Have you checked your error and access log?

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    There is 302 redirect somewhere in your config.

    Search for more .htaccess files in any subfolders.
    Look at yourforum.de/dashboard/routes to see if there is something temporary defined

  • Options
    Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭
    edited June 2015

    Hi, RJ, thank you so much for taking the Time with my issue... ;)

    SO let me tell you what I did th whole day... :O :dizzy:

    1. I deleted the *.ini Files in Cache.. several times
    2. I Uploaded the 2.2b1 Vanilla files over the 2.1.10 Forum.. .also several times..
    3. disabled all plugins
    4. I couldn't find any more .htaccess Files except the one above and one in "MyForum/library/vendors/Minify":

      <IfModule mod_rewrite.c>
      RewriteEngine on
      RewriteRule ^([a-z]=.*)  index.php?$1  [L,NE]
      </IfModule>
      
    5. I'm so desperate that i DELETED Apache2 and reinstalled it... :awesome::anguished:;)

    6. checked if .htaccess is working

    What can I say... no success at all.. ;(
    So now I'm uploading the OLD Forum... and the Sign in and Register are working!!! :open_mouth:

    I'll certainly go crazy... :D:D:D

    here's the .htaccess of the old working forum:

    # Original
    # If you modify this file then change the above line to: # Modified
    <IfModule mod_rewrite.c>
       RewriteEngine On
       # Certain hosts may require the following line.
       # If vanilla is in a subfolder then you need to specify it after the /. 
       # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
       # RewriteBase /
       RewriteCond %{REQUEST_FILENAME} !-d
       RewriteCond %{REQUEST_FILENAME} !-f
       RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    </IfModule>
    

    I can't imagine what is going wrong... ;(

    As you could experience yourself if you go over the " emergency login ", it was working!!

    No clue... nooo clue... ;(
    :)

    I'll test the beta Forum once again on a copy.... ;(

  • Options
    Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    Sorry, I forgot these actions:

    1. installed a fresh new vanilla 2.2b1 and on the config site pointed to the old vanillaDB

    everything went fine, but also the same sign in/Register error... ;(

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    I have read on github that there are some problems with the new htaccess. So it wouldn't hurt to try the "old" (2.1) htaccess file with your new installation

  • Options
    Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭
    edited June 2015

    I tried that RJ, but also no luck... ;(
    this is nuts... as soon as I revert to the old forum, everything is working...

    Another crazy thing:
    I just REMOVED .htaccess in the old one... an its still working!! Everything, Sign in and Registering too!!!
    So it seems NOT to be a .htaccess issue?? :anguished:
    Question:
    Is it possible to NOT use .htaccess but do everything in apache2?

  • Options
    hgtonighthgtonight ∞ · New MVP

    @Dr_Sommer said:
    Question:
    Is it possible to NOT use .htaccess but do everything in apache2?

    The .htaccess file is merely a directory level configuration script for apache. It is not necessarily required. Url rewriting shouldn't work without it however.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • Options
    Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭
    edited June 2015

    @hgtonight: so it should run without the .htaccess file, as the 2.1.10 Forum does?
    but if so, how can I address these difficulties that I have with 2.2b1? Where could I search for an error? Or where could be the difference in Forum code, if 2.1.10 is working, but 2.2.b1 not?
    As stated, I deleted apache2 and all files in etc/apache2, tried everything with Allow override on/off... so where could I search more for the "redirect loop" error??

    I'm stuck... :lol::cry::scream::lol:

  • Options
    Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    Hm.... anybody an Idea how to pursue this error? I would soooo like to update to the 2.2, despite of Beta status, cause loving the new Editor... :+1::awesome:
    Working on a Copy on the same Server does not work, cause on Sign in/out it directs me back to the old forum... certainly cause of the Cookies... i think.. :scream::D
    If anybody knows a way to catch this error, thanks allot... ;)

Sign In or Register to comment.