Vanilla 2.5 is now available

LincLinc Director of DevelopmentDetroit Vanilla Staff
edited December 2017 in Releases

Vanilla 2.5 - the stable gold release - can now be downloaded. The upgrade instructions are in the README.md as part of the download. This release brings a completely revised Dashboard, a native RESTful API, "flat" categories, IPv6 support, enhanced security, and hundreds of bug fixes. Details in the pre-release discussion.

Upgrading Notes:

  • Vanilla 2.5 requires PHP 5.6 which is a change from earlier versions. We strongly recommend upgrading to PHP 7.2 as soon as possible. Many hosting plans allow a seamless transition via their control panel. Vanilla will end support of PHP 5.6 in 2018.
  • To upgrade, first delete /applications/vanilla/controllers/class.settingscontroller.php, then follow the normal upgrade process, including running /utility/update.
  • We strongly recommend deleting the contents of your /cache folder after upgrading, and again if you experience issues after the upgrade.
  • Test your plugin & theme compatibility in a safe place before upgrading your production forum. We do sometimes accidentally break backwards compatibility.

IF YOU HAVE TROUBLE UPGRADING AND NEED ASSISTANCE, PLEASE START A NEW DISCUSSION. If you are a developer and locate a reproducible issue, please file it on our GitHub tracker, noting your version as 2.5. We greatly appreciate the assistance.

Please upgrade to 2.5 as soon as possible.

R_JLinuxLeftystackmouserbrahmsonDr_SommerGermontTramssmokvinlistphreakkassiusAdriansubdreamerShadowdareBadVolttimme2707mlemaCodeHousedata66Csabbencssteam
«1

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    What a nice Christmas gift - thanks for investing your time!


    LincrbrahmsonAdrianCodeHouse
  • LincLinc Director of Development Detroit Vanilla Staff
    edited December 2017

    @R_J said:
    thanks for investing your time!

    Likewise. That HtmLawed catch was critical.

    Adrianboeka
  • Thank you so much for all your hard work! You rock B)

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator
    edited December 2017

    @Linc said:

    BEFORE doing that, you have to delete /applications/vanilla/controllers/class.settingscontroller.php. Not doing so will result in several inaccessible sections in the dashboard.
    (Only when updating from 2.3, in 2.4 there shouldn't be such a file)


    rbrahmsonLincCaylus
  • LincLinc Director of Development Detroit Vanilla Staff

    I've amended the OP accordingly.

  • Thanks. Very nice news.

    It it release closest to announcement date since like 1.8.

  • LincLinc Director of Development Detroit Vanilla Staff

    @maximka10 said:
    It it release closest to announcement date since like 1.8.

    Made all the more impressive by that version not existing.

    R_Jstackmousewhu606data66
  • I am now running a test site on 2.5 with data imported from SMF2 (to give my users a final moment to give feedback before abandoning the SMF once and for all).

    Thank you to all of you involved on the Vanilla 2.5 and Merry Cthulhumas to all!

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    Thank you soooo much.... :heart: :love: :+1:

    Im so excited!! :D :D :D

    Flower420
  • K17K17 Unkorneglosk - Français / French ✭✭✭
    edited December 2017

    YEAHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHH
    YOU GUYS ROCKS !

    Flower420
  • VivantVivant New
    edited December 2017

    Upgraded to 2.5 gold and it worked perfectly.

    There's an issue with the I like this plugin not working with 2.5 but the main install worked a treat.

    Thanks Linc and everyone else who helped get this release out.

  • LincLinc Director of Development Detroit Vanilla Staff

    I've monkey-patched 2.5 with two things:

    • Added the missing .htaccess.dist file.
    • Corrected a column in the database from DateExpire to DateExpires.

    If you need either of those fixes and downloaded Vanilla 2.5 before the time of this post, please re-download it and try again. Or, manually add the .htaccess file and fix the column name references manually.

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    Upgrade from 2.3.1
    Worked flawlessly... :heart:

    If you get an "404" Error after "yourforum.com/utility/update", read the README Instructions on this... :sunglasses: :+1: :lol:

    AND if youre using Appache2, ensure that Rewrite Mod is Enabled with:

    a2enmod rewrite

    Thanks again to all the Coders and Supporters of this great Forum Software... :heart:

    amy2
  • @Linc said:

    @maximka10 said:
    It it release closest to announcement date since like 1.8.

    Made all the more impressive by that version not existing.

    I mean 2.1.8

  • subdreamersubdreamer San Jose, CA

    Thank you so much for all your hard work! I am not currently using VF, but I still like to follow its development.

    R_J
  • GermontGermont New
    edited January 2018

    After this upgrade, the forum I manage had a sudden click burst from google searches, from 400-500, to 850 clicks per day. And sitemap is not yet entirely indexed: only 310 of 427 submitted pages, after long time halted at 230.

    Cosequently all other linked from the forum had a similar increase, I assume due to page rank transfer.
    The owner will give me a bonus! Thanks for your great work ;)

    LincFlower420
  • nice :)

  • Thank you! =)

  • mirXmirX
    edited January 2018

    Upgrade from 2.3.1 and get "Something has gone wrong". :3 Looks like a problem with locale

    This is error_log:

    _[15-Jan-2018 18:56:22 UTC] PHP Fatal error: Uncaught Exception: The addon at /locales/vf_ru doesn't have any info. in /home/interna1/public_html/library/Vanilla/Addon.php:189
    Stack trace:

    0 /home/interna1/public_html/library/Vanilla/Addon.php(80): Vanilla\Addon->scanInfo()

    1 /home/interna1/public_html/library/Vanilla/Addon.php(67): Vanilla\Addon->scan('/locales/vf_ru')

    2 /home/interna1/public_html/library/Vanilla/AddonManager.php(534): Vanilla\Addon->__construct('/locales/vf_ru')

    3 /home/interna1/public_html/library/Vanilla/AddonManager.php(1097): Vanilla\AddonManager->lookupSingleCachedAddon('vf_ru', 'locale')

    4 /home/interna1/public_html/library/Vanilla/AddonManager.php(1074): Vanilla\AddonManager->lookupByType('vf_ru', 'locale')

    5 /home/interna1/public_html/bootstrap.php(249): Vanilla\AddonManager->startAddonsByKey(Array, 'locale')

    6 [internal function]: {closure}(Object(Garden\Container\Container), Object(Gdn_Configuration), Object(Vanilla\AddonManager), Object(Garden\EventManager), Object(Gdn_Request))

    7 /home/interna1/public_html/vendor/vanilla/garden-container/src/Container.php(723): call_user_func_array(Object(Closure), Array)

    8 /home/interna1/public_html/bootstrap.php(308): Garden\Container\Container->call(Object(Closure))

    9 /home/interna1/public_html/index.php(22): require_once('/home/interna1/...')

    10

    thrown in /home/interna1/public_html/library/Vanilla/Addon.php on line 189_

«1
Sign In or Register to comment.