Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

404 File Not Found - On the Index Page!

edited September 2009 in Vanilla 2.0 - 2.8
Moved to GitHub.

I'm getting a 404 message whenever I visit my test installation's root directory. I've installed on a subdomain, and I get the 404 message at and, but not on This occurs with url rewrite on or off. Any ideas?


  • MarkMark Vanilla Staff
    Is your apache configured to use index.php as a default file?
  • edited September 2009

    I don't know if this is a bug or just user error, but it is driving me crazy. I've installed Garden on both localhost and a test server on a subdomain.

    I'm still getting the default 404 message whenever I visit my test installation's root directory, as noted above.

    Everything seems to work fine on my localhost installation, but this problem's cropping up on my MediaTemple gridserver. I cannot reproduce this problem on localhost, and it does not seem to be an issue on subdomains. My mind is blown.

    Here is the contents of my .htaccess file if it helps:

    AddHandler php5-script .php <IfModule mod_rewrite.c> RewriteEngine On RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^(.*)$ index.php/$1 [QSA,L] </IfModule>
  • Did you make sure that mod_rewrite is enabled?
  • edited September 2009
    Yep, mod_rewrite is up and running on Apache, and I've enabled and/or disabled it under "General Settings," and neither works.

    Understand, now, that all the other pages work just fine, with rewrite on or off. So, for example, both and work, depending on whether I have rewriting on or off.

    It just seems that neither / or /index.php will redirect to /index.php/.
  • As seen somewhere (maybe in github issues), default (maybe upstream or a particular distribution, I don't know as I use nginx) apache conf disallow override by .htaccess.
  • Here's a question that just occurred to me: If I'm getting a "File Not Found" message on the index page, exactly what file or page is Garden looking for?
  • @bean: If you're suggesting that my .htaccess isn't working, I don't think that's the problem. If I take out the rewrite rules listed above, I start getting real Apache errors, and if I take out the AddHandler stuff, Garden blows up entirely.

    Plus, if I tell Garden (via "General Settings") not to rewrite the urls, I get the same problem -- the root directory won't take me to /index.php/.

    Maybe I could add another rewrite rule to specifically address this?
  • RefringeRefringe New
    edited October 2009
    The problem is, Media Temple Grid Servers do not support the "IfModule" tag in your .htaccess file. If they are removed, the 404 goes away and this issue is resolved.

    With a Media Temple Grid Server, your .htaccess file should look like this:

    // Incorrect, read my next reply.

    This did the trick on my GS, so I hope it works for yours.
  • MarkMark Vanilla Staff
    @Refringe - YES! Thank you!!
  • RefringeRefringe New
    edited October 2009
    It seams I've been had.

    Media Temple does in fact support the "IfModule" tag. I thought it was working when I removed it, but I just tried a fresh install to double check, my fix doesn't change anything.


    Let me just re-clarify the issue we're having.

    Here is a completely fresh install of Vanilla2 on Media Temple. I haven't touched anything (except for adding the Addhandler in the htaccess file).

    "File Not Found"

    However when I visit the following URL I get the default discussions page.

    I don't know exactly what's going on behind the scenes here, but it looks as if without the "index.php/" in the URL, something's not being initialized.


    When the "use Garden's .htaccess file to rewrite urls" setting is enabled the root still gives a 404 error.
  • ToddTodd Chief Product Officer Vanilla Staff
    In your installation your example above you are not using mod rewrite, correct?
  • hey aerocapture -

    I had a 404 error back in August; here's how I resolved it:
  • @Todd - ModRewrite is enabled on the server and I'm using the default Vanilla2 .htaccess file, so no, ModRewrite is being used.

    However the "use Garden's .htaccess file to rewrite urls" setting is disabled (as it is by default).
  • ToddTodd Chief Product Officer Vanilla Staff
    I think there are configuration problems that might be fixed with jbminn's solution, but I'll look into your specific problem @Refringe. It seems like there might be a bug with this configuration.

    Truth be told I haven't looked at Vanilla without the use .htaccess option for a while.
  • fyi - I successfully installed using my instructions & a fresh source tarball yesterday
  • ...and by the way, I love Vanilla. I saw/heard Mark present in Mountain View last week. I was impressed, as was the VC sitting next to me.
  • MarkMark Vanilla Staff
    @jbminn - you should have said hello!
  • dude, you had your hands full. Plus, I work best behind the scenes. See you at Defrag? I'm hosting a pre-conf dinner & would love to have you as my guest.
  • @Todd - It's happening with the .htaccess option enabled or disabled. I can't figure it out for the life of me.
  • ToddTodd Chief Product Officer Vanilla Staff
    And this is on the Media Temple grid? Is there any specific plan you are on @Refringe? I might get an account for a month and try it out.
Sign In or Register to comment.