Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

404 File Not Found - On the Index Page!



  • I have tried every single solution listed above and none of them worked for me.

    I am having exactly the same problem of 404 error in:


    but not in:


    I believe the problem is in .htaccess and with the mod_rewrite, but I just have no idea how come by adding the RewriteBase doesn't work for me..

    any1 still following this issue? I am on a host "streamline" in the uk...
  • @Louis thanks alot changing to simple CGI fixed my problem! Will I see any any noticeable performance decreases vs FastCGI?
  • @dejitaru Glad it helped. Honestly, if you don't notice the difference now, you likely won't notice it later either, at this level. FastCGI is designed to keep a few PHP processes running on the back burner, rather than creating a new process for each request. It can speed up a site if it's not accessed as frequently, but honestly I can't tell the difference currently, myself. If I had to pick, I'd use FastCGI, but ... other than that bias, I'm using whatever works ;-)
  • thanks for all you post and suggestions but i have tried everything and its still not working for me, my hosting company is westhost and the domain is every-time i try to edit the site settings i get the error "403 Forbidden" message, i have changed the settings.php permissions and also the httaccess file from the original to what was recommended here.
    any other suggestions would be greatly appreciated.
  • TimTim Operations Vanilla Staff
    @organdonor I see that your forum is now working properly... is this bug fixed for you?

    Vanilla Forums COO [GitHub, Twitter,]

  • @Tim Similar issue - details posted here:

    Any ideas? PS: Great job on the RC!
  • hey guys, I think I got the solution (FastCGI) !
    Simply replace "/$1" to "?$1" !
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php?$1 [QSA,L]
    Tested on Vanilla2 RC1.
  • None of these solutions have worked for me. Animated icon still showing in Vanilla forum Configure an Authenticator settings page.

    Tried the htaccess solution, and the $Configuration['Garden']['RewriteUrls'] = FALSE; solution to no avail.

    Any other suggestions? Apparently this "was" fixed in Vanilla 2.0.6, but that's the version i'm having problems with, how about all of you?
  • Here's a fix for the constant loading of the settings:
  • I'm getting a page not found.. It seams to only in ie. Any help
Sign In or Register to comment.