HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla 3.3 is now available

124

Comments

  • Awesome thanks.

    No. I use a file browser to manage all forum image uploads, and I use gravatar for all profile purposes. And I am thinking of even using the first letter of the username for pictureless profile experience.

    I just noticed this gd requirement for the first time in 3.3.

    Has this always been the case? If so, then it is a fault on my end. My server update must have altered some settings ... hmmm!

    afmadeira
  • charrondevcharrondev Developer Lead (PHP, JS) Montreal Vanilla Staff

    @donshakespeare We've actually always had GD in the installation requirements (it has historically bee used to generate profile image thumbnails).

    In the latest releases we are also resizing and modifying uploaded photos in the Forum and in the dashboard.

    donshakespeare
  • When I run this url, I get page not found and also /update

  • Hello

    I need help

    where can I find it

    "View Discussions and Categories on"

    Needed to change to polish

  • title in title looks like this

    Otwieram salon - Mam salon Discussions on

    And it should look like this

    Otwieram salon - Mam salon Dyskusje na temat

    How to change that? is not there in the locale?

  • edited February 25

    the point is

    <head><meta charset="utf-8"> <meta http-equiv="X-UA-Compatible" content="IE=edge"> <title>View Discussions and Categories on </title>

    "View Discussions and Categories on " how to change it to "Zobacz dyskusje i kategorie na"


    <head> <meta charset="utf-8"> <meta http-equiv="X-UA-Compatible" content="IE=edge"> <title>Otwieram salon - Mam salon Discussions on </title>

    "Otwieram salon - Mam salon Discussions on" how to change it to "Otwieram salon - Mam salon Dyskusje na"

    ?????????? does anyone live here ?????????????

  • Support offered is on free basis meaning they do not get paid for it

    You posted 2 times today, while it may happen you cannot expect a reply in that time.

    Please look in the tutorials and Localization category which is also where should you ask for help about this.

  • edited February 25

    thanks

  • fr3em1ndfr3em1nd ✭✭

    Hey guys, where can i find compatible plugins for 3.3 ?

  • phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP
    edited March 6
    • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
    • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
  • yguerdatyguerdat Delémont New

    Under last activities the avatar is no more display.

    Would be nice to be fixed for the version 3.4 :-)

  • CirphrankCirphrank Benin New

    Was this auto installed for some using it via softaculous?

  • KasparKaspar ✭✭

    Yes, I have installed via softaculous (to a new test setup).

    Update of my live forum was done manually though.

    Cirphrank
  • CirphrankCirphrank Benin New

    I asked for I had try updating earlier, repeatedly via softaculous but kept getting errors and I stopped, I even had to savage the site with backup restore. Yesterday, I decided to check again and saw v 3.3 installed already, I was perplexed.

  • Hey can anyone tell me which group addon i can use to my community ?

    Current groups addon is not working .

    It will be help to let me know if there is a solution for that.

    Thanks

  • LincLinc Former Staff Detroit Admin
    edited June 10

    This release added a requirement for the Intl PHP extension. This is not mentioned in this discussion, in the docs, nor checked in the code.

    If you upgrade to Vanilla 3.3 without this PHP extension it will absolutely crash your forum.

    Reference: https://github.com/vanilla/vanilla/issues/9499

    This is so irresponsible I'm apoplectic.

    neptronixpinchies
  • LincLinc Former Staff Detroit Admin

    You can't even stub out the class just to make it exist, because that triggers a bunch of code that was properly checking the existence of the class before triggering, so you just double down on the errors.

    Your options are: A) Recompile PHP on production (in case you were bored) or B) Hack that line.

    The problem is here: /applications/dashboard/controllers/api/LocalesApiController.php

    Find this line:

    $displayName = \Locale::getDisplayLanguage($row["localeKey"], $locale);
    

    And just hard code your language (and pray it doesnt break something else before you can install the dependency):

    $displayName = 'English'; //\Locale::getDisplayLanguage($row["localeKey"], $locale);
    

    gl;hf

    neptronix
  • Hello, my forum still runs with the 2.6.4 version. Can I directly update with 3.3? Is there a instruction page that can help me?

Sign In or Register to comment.