HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Plugins & Themes that WORK and DON'T work in vanilla 2.1

123457»

Comments

  • peregrineperegrine MVP
    edited September 2015

    @nikonrumors said:
    those are the plugins that work in 2.1.11: BotStop, Emotify, FileUpload, Flagging, HTMLPurifier, Last Edited, Pockets, Post Count, Quotes, Role Titles, ShareThis, Signatures, Sitemaps, Stop Forum Spam, Touch Icon, Vanilla SEO, WhosOnline

    • I would recommend you use AddRegistrationQuestion plugin instead of Botstop

    • Add Registration Question plugin does NOT have the problems listed below and serves the same function.


    • Botstop doesn't use the improved password checking that 2.1 offers.
    • it will also not work properly with profile extender registration fields.
    • it can also be incompatible with other plugins below and cause them to break.
    • Botstop uses old vanilla 2.0 views.
    • Botstop also lacks other hooks that vanilla 2.1 offers.

    these plugins also have the same problems that Botstop has regarding 2.0 views.

    FirstLastNames - same problems as above
    Mailchimp - same problems as above
    Phplist same problems as above

    feel free to do what you wish, if you experience the problems I listed you know why.

    replyto and anonymouse is broken in vanilla 2.1 and will cause problems.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinder
  • In Vanilla 2.1.11

    Whosonline isn't working for me. It just says 1 user is online, and that user is the person who is logged in.

    ProfileExtender wasn't working for me until @peregrine created the following file from Vanilla 2.2 with a slight adjustment: http://vanillaforums.org/discussion/27874/profile-extender-fields-blank-when-editing-profile#latest

    Also, in dashboard/settings/registration, whenever I click on "approval" and click "save", nothing changes and it still directs the register buttons to the "basic" registration form.

    Perhaps some of the troubles I'm having have to do with the fact that I imported in my database from 2.0.17.9 directly to 2.1.11 and I wonder if some necessary database tables are missing.

    All of the other plugins work as far as I can tell.

  • peregrineperegrine MVP
    edited September 2015

    @gratiafide

    All of the other plugins work as far as I can tell.

    which ones are these?

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • I guess it would help to tell you which ones we are using.

    Working plugins:

    Add Registration Question, Button Bar, Buttons, Emotify :), Flagging, Gravatar, In This Discussion, OnlineNow, Post Count, Profile Visitors, Role Badges, Sprites, Vanilla SEO, and WYSIWYG (CLEditor)

Sign In or Register to comment.