Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Yaga on = Blank page

Using Yaga 1.0.3. It's been working fine for two months, and now all of a sudden broke the whole forum. Every page of the forum and dashboard was blank until I renamed the yaga folder.

How do I even begin to work out the problem here? Database seems fine.

«1

Comments

  • Perhaps a separate issue but I'm now also getting bizarre alert messages on some threads when posting or deleting posts.

    {"Targets":[{"Target":"#Comment_637405","Data":"","Type":"SlideUp"}],"FormSaved":true,"DeliveryType":"BOOL","Data":"MQ==","InformMessages":[],"ErrorMessages":"","RedirectUrl":""}

  • One more thing ... I can't actually disable Yaga now by clicking the 'Disable' button in the dashboard. If I rename the directory it stops working, but clicking 'Disable' just loads a blank page.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    "Blank page" is the default error behavior: http://vanillaforums.org/search?adv=&search=blank+page&title=&author=&cat=all&tags=&discussion_d=1&discussion_question=1&comment_c=1&comment_answer=1&page_p=1&within=1+day&date=

    And the default answer is: add $Configuration['Debug'] = TRUE; to conf/config.php and report the "real" error ;)

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    And when you get JSON messages, you should check the JavaScript error console of your browser for errors.

  • Ah ha

    [Error] Failed to load resource: the server responded with a status of 500 (Internal Server Error) (analyticstick.json, line 0)

  • Oh, and Debug is showing me this:

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 72 bytes) in /home/bomberbl/public_html/discussion/library/core/class.configuration.php on line 1159

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    For the memory size error, you would have to raise the php "memory_limit" but normaly that limit is set by your hoster. You would have to ask them about a higher memory limit. You can also try to set it with a custom php.ini, but it might not work...

    Add memory_limit = 128M to your php.ini or
    add php_value memory_limit 128M to your .htaccess file or
    add ini_set('memory_limit', '128M'); directly to index.php

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    For the 500 internal server error, you would have to look at the error log of your server. But I would try to solve the memory limit problem first.

  • Thanks, I've increased it to 256MB, and still occasionally getting just a blank page with just this error...

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 72 bytes) in .../class.configuration.php on line 934

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Sorry I do not know how to trace memory consumption :(

  • hgtonighthgtonight ∞ · New Moderator

    How big is your configuration file?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • @hgtonight 13kb

    I can't tell if it's specifically related to Yaga, or Memcached, or both. I just know the forum came back to life (albeit with errors) after changing Yaga's directory name to disable it.

  • hgtonighthgtonight ∞ · New Moderator

    You can disable addons by editing the conf/config.php file, no need to change filenames.

    What other addons are you using? 256mb seems excessive.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • peregrineperegrine MVP
    edited September 2015

    @R_J said:
    For the 500 internal server error, you would have to look at the error log of your server. But I would try to solve the memory limit problem first.

    or vice-versa :)

    or it could be a redirection loop or some type of looping that causes the internal error that cause the eating up of memory and the memory consumption.

    I'm betting on a loop of some type that is eating your memory. And no matter how large you set it, it will always be exhausted.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    R_J
  • @peregrine said:
    R_J said:

    Yeah that seemed to be the case. I kept increasing the memory and it kept being exhausted, until the server ended up just crashing completely.

    I've gone through my Config file and disabled all plugins, and I'm still getting just the error message:

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 92645304 bytes) in /home/bomberbl/public_html/discussion/library/core/class.configuration.php on line 866

  • hgtonighthgtonight ∞ · New Moderator

    What version of Vanilla are you running?

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • when disabling plugins, best if you can disable via dashboard, otherwise you can still have remnants such as routes added that could be prime candidates.

    the other thing to look toward is your theme and see if you get memory exhuastion from default theme as well.

    look into your routes and your .htaccess or nginx config files as well depending on your server.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • @hgtonight said:
    What version of Vanilla are you running?

    2.1.1

    But I was using the updated version of YAGA that greatly reduced CPU usage on my server. If that's the culprit perhaps we found a new issue?

    @peregrine said:
    when disabling plugins, best if you can disable via dashboard, otherwise you can still have remnants such as routes added that could be prime candidates.

    the other thing to look toward is your theme and see if you get memory exhuastion from default theme as well.

    look into your routes and your .htaccess or nginx config files as well depending on your server.

    Okay thanks. I have tried changing my theme in config, but I can't even get the dashboard to load right now.

  • peregrineperegrine MVP
    edited September 2015

    2.1.1

    do you mean 2.1.11? if not upgrade.

    make a copy of your config file and save it somewhere.

    then...

    if you want, you could post your config.php (remove the private information).

    you can manually change theme in config

    bittersweet is a good test theme.

    $Configuration['Garden']['Theme'] = 'bittersweet';

    if you have any routes in config file you can delete them

    the only one you really need is:

    $Configuration['Routes']['DefaultController'] = array('discussions', 'Internal');

    also check any bootstrap.early bootstrap.before bootstrap.late bootstrap.after files for any changes you have made. they could also be causing you issues.

    and if you use apache (post your .htacess)

    and if you use nginx post your config file for that.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • edited September 2015

    Thanks @peregrine !

    • I've updated all the Vanilla site files, but I can't run the updater (get the memory exhausted message)
    • .htaccess is unchanged in the directory this forum is stored in
    • config.php can be viewed here: http://pastebin.com/RF9y5x55
    • Installed bittersweet theme and enabled it in config, but just can't get any pages to load

    .html files will load on the server, but I can't get any Vanilla pages to work.

  • edited September 2015

    Update:

    Just increased memory again (most of my visitors are asleep atm) and ran the update page ... 'update was not successful'. But in the footer of the dashboard I see Version 2.1.11 so I don't know what that means!

    Anyway, site's ticking along again on the Bittersweet theme. Going to try turning things back on ... slowly.

    Thanks thanks thanks for the quick responses!

  • hgtonighthgtonight ∞ · New Moderator

    Please remove the _Quotes plugin from the enable list. Unless this an intentional fork you made.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • peregrineperegrine MVP
    edited September 2015

    'update was not successful'

    you need to correct this!!!!!

    delete ini files in cache as well.

    run utility/structure (do you see any problems?)

    rescan and run again.

    then run utility/update a few times.

    you want things to be successful, otherwise you will have issues!!

    also turn on debugging if necessary in the config.

    http://vanillaforums.org/discussion/28420/faq Question 29.

    the civiltongue words in your config were a treat!!! :grin:

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Also, reset your cookie-salt (and installation secret) if you don't want me to login to your forum as your new admin :winky:

    Always remove these sensitive values when you publish your config.php.

    -

    peregrineR_J
  • @mtschirs said:
    Also, reset your cookie-salt (and installation secret) if you don't want me to login to your forum as your new admin :winky:

    Always remove these sensitive values when you publish your config.php.

    Oops.

    Can these be any random values? Or is there a proper reset button somewhere?

  • @hgtonight said:
    Please remove the _Quotes plugin from the enable list. Unless this an intentional fork you made.

    It is.

  • hgtonighthgtonight ∞ · New Moderator

    @Simeon_Griggs said:
    It is.

    Awesome :)

    @peregrine said:
    the civiltongue words in your config were a treat!!! :grin:

    I got a :lol: out of that as well.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • edited September 2015

    @peregrine

    • No problems in the utility/structure
    • Ran update several times, still not successful
    • No errors reported with Debug on

    Oh yeah the civil tongue words are a laugh ... I think they were the first item I found when googling 'swear words list' or something

  • I don't know how to reset the installation secret (but that is only used for communication with the Vanilla analytics servers). Regarding the cookie salt: you have to replace it manually with any random string (treat it as the master-password to every user-account), but all active sessions will be logged out, i.e. every user has to re-login.

    -

  • peregrineperegrine MVP
    edited September 2015

    @Simeon_Griggs said:
    No problems in the utility/structure
    Ran update several times, still not successful
    No errors reported with Debug on

    do you have a really large database?
    you might try purging the activity table.
    emptying the log table.
    to reduce the size as well.

    sounds like you need @linc

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

«1
Sign In or Register to comment.