HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

CRITICAL: Vanilla 2.1.8 released



  • Problem Solved; i forgot to disable the plugins

  • heliodonheliodon New
    edited January 2015

    My experience has paralleled that of morepotates. Trying an install of 2.1.8p2 using my database file from a 2.0.18 site. Receive this error just after filling out the basic information fields (database, user, password, etc.) in the install dialog.

    Can't DROP 'FK_Comment_DiscussionID'; check that column/key exists|Gdn_Database|Query|drop index FK_Comment_DiscussionID on GDN_Comment

    This is a basic install, no plugins.

  • @heliodon said:
    Receive this error just after filling out the basic information fields (database, user, password, etc.) in the install dialog.

    You do not have to go through the install dialog again, if you are upgrading from vanilla
    Do you still have the config file from your previous install? Copy that to the /conf folder.

  • heliodonheliodon New
    edited January 2015

    Thanks Bleistivt for responding. I did try to use my config.php from the 2.0.18 site (after disabling all plugins). This does present a site but I cannot login using my admin account or my backup account. After entering credentials it just goes back to the "Howdy Stranger" version of the main page. Go figure.

  • @heliodon Turn on debug mode and check for any errors when trying to log in.

    Also remove all the "EnabledPlugins" lines from the config.php and try visiting utility/update again

  • heliodonheliodon New
    edited January 2015

    @Bleistivt Thank you for the suggestions.

    I ran utility/update again and it returned a "success" page with a smiley face background. That's good. However, I still cannot login using my admin and backup accounts from the previous site.

    I added

    Set $Configuration['Debug'] = TRUE;

    to my config.php and the site home page URL returns a blank page.Where would I look for errors?

    I added

    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php';

    and the site loads but I cannot login. No error messages.

    The only "EnabledPlugins" line is

    $Configuration['EnabledPlugins']['HtmLawed'] = 'HtmLawed';

    I removed that but still could not log in. I have since restored that line as I read it is necessary.

    I have tried several browsers and the behavior remains the same. I ran utility/update another time - no help.

  • Yes, my bad, you need to leave HTMLLaweds line.

    So you get a blank page with

    $Configuration['Debug'] = TRUE;

    Try what R_J suggested above:

    @R_J said:
    Try changing

    ini_set('display_errors', 0); to ini_set('display_errors', 1); in your index.php

  • Hi, we have updated our forums apparently successfully.
    Thanks :)

  • chanhchanh OngETC.com - CMS Researcher ✭✭

    For me the upgrade is a piece of cake, do as the upgrade notes and it just works. Thanks

  • @Bleistivt Thank you for sticking with me on this.

    I have added ini_set('display_errors', 1); in my index.php and now $Configuration['Debug'] = TRUE; added to my config.php file produces the following message at the bottom of the home page when I reload it:

    Debug Trace
    Info    Need to re-index theme cache
    Info    Need to re-index plugin cache

    Trying to login using my admin credentials just returns me to the home page with a "Howdy Stranger" message.

  • Now I'm confused, where are you getting a blank page - or was that issue resolved?

    If you are using the popup signin, could you try signing in through the entry/signin page?

  • heliodonheliodon New
    edited January 2015

    @Bleistivt - I apologize for the confusion.

    First attempt - an install with my previous 2.0.18 config.php the process stalled out with the Can't DROP 'FK_Comment_DiscussionID'; check that column/key existsproblem that @morepotatoes reported on 15 January.

    I then tried to use my 2.0.18 database file in an install with a fresh config.php and filling out the install dialog.

    You then helpfully advised that I did not have to go through the install dialog again. I tried using my config.php from the 2.0.18 site again (this time after disabling all plugins and running utility/upgrade). This presented a success page and I can now see my site in Vanilla's Standard theme. But, I cannot login using the admin account or my backup account from my 2.0.18 site. After entering credentials it just goes back to the "Howdy Stranger" version of the main page.

    You suggested adding Set $Configuration['Debug'] = TRUE;
    to my config.php. After doing so the site home page URL returned a blank page. This issue was resolved by following your suggestion to add ini_set('display_errors', 1); in my index.php. I am now receiving debug messages (reindex plugin and theme caches) but the failure to login issue remains.

    I am attempting to sign in using this page:


  • heliodonheliodon New
    edited January 2015

    @Bleistivt - I have signed in successfully. In reviewing the config.php file from 2.0.18 I found $Configuration['Garden']['WebRoot'] = 'http://....; pointed to the wrong directory. My bad.

    Thanks for your help! I really appreciate it.

  • edited January 2015

    I did as was suggested to heliodon, uploading my past config file (with enabled plugins stripped). Then hit the update page, I got update successful but now all of the forum's past discussions have been deleted. I just checked the database and there are 0 entries in GDN_Discussion. The rest of the database seems intact. I have a backup, but I'm very confused how or why that would happen.

    This is all very frustrating and disheartening.

  • R_JR_J Ex-Fanboy Munich Moderator

    @morepotatoes: in the code behind /utility/update there is no way to erase the content of a table. That could only be done if you have enabled a plugin that on its activation deletes all discussions (and I doubt there is such a plugin). Furthermore you have first deactivated all plugins. So I guess the deletion happened before the call to /utility/update.
    I've seen that you had other problems before: http://vanillaforums.org/discussion/comment/223796/#Comment_223796
    Could it be that you have deleted the contents of the discussion table or dropped it completely when you were trying to fix that problem?

  • edited January 2015

    Can't we just get a list of individual files that need to be replaced? I don't want to overwrite all the files as i have been changing some of them, from theme css files even to some php files.

  • @MarcusMaximus If you changed core files you should put these changes into a plugin and / or a custom theme. It will save much more time in the long run.

    But if you want a diff you can get the it from the first post. Just append .diff or .patch to the URL


  • MarcusMaximus good reason not to edit the core, unless you want a fork, then it is entirely your responsibility from then on to maintain, update, support.

    This is a support forum for the core, rather then forks of the core which can't possibly be supported.

    grep is your friend.

  • Hi all,

    Upgraded manually by replacing only the files in the diff in patch 2. Ran the updater. Worked fine.

    Forum displays, but when someone tries to post, they get:

    Specified validation function could not be found.|Validation|Validate|ValidateString

  • LincLinc Former Staff Detroit Admin

    @lament Are you sure you were already on 2.1.7? That's when ValidateString was added. You need to do a full upgrade, I suspect.

Sign In or Register to comment.