HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Feedback Issues Questions for Galleries Plugin



  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited August 2013

    @javo Thanks !! I am glad you found it useful .

    The upload size is controlled by the upload settings in the config and also in the gallery.php line 264 you would change the $maxSize

    function uploadNresizeGallery($file, $dir){
        global $PATH2IM;
        $Lwidth =1000;
        $Lheight =1000;
        $maxSize = 6656000; // KBs in size
        $mode = 0666;
        $countinue = true;
  • Hi there, I've just done a completely new install on a different site with exactly the same problem. Yet I note that javo has not had any problem at all. I've zipped it back up and attached it but I haven't changed it. I'm putting the Galleries folder straight into the plugins folder and then enabling it.

    @javo - could you send me a URL link please so I can see what happens on your site. Thanks

    @vrijvlinder what URL should it be trying to go to when I try to edit a gallery?



  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited August 2013

    The url to the album should look like this , I could not find anything wrong with the plugin , I installed your copy onto another site and it worked fine.


    you can look at a sample gallery here


    try downloading an older version http://vanillaforums.org/addon/galleries-plugin-1.1

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    I wrote down the wrong url to my gallery up there this is the correct one


  • That's the URL mine is trying to access. Should the Galleries plugin create a folder called /gallery/ in the folder /var/www? Is this a permissions issue on my servers do you think?



  • @demsley, it shouldn't create a directory called 'gallery' in the '/var/www' directory of your site. It works by creating a route in Vanilla's system that will internally redirect '/gallery' to the correct target.

    Add Pages to Vanilla with the Basic Pages app

  • Thanks for a quick response. I'm completely baffled now. I've tried it on a number of servers.

  • ShadowdareShadowdare r_j MVP
    edited August 2013

    @demsley, check the routes setting page of your Vanilla dashboard for a route called 'gallery' or something similar. If there isn't a route like that, then add a new route with the expression gallery, the target plugin/gallery, and the type set to Internal. The gallery should be accessible with '/gallery' after your forum's link.

    Add Pages to Vanilla with the Basic Pages app

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    @demsley said:
    That's the URL mine is trying to access. Should the Galleries plugin create a folder called /gallery/ in the folder /var/www? Is this a permissions issue on my servers do you think?

    No there is no page needs to be made, the albums and pics get uploaded to the uploads folder in the pic gals folder in that one.

    I would try disable and re enable ? the plugin has a pretty url so it says gallery instead of plugin/Galleries

    so the actual url is plugin/Galleries but the route matches the name /gallery. It can be possible that the route did not take. Disabling and enabling sometimes jolts it to work.

    If you want you can give me temporary access to your server file manager and I can look at it to see what is going on. If you do want me to look at it then send me the login info via PM.

    Otherwise just keep trying. It is not a complicated plugin really, all it is is a page with upload forms and it posts the pic to that page. The trick is getting the urls to work with your set up and I figured that out . Your setup should work without issues.

    I have it installed in 6 forums and they all have either Forum or foro in the url so I had to change them to that but after that everything works as expected.

  • @vrijvlinder I've just upgraded to with a great deal of assistance from @peregrine .
    I subsequently installed the Galleries plugin but had an issue with some albums but not all. On the problem albums I got a 404 not found when clicking on the main thumbnail to display an image full size. The problem is with albums that have names with a space, the url puts an underscore in place when trying to link to the picture but the actual album just has a space so the link doesn't work.

    My question is how best to tackle the problem, in an ideal world it would be nice to allow spaces but if it's not possible how can I stop users using spaces in the first place?

    I've removed the plugin completely then put it back from scratch but not enabled it yet.

  • hgtonighthgtonight ∞ · New Moderator

    You need to rename on upload to either strip illegal characters, OR encode HTML entities.

    Search first

    Check out the Documentation! We are always looking for new content and pull requests.

    Click on insightful, awesome, and funny reactions to thank community volunteers for their valuable posts.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited September 2013


    Yes spaces in names for the albums is not allowed. Because they end up getting %20 between the words and cause a 404.

    I did add a notice by the form to add a new album which says no spaces as seen in this screenshot.
    So people will know not to add spaces.
    You can rename the albums from the your file manager. Just go to the Uploads folder and find the picgal folder, where you will see the albums you created. Just rename them from there.

  • demsleydemsley New
    edited November 2013

    [Split Dammit, refer to Forum Etiquette pls]

    Hi all, I'm back. ...and still not working I'm afraid. I really am confused over this as I think I've followed all instructions completely.

    The plugin folder is called /plugins/Galleries/ as that's what unzipping the download gave, I haven't changed this.

    The site is top level so I've used the gallery.php previously posted by @vrijvlinder

    Clicking on the Gallery link in the menu bar works. I can create a Gallery and add an image. However the same fault occurs when I click the View or Upload More Pictures from GalleryName button.

    The route is set as @Shadowdare suggested. I tried both /plugins/gallery and /plugins/Galleries as the route to no avail.

    The site is http://www.haflingerandpinzgauerclubuk.org/ if anyone could look at it and explain what I'm getting wrong I'd be grateful.



  • The error I get from the above is:

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited November 2013

    @demsley I am sorry this has been a problem for you, please let's start over. Delete the plugin you have and re upload a new copy ,then only replace the gallery.php with the file here .


    You do not need to change anything in the files. Just replace the gallery.php with the one above.

    when you get a 500 error it means something is wrong with the code and the request can't be fulfilled.

    Please do not change anything in the files. Just reinstall the plugin and change the gallery.php with the one in that link. Let me know if it worked. Also do not use other Gallery plugins at the same time.

  • @vrijvlinder

    I really appreciate your support on this. Firstly I've moved the forum so it now resides in http://www.haflingerandpinzgauerclubuk.org/forum/ so that I can use the "normal" version of the plugin. This is served from /var/www/haflinger/forum/

    I've downloaded a complete new Galleries plugin and put it in /var/www/haflinger/forum/plugins/ (see attached)

    I have changed nothing - not even the css yet. I can create and upload an image to a gallery (see attached). I can also view the image,

    I've checked the route and it is plugin/gallery as expected.

    Here's where it goes wrong - clicking on the View or Upload button tries to get to the url: http://www.haflingerandpinzgauerclubuk.org/forum/gallery/Test (Test is the gallery name). It now fails with a redirect as the page does not exist.

    Once again I appreciate the time you've spent trying to sort this out for me.



  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    My computer is crippled and can only use my phone , you need to check to have rewrite URL True in config.php also check in the dashboard routes to make sure the gallery shows. If not there, disable and re enable . Check if route was saved.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited November 2013

    @demsley The url without rewrite url is this


    that means the url below will yield a bonk or a blank page or a 404


    You need to set rewrite url true in the config.php , if the line is not there,put it in yourself. That will fix the issue. Also make sure that the .htaccess file has the /forum rewrite

    $Configuration['Garden']['RewriteUrls'] = TRUE;

    for the .htaccess file

    # Modified
    # If you modify this file then change the above line to: # Modified
       RewriteEngine On
       # Certain hosts may require the following line.
       # If vanilla is in a subfolder then you need to specify it after the /. 
       # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
       RewriteBase /forum
       RewriteCond %{REQUEST_FILENAME} !-d
       RewriteCond %{REQUEST_FILENAME} !-f
       RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
  • Many, many thanks. It will only let me click AWSOME once.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Thanks, I always like it when the problem is totally unrelated to my plugin and can be able to help fix it anyway :)

Sign In or Register to comment.